aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-02-15 11:15:38 +0100
committerKoen Kooi <koen@openembedded.org>2010-02-15 11:15:38 +0100
commitb8c29b12f258838f0dd0b66022de8301e7806aaf (patch)
tree024982b9c0628577d13a206f402fa885af4ae2ca
parent326a2d63b82a20b6d80cef2f11e349886f3390a4 (diff)
downloadopenembedded-b8c29b12f258838f0dd0b66022de8301e7806aaf.tar.gz
python-pygobject-native 2.20: fix configure and convert to new-style staging
-rw-r--r--recipes/python/python-pygobject-native_2.20.0.bb14
1 files changed, 9 insertions, 5 deletions
diff --git a/recipes/python/python-pygobject-native_2.20.0.bb b/recipes/python/python-pygobject-native_2.20.0.bb
index 918ffa2643..409481c2bf 100644
--- a/recipes/python/python-pygobject-native_2.20.0.bb
+++ b/recipes/python/python-pygobject-native_2.20.0.bb
@@ -1,11 +1,11 @@
require python-pygobject_${PV}.bb
+inherit native
+
DEPENDS = "python-native glib-2.0-native"
PARALLEL_MAKE = ""
-inherit native
-
SRC_URI = "\
ftp://ftp.gnome.org/pub/GNOME/sources/pygobject/${MAJ_VER}/pygobject-${PV}.tar.bz2 \
# file://python-path.patch;patch=1 \
@@ -13,7 +13,11 @@ SRC_URI = "\
export GOBJECT_INTROSPECTION_CFLAGS="-pthread -I${STAGING_INCDIR}/gobject-introspection-1.0 -I${STAGING_INCDIR}/glib-2.0 -I${STAGING_LIBDIR}/glib-2.0/include"
-do_stage_append() {
- install -d ${STAGING_BINDIR}
- install -m 0755 gobject/generate-constants ${STAGING_BINDIR}/gobject-generate-constants
+do_configure_prepend() {
+ unset PYTHONPATH
+}
+
+do_install_append() {
+ install -d ${D}${bindir}
+ install -m 0755 gobject/generate-constants ${D}${bindir}/gobject-generate-constants
}