aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2011-02-15 12:21:58 +0100
committerHenning Heinold <heinold@inf.fu-berlin.de>2011-02-15 12:26:16 +0100
commitc8e377aebf7ab50d7af9cb7cbd4f17e4dda58d86 (patch)
treef5c32787d5d3ad19133b5e6cd5a90bb8d22742e6
parentdb341fa90635eeab4a72f51f0d046ae03e9a1edd (diff)
downloadopenembedded-c8e377aebf7ab50d7af9cb7cbd4f17e4dda58d86.tar.gz
libsdl-mixer: fix compiling for angstroem 2008.1
* libtool don't honors AC_CONFIG_AUX_DIRS in this case so not all libtool stuff is deleted, fixed it by copy the stuff from the build-script dir and remove the dir afterwards * bump PR
-rw-r--r--recipes/libsdl/libsdl-mixer/configure.patch22
-rw-r--r--recipes/libsdl/libsdl-mixer_1.2.11.bb10
2 files changed, 29 insertions, 3 deletions
diff --git a/recipes/libsdl/libsdl-mixer/configure.patch b/recipes/libsdl/libsdl-mixer/configure.patch
new file mode 100644
index 0000000000..7cc69e057f
--- /dev/null
+++ b/recipes/libsdl/libsdl-mixer/configure.patch
@@ -0,0 +1,22 @@
+Index: SDL_mixer-1.2.11/configure.in
+===================================================================
+--- SDL_mixer-1.2.11.orig/configure.in 2011-02-15 11:54:23.929086120 +0100
++++ SDL_mixer-1.2.11/configure.in 2011-02-15 11:56:53.745736645 +0100
+@@ -1,6 +1,5 @@
+ dnl Process this file with autoconf to produce a configure script.
+ AC_INIT(README)
+-AC_CONFIG_AUX_DIRS($srcdir/build-scripts)
+
+ dnl Set various version strings - taken gratefully from the GTk sources
+
+@@ -40,10 +39,6 @@
+ AC_SUBST(LT_REVISION)
+ AC_SUBST(LT_AGE)
+
+-dnl Detect the canonical build and host environments
+-AC_CONFIG_AUX_DIRS($srcdir/build-scripts)
+-dnl AC_CANONICAL_HOST
+-
+ dnl Check for tools
+ AC_PROG_LIBTOOL
+ AC_PROG_CC
diff --git a/recipes/libsdl/libsdl-mixer_1.2.11.bb b/recipes/libsdl/libsdl-mixer_1.2.11.bb
index d495503b65..1fc68a4007 100644
--- a/recipes/libsdl/libsdl-mixer_1.2.11.bb
+++ b/recipes/libsdl/libsdl-mixer_1.2.11.bb
@@ -4,10 +4,12 @@ PRIORITY = "optional"
DEPENDS = "virtual/libsdl flac libmikmod libvorbis ${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'libmad', d)}"
LICENSE = "LGPL"
-PR = "r6"
+PR = "r7"
SRC_URI = "http://www.libsdl.org/projects/SDL_mixer/release/SDL_mixer-${PV}.tar.gz \
- file://fix-flac-madness.diff"
+ file://fix-flac-madness.diff \
+ file://configure.patch \
+ "
S = "${WORKDIR}/SDL_mixer-${PV}"
@@ -18,7 +20,7 @@ inherit autotools
# Add support for runtime linking with libmad so we can use that for fixed point MP3 decoding.
# Add support for runtime linking with libtremor so we can use that for fixed point OGG Vorbis decoding.
-EXTRA_AUTORECONF += "--include=acinclude --exclude=autoheader"
+EXTRA_AUTORECONF += "--include=acinclude"
do_configure_prepend () {
# Remove old libtool macros.
@@ -26,6 +28,8 @@ do_configure_prepend () {
for i in ${MACROS}; do
rm -f acinclude/$i
done
+ cp build-scripts/* .
+ rm -rf build-scripts/
export SYSROOT=$PKG_CONFIG_SYSROOT_DIR
}