aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2009-08-27 00:29:56 -0700
committerKhem Raj <raj.khem@gmail.com>2009-08-27 00:29:56 -0700
commitf15dec06d80b480c9c701b653efdaf4c97b73ddc (patch)
treea0e40383f3bd92c275cfd7779bc9588f27e47b66
parent706d50df6018175d6fafd150aaead3e56e5620ac (diff)
parent4e00d90a75f734c1bbf81a26e93e723a85a7329a (diff)
downloadopenembedded-f15dec06d80b480c9c701b653efdaf4c97b73ddc.tar.gz
Merge branch 'org.openembedded.dev' of git@git.openembedded.org:openembedded into org.openembedded.dev
-rw-r--r--recipes/autofs/autofs-4.1.4/Makefile.rules-cross.patch8
-rw-r--r--recipes/autofs/autofs_4.1.4.bb6
2 files changed, 8 insertions, 6 deletions
diff --git a/recipes/autofs/autofs-4.1.4/Makefile.rules-cross.patch b/recipes/autofs/autofs-4.1.4/Makefile.rules-cross.patch
index d8b3692efa..dd54dc187a 100644
--- a/recipes/autofs/autofs-4.1.4/Makefile.rules-cross.patch
+++ b/recipes/autofs/autofs-4.1.4/Makefile.rules-cross.patch
@@ -6,15 +6,15 @@
ifdef DEBUG
-CFLAGS = -O2 -g -DDEBUG
-LDFLAGS = -g
-+CFLAGS += -O2 -g -DDEBUG
-+LDFLAGS += -g
++CFLAGS ?= -O2 -g -DDEBUG
++LDFLAGS ?= -g
STRIP = :
else
-CFLAGS = -O3 -fomit-frame-pointer -Wall
-LDFLAGS = -s
-STRIP = strip --strip-debug
-+CFLAGS += -O3 -fomit-frame-pointer -Wall
-+LDFLAGS += -s
++CFLAGS ?= -O3 -fomit-frame-pointer -Wall
++LDFLAGS ?= -s
+STRIP = ${TARGET_PREFIX}strip --strip-debug
endif
diff --git a/recipes/autofs/autofs_4.1.4.bb b/recipes/autofs/autofs_4.1.4.bb
index d9863ad9dd..2f998ab220 100644
--- a/recipes/autofs/autofs_4.1.4.bb
+++ b/recipes/autofs/autofs_4.1.4.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Kernel based automounter for linux."
SECTION = "base"
LICENSE = "GPL"
-PR = "r2"
+PR = "r3"
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/daemons/autofs/v4/autofs-${PV}.tar.bz2 \
${KERNELORG_MIRROR}/pub/linux/daemons/autofs/v4/autofs-4.1.4-misc-fixes.patch;patch=1 \
@@ -20,7 +20,9 @@ inherit autotools update-rc.d
INITSCRIPT_NAME = "autofs"
INITSCRIPT_PARAMS = "defaults"
-EXTRA_OEMAKE="TARGET_PREFIX=${TARGET_PREFIX}"
+# FIXME: modules/Makefile has crappy rules that don't obey LDFLAGS
+CFLAGS += "${LDFLAGS}"
+EXTRA_OEMAKE = "STRIP=/bin/true"
PARALLEL_MAKE = ""
do_configure_prepend () {