aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Garman <sgarman@zenlinux.com>2010-04-09 19:20:56 +0000
committerHolger Hans Peter Freyther <zecke@selfish.org>2010-04-15 10:59:09 +0200
commitf994e036d74f481b2a673774853a959b363324d3 (patch)
tree442a55bf0e15b44728caa080aa5142f566e4707b
parent67cae2cf064970365337525db76467d7dd121fdd (diff)
downloadopenembedded-f994e036d74f481b2a673774853a959b363324d3.tar.gz
libnids: Upgrade to 1.24
* Addresses CVE-2010-0751 * Use new-style checksums Signed-off-by: Scott Garman <sgarman@zenlinux.com> Signed-off-by: Holger Hans Peter Freyther <zecke@selfish.org>
-rw-r--r--recipes/libnids/libnids-1.24/configure.patch60
-rw-r--r--recipes/libnids/libnids_1.24.bb26
2 files changed, 86 insertions, 0 deletions
diff --git a/recipes/libnids/libnids-1.24/configure.patch b/recipes/libnids/libnids-1.24/configure.patch
new file mode 100644
index 0000000000..332675b057
--- /dev/null
+++ b/recipes/libnids/libnids-1.24/configure.patch
@@ -0,0 +1,60 @@
+--- tmp/base/libnids-1.18-r0/libnids-1.18/configure.in Tue Oct 14 18:40:00 2003
++++ libnids-1.18/configure.in Wed Nov 5 16:01:27 2003
+@@ -65,12 +65,15 @@
+ ;;
+ *)
+ AC_MSG_RESULT($withval)
+- if test -f $withval/pcap.h -a -f $withval/libpcap.a; then
+- owd=`pwd`
+- if cd $withval; then withval=`pwd`; cd $owd; fi
+- PCAP_CFLAGS="-I$withval -I$withval/bpf"
+- PCAPLIB="-L$withval -lpcap"
+- else
++ for i in $withval $withval/include $withval/lib $withval/include/pcap; do
++ if test -f $i/pcap.h; then
++ PCAP_CFLAGS="-I$i -I$i/bpf"
++ fi
++ if test -f $i/libpcap.a; then
++ PCAPLIB="-L$i -lpcap"
++ fi
++ done
++ if test -z "$PCAP_CFLAGS" -o -z "$PCAPLIB"; then
+ AC_ERROR(pcap.h or libpcap.a not found in $withval)
+ fi
+ ;;
+@@ -127,20 +130,22 @@
+ ;;
+ *)
+ AC_MSG_RESULT($withval)
+- if test -f $withval/include/libnet.h -a -f $withval/lib/libnet.a -a -f $withval/libnet-config ; then
+- owd=`pwd`
+- if cd $withval; then withval=`pwd`; cd $owd; fi
+- LNET_CFLAGS="-I$withval/include `$withval/libnet-config --defines`"
+- LNETLIB="-L$withval/lib -lnet"
+- elif test -f $withval/include/libnet.h -a -f $withval/src/libnet.a; then
+- owd=`pwd`
+- if cd $withval; then withval=`pwd`; cd $owd; fi
+- LNET_CFLAGS="-I$withval/include"
+- LNETLIB="-L$withval/src -lnet"
+- else
+- echo "A working combination of libnet.h, libnet.a and libnet-config not found in $withval; get libnet from www.packetfactory.net/projects/libnet and reinstall"
+- AC_ERROR(libnet)
++ LNETC="`which libnet-config 2>/dev/null`"
++ for i in $withval $withval/include $withval/lib $withval/bin; do
++ if test -f $i/libnet-config; then
++ LNETC"=$i/libnet-config"
++ fi
++ if test -f $i/libnet.h; then
++ LNET_CFLAGS="-I$i"
++ fi
++ if test -f $i/libnet.a; then
++ LNETLIB="-L$i -lnet"
++ fi
++ done
++ if test -z "$LNET_CFLAGS" -o -z "$LNETLIB" -o -z "$LNETC"; then
++ AC_ERROR([libnet not found in $withval])
+ fi
++ LNET_CFLAGS="$LNET_CFLAGS `$LNETC --defines`"
+ ;;
+ esac ],
+ [ if test "x"$LIBNET_VER = "x"-1 ; then
diff --git a/recipes/libnids/libnids_1.24.bb b/recipes/libnids/libnids_1.24.bb
new file mode 100644
index 0000000000..09702a94d1
--- /dev/null
+++ b/recipes/libnids/libnids_1.24.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "Libnids performs assembly of TCP segments \
+into TCP streams, IP defragmentation, and TCP port \
+scan detection."
+LICENSE = "GPL"
+SECTION = "libs"
+DEPENDS = "libnet-1.0 libpcap"
+PR = "r0"
+
+SRC_URI = "\
+ ${SOURCEFORGE_MIRROR}/libnids/libnids-${PV}.tar.gz;name=libnids \
+ file://configure.patch;patch=1"
+SRC_URI[libnids.md5sum] = "72d37c79c85615ffe158aa524d649610"
+SRC_URI[libnids.sha256sum] = "314b4793e0902fbf1fdb7fb659af37a3c1306ed1aad5d1c84de6c931b351d359"
+
+inherit autotools
+
+EXTRA_OECONF = "\
+ --with-libpcap=${STAGING_LIBDIR}/.. \
+ --with-libnet=${STAGING_LIBDIR}/.. \
+"
+EXTRA_OEMAKE = "'install_prefix=${D}'"
+
+do_stage () {
+ install -m 0644 ${S}/src/nids.h ${STAGING_INCDIR}/
+ oe_libinstall -a -C src libnids ${STAGING_LIBDIR}
+}