aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-02-15 11:16:40 +0100
committerKoen Kooi <koen@openembedded.org>2010-02-15 11:16:40 +0100
commitfeb019622e464739efe440ecabc2f9e5b5477682 (patch)
tree368cf894ccccb7dbd67bbd052d53872850f0828e
parentb8c29b12f258838f0dd0b66022de8301e7806aaf (diff)
downloadopenembedded-feb019622e464739efe440ecabc2f9e5b5477682.tar.gz
e*bbclass: run autopoint in configure
* remove config.rpath stuff from recipes
-rw-r--r--classes/e.bbclass8
-rw-r--r--classes/efl.bbclass2
-rw-r--r--recipes/e17/e-module.inc1
-rw-r--r--recipes/e17/places_svn.bb1
4 files changed, 7 insertions, 5 deletions
diff --git a/classes/e.bbclass b/classes/e.bbclass
index fca9aa0010..5db0749eef 100644
--- a/classes/e.bbclass
+++ b/classes/e.bbclass
@@ -10,12 +10,16 @@ ARM_INSTRUCTION_SET = "arm"
inherit autotools pkgconfig binconfig
do_prepsources () {
- make clean distclean || true
+ make clean distclean || true
}
addtask prepsources after do_patch before do_configure
+do_configure_prepend() {
+ autopoint || touch config.rpath
+}
+
do_configure_append() {
- find ${S} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
+ find ${S} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
}
export CURL_CONFIG = "${STAGING_BINDIR_CROSS}/curl-config"
diff --git a/classes/efl.bbclass b/classes/efl.bbclass
index 805422fdf4..14334571ce 100644
--- a/classes/efl.bbclass
+++ b/classes/efl.bbclass
@@ -17,7 +17,7 @@ inherit autotools
AUTOTOOLS_STAGE_PKGCONFIG = "1"
do_configure_prepend() {
- touch config.rpath
+ autopoint || touch config.rpath
}
do_install_prepend () {
diff --git a/recipes/e17/e-module.inc b/recipes/e17/e-module.inc
index d275b0a267..a620746b32 100644
--- a/recipes/e17/e-module.inc
+++ b/recipes/e17/e-module.inc
@@ -13,4 +13,3 @@ EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc"
FILES_${PN} += "${libdir}/enlightenment/modules/${PN}"
FILES_${PN}-dbg += "${libdir}/enlightenment/modules/${PN}/*/.debug"
-
diff --git a/recipes/e17/places_svn.bb b/recipes/e17/places_svn.bb
index bcaf144ae7..13ef860f77 100644
--- a/recipes/e17/places_svn.bb
+++ b/recipes/e17/places_svn.bb
@@ -10,7 +10,6 @@ SRC_URI += "file://fix-api.diff;patch=1;maxrev=39830;pnum=3"
do_configure_prepend() {
sed -i -e /po/d -e /AM_GNU_GETTEXT/d configure.ac
sed -i -e s:\ po::g Makefile.am
- touch ${S}/config.rpath
}
# Calls /usr/bin/eject for media