aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulian_chu <julian_chu@openmoko.com>2008-09-18 17:06:10 +0800
committerHolger Hans Peter Freyther <zecke@selfish.org>2008-10-15 20:37:47 +0200
commitaed1f4ad670dbcc2bd47a83c7968d1a883acdfab (patch)
tree1ff7a3246573767b6f55e54613918f2525eaf24c
parent7a4455feaa846794343594376bcedadb008cbd38 (diff)
downloadopenembedded-aed1f4ad670dbcc2bd47a83c7968d1a883acdfab.tar.gz
[connman] Upgrade connman to latest revision.
connman use native _nm_ to list symbols. However, it may cause problem when cross compiling. Add a patch to use cross-tools if set host=$SOMETHING when do configure.
-rw-r--r--conf/distro/include/sane-srcrevs.inc2
-rw-r--r--packages/connman/connman_git.bb6
-rw-r--r--packages/connman/files/use_nm_in_cross_compiling.patch17
3 files changed, 21 insertions, 4 deletions
diff --git a/conf/distro/include/sane-srcrevs.inc b/conf/distro/include/sane-srcrevs.inc
index db099de4c2..bfac652d55 100644
--- a/conf/distro/include/sane-srcrevs.inc
+++ b/conf/distro/include/sane-srcrevs.inc
@@ -22,7 +22,7 @@ SRCREV_pn-clutter-box2d = "3197"
SRCREV_pn-clutter-cairo ?= "3210"
SRCREV_pn-clutter-gst ?= "3188"
SRCREV_pn-clutter ?= "3240"
-SRCREV_pn-connman ?= "f9f84ccfa0cd338e2de22878f277352436570b83"
+SRCREV_pn-connman ?= "103706c4f4da0c89f8b6f33cccdc3149f4ecc09a"
SRCREV_pn-contact ?= "1410"
SRCREV_pn-dasher-gpe ?= "1251"
SRCREV_pn-dbus-c++-native ?= "13131"
diff --git a/packages/connman/connman_git.bb b/packages/connman/connman_git.bb
index afe28a0e19..4cc0209856 100644
--- a/packages/connman/connman_git.bb
+++ b/packages/connman/connman_git.bb
@@ -1,7 +1,7 @@
HOMEPAGE = "http://www.moblin.org/projects/projects_connman.php"
SUMMARY = "Moblin Connection Manager"
PV = "0.0+git${SRCREV}"
-PR = "r4"
+PR = "r4.01"
S = "${WORKDIR}/git"
LICENSE = "GPL"
@@ -13,7 +13,7 @@ EXTRA_OECONF += " \
ac_cv_path_DHCLIENT=/sbin/dhclient "
SRC_URI = "git://moblin.org/repos/projects/connman.git;proto=http \
- file://connman-build-and-work.patch;patch=1 \
+ file://use_nm_in_cross_compiling.patch;patch=1\
file://connman "
INITSCRIPT_NAME = "connman"
@@ -41,7 +41,7 @@ FILES_${PN}-dbg += "${libdir}/connman/plugins/.debug \
python populate_packages_prepend() {
plugin_dir = bb.data.expand('${libdir}/connman/plugins/', d)
plugin_name = bb.data.expand('${PN}-plugin-%s', d)
- do_split_packages(d, plugin_dir, '^lib(.*).so$', plugin_name, '${PN} plugin for %s', extra_depends='' )
+ do_split_packages(d, plugin_dir, '^(.*).so$', plugin_name, '${PN} plugin for %s', extra_depends='' )
}
do_stage() {
diff --git a/packages/connman/files/use_nm_in_cross_compiling.patch b/packages/connman/files/use_nm_in_cross_compiling.patch
new file mode 100644
index 0000000000..e9f2b29e3e
--- /dev/null
+++ b/packages/connman/files/use_nm_in_cross_compiling.patch
@@ -0,0 +1,17 @@
+Index: git/src/Makefile.am
+===================================================================
+--- git.orig/src/Makefile.am 2008-09-18 16:48:44.000000000 +0800
++++ git/src/Makefile.am 2008-09-18 16:49:54.000000000 +0800
+@@ -44,7 +44,11 @@
+ MAINTAINERCLEANFILES = Makefile.in
+
+ connman.exp:
+- nm -B *.o | awk '{ print $$3 }' | sort -u | grep -E -e '^connman_' > $@
++ if test -n $$host ; then \
++ $(host)-nm -B *.o | awk '{ print $$3 }' | sort -u | grep -E -e '^connman_' > $@ ;\
++ else \
++ nm -B *.o | awk '{ print $$3 }' | sort -u | grep -E -e '^connman_' > $@ ;\
++ fi
+
+ connman.ver: connman.exp
+ echo "{ global:" > $@