aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCliff Brake <cbrake@bec-systems.com>2010-09-23 10:59:11 -0400
committerCliff Brake <cbrake@bec-systems.com>2010-09-23 10:59:11 -0400
commit213d9c4dcd946eedbf25bf0abf70d79d51b27f14 (patch)
tree6c6eb67efc99b2a39c9ab630b459db90135c9baa
parent9695735f3bcce8a45419053c184271aa3e3e1d1a (diff)
parent1fc3b764c48de84260fe9560c66930388cbaa058 (diff)
downloadopenembedded-213d9c4dcd946eedbf25bf0abf70d79d51b27f14.tar.gz
Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into org.openembedded.dev
-rw-r--r--conf/distro/include/preferred-shr-versions.inc2
-rw-r--r--lib/oe/patch.py1
-rw-r--r--recipes/binutils/binutils-2.20.1/binutils-2.19.1-ld-sysroot.patch36
-rw-r--r--recipes/binutils/binutils_2.20.1.bb3
-rw-r--r--recipes/libnl/files/dont-link-libnl-from-sysroot.patch26
-rw-r--r--recipes/libnl/libnl_1.1.bb6
6 files changed, 68 insertions, 6 deletions
diff --git a/conf/distro/include/preferred-shr-versions.inc b/conf/distro/include/preferred-shr-versions.inc
index 0319ec316a..3bfb1fe5bf 100644
--- a/conf/distro/include/preferred-shr-versions.inc
+++ b/conf/distro/include/preferred-shr-versions.inc
@@ -46,7 +46,7 @@ PREFERRED_VERSION_openssl-native = "1.0.0a"
UDEV_GE_141 = "1"
PREFERRED_VERSION_postgresql = "8.4.4"
-ANGSTROM_QT_VERSION ?= "4.6.3+4.7.0-beta2"
+ANGSTROM_QT_VERSION ?= "4.7.0"
PREFERRED_VERSION_qt4-tools-native = "${ANGSTROM_QT_VERSION}"
PREFERRED_VERSION_qt4-tools-sdk = "${ANGSTROM_QT_VERSION}"
PREFERRED_VERSION_qt4-embedded = "${ANGSTROM_QT_VERSION}"
diff --git a/lib/oe/patch.py b/lib/oe/patch.py
index d7f4ccb9e9..05abccfc1c 100644
--- a/lib/oe/patch.py
+++ b/lib/oe/patch.py
@@ -192,6 +192,7 @@ class QuiltTree(PatchSet):
def Clean(self):
try:
self._runcmd(["pop", "-a", "-f"])
+ oe.path.remove(os.path.join(self.dir, "patches","series"))
except Exception:
pass
self.initialized = True
diff --git a/recipes/binutils/binutils-2.20.1/binutils-2.19.1-ld-sysroot.patch b/recipes/binutils/binutils-2.20.1/binutils-2.19.1-ld-sysroot.patch
new file mode 100644
index 0000000000..b252196a79
--- /dev/null
+++ b/recipes/binutils/binutils-2.20.1/binutils-2.19.1-ld-sysroot.patch
@@ -0,0 +1,36 @@
+http://sourceware.org/bugzilla/show_bug.cgi?id=10340
+
+Signed-off-by: Sven Rebhan <odinshorse@googlemail.com>
+
+Always try to prepend the sysroot prefix to absolute filenames first.
+
+--- a/ld/ldfile.c 2009-06-14 12:46:19.000000000 +0200
++++ b/ld/ldfile.c.new 2009-06-14 12:46:04.000000000 +0200
+@@ -308,18 +308,24 @@
+ directory first. */
+ if (! entry->is_archive)
+ {
+- if (entry->sysrooted && IS_ABSOLUTE_PATH (entry->filename))
++ /* For absolute pathnames, try to always open the file in the
++ sysroot first. If this fails, try to open the file at the
++ given location. */
++ entry->sysrooted = is_sysrooted_pathname(entry->filename, FALSE);
++ if (IS_ABSOLUTE_PATH (entry->filename) && ld_sysroot && ! entry->sysrooted)
+ {
+ char *name = concat (ld_sysroot, entry->filename,
+ (const char *) NULL);
+ if (ldfile_try_open_bfd (name, entry))
+ {
+ entry->filename = name;
++ entry->sysrooted = TRUE;
+ return TRUE;
+ }
+ free (name);
+ }
+- else if (ldfile_try_open_bfd (entry->filename, entry))
++
++ if (ldfile_try_open_bfd (entry->filename, entry))
+ {
+ entry->sysrooted = IS_ABSOLUTE_PATH (entry->filename)
+ && is_sysrooted_pathname (entry->filename, TRUE);
+
diff --git a/recipes/binutils/binutils_2.20.1.bb b/recipes/binutils/binutils_2.20.1.bb
index d75dbb2569..c2a5dab174 100644
--- a/recipes/binutils/binutils_2.20.1.bb
+++ b/recipes/binutils/binutils_2.20.1.bb
@@ -1,7 +1,7 @@
require binutils.inc
LICENSE = "GPLv3"
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.2"
#COMPATIBLE_TARGET_SYS = "."
@@ -15,6 +15,7 @@ SRC_URI = "\
file://binutils-uclibc-gas-needs-libm.patch \
file://binutils-x86_64_i386_biarch.patch \
file://libtool-update.patch \
+ file://binutils-2.19.1-ld-sysroot.patch \
"
SRC_URI_append_nios2 =" \
diff --git a/recipes/libnl/files/dont-link-libnl-from-sysroot.patch b/recipes/libnl/files/dont-link-libnl-from-sysroot.patch
new file mode 100644
index 0000000000..beb63617ac
--- /dev/null
+++ b/recipes/libnl/files/dont-link-libnl-from-sysroot.patch
@@ -0,0 +1,26 @@
+Index: libnl-1.1/src/Makefile
+===================================================================
+--- libnl-1.1.orig/src/Makefile 2008-01-14 07:48:45.000000000 -0800
++++ libnl-1.1/src/Makefile 2010-09-22 14:58:46.820826001 -0700
+@@ -13,7 +13,7 @@ ifeq ($(shell [ ! -r ../Makefile.opts ]
+ include ../Makefile.opts
+ endif
+
+-LDFLAGS += -L../lib -lnl utils.o
++LDFLAGS += ../lib/libnl.so utils.o
+ CIN := $(wildcard nl-*.c) $(wildcard genl-*.c) $(wildcard nf-*.c)
+ TOOLS := $(CIN:%.c=%)
+
+Index: libnl-1.1/tests/Makefile
+===================================================================
+--- libnl-1.1.orig/tests/Makefile 2008-01-14 07:48:45.000000000 -0800
++++ libnl-1.1/tests/Makefile 2010-09-22 14:58:46.820826001 -0700
+@@ -13,7 +13,7 @@ ifeq ($(shell [ ! -r ../Makefile.opts ]
+ include ../Makefile.opts
+ endif
+
+-LDFLAGS += -L../lib -lnl ../src/utils.o
++LDFLAGS += ../lib/libnl.so ../src/utils.o
+ CIN := $(wildcard test-*.c)
+ TOOLS := $(CIN:%.c=%)
+
diff --git a/recipes/libnl/libnl_1.1.bb b/recipes/libnl/libnl_1.1.bb
index 06059ca85d..f1b2a9d485 100644
--- a/recipes/libnl/libnl_1.1.bb
+++ b/recipes/libnl/libnl_1.1.bb
@@ -3,10 +3,7 @@ SECTION = "libs/network"
LICENSE = "LGPL"
HOMEPAGE = "http://www.infradead.org/~tgr/libnl/"
-# If you get errors like : undefined reference to `nl_handle_alloc
-# do a bitbake -c clean libnl2
-
-PR = "r3"
+PR = "r4"
inherit autotools pkgconfig
@@ -18,6 +15,7 @@ SRC_URI = "\
file://fix-includes.patch \
file://respect-ldflags.patch \
file://netlink-local-fix.patch \
+ file://dont-link-libnl-from-sysroot.patch \
"