aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteffen Sledz <sledz@dresearch.de>2010-09-24 11:18:02 +0200
committerSteffen Sledz <sledz@dresearch.de>2010-09-24 11:59:54 +0200
commit49ac8666c30a8cc3e2f6955b1b450934eb67abd5 (patch)
tree755d8bd11253812146c17962a12053f91342ce02
parent3195eec237c597d340eb5fa60aeea281cfe758c7 (diff)
downloadopenembedded-49ac8666c30a8cc3e2f6955b1b450934eb67abd5.tar.gz
libatasmart-0.13: resolve cross compile problem
* This patch solves a cross/native compile problem: | ./strpool atasmart.c atasmart.strpool.c | ./strpool: ./strpool: cannot execute binary file Signed-off-by: Steffen Sledz <sledz@dresearch.de> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Paul Menzel <paulepanter@users.sourceforge.net>
-rw-r--r--recipes/devicekit/libatasmart-0.13/strpool.patch11
-rw-r--r--recipes/devicekit/libatasmart_0.13.bb12
2 files changed, 14 insertions, 9 deletions
diff --git a/recipes/devicekit/libatasmart-0.13/strpool.patch b/recipes/devicekit/libatasmart-0.13/strpool.patch
new file mode 100644
index 0000000000..e9f6ab31e5
--- /dev/null
+++ b/recipes/devicekit/libatasmart-0.13/strpool.patch
@@ -0,0 +1,11 @@
+--- git/Makefile.am.orig 2010-09-24 11:03:40.917602895 +0200
++++ git/Makefile.am 2010-09-24 11:07:04.145852660 +0200
+@@ -81,5 +81,8 @@
+ BUILT_SOURCES = \
+ atasmart.strpool.c
+
++strpool: $(strpool_SOURCES)
++ $(BUILD_CC) -o $@ $?
++
+ atasmart.strpool.c: atasmart.c strpool
+ $(top_builddir)/strpool $< $@
diff --git a/recipes/devicekit/libatasmart_0.13.bb b/recipes/devicekit/libatasmart_0.13.bb
index 992ff3ebbe..4a4986effe 100644
--- a/recipes/devicekit/libatasmart_0.13.bb
+++ b/recipes/devicekit/libatasmart_0.13.bb
@@ -2,20 +2,14 @@ DEPENDS = "udev"
LICENSE = "LGPL"
SRCREV = "a80d7d5c25e88adea7b8e843cdb57143e6cfb46b"
-SRC_URI = "git://git.0pointer.de/libatasmart.git;protocol=git"
+SRC_URI = "git://git.0pointer.de/libatasmart.git;protocol=git \
+ file://strpool.patch"
S = "${WORKDIR}/git"
-PR = "r1"
+PR = "r2"
inherit autotools lib_package
-do_compile_prepend() {
- rm strpool -f
- ${BUILD_CC} -o strpool strpool.c
- chmod +x strpool
-}
-
do_install_append() {
sed -i -e s://:/:g -e s:${base_libdir}/libudev.la:-ludev:g ${D}${libdir}/libatasmart.la
}
-