aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPierluigi Passaro <pierluigi.passaro@phoenixsoftware.it>2010-10-04 11:54:59 +0200
committerKoen Kooi <koen@openembedded.org>2010-10-04 14:01:42 +0200
commitc31636c6a910d246e00a955bdc88014cab6b565b (patch)
tree221ae33339e01af4dad59617023cbbb7efbb4b23
parent0849a1dca4f1963c58f73712dc0f731873762dea (diff)
downloadopenembedded-c31636c6a910d246e00a955bdc88014cab6b565b.tar.gz
mysql5: adopt to new style sysroot
Signed-off-by: Koen Kooi <koen@openembedded.org>
-rw-r--r--recipes/mysql/mysql5_5.1.40.inc6
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes/mysql/mysql5_5.1.40.inc b/recipes/mysql/mysql5_5.1.40.inc
index aa609479e6..1ebfe8d002 100644
--- a/recipes/mysql/mysql5_5.1.40.inc
+++ b/recipes/mysql/mysql5_5.1.40.inc
@@ -3,7 +3,7 @@ HOMEPAGE = "http://www.mysql.com/"
SECTION = "libs"
LICENSE = "GPL"
DEPENDS = "ncurses"
-PR = "r4"
+PR = "r5"
SRC_URI = "http://downloads.mysql.com/archives/mysql-5.1/mysql-${PV}.tar.gz \
file://configure.in.patch \
@@ -46,8 +46,8 @@ SYSROOT_PREPROCESS_FUNCS += "mysql5_sysroot_preprocess"
# We need to append this so it runs *after* binconfig's preprocess function
mysql5_sysroot_preprocess () {
- sed -i -es,^pkgincludedir=\'/usr/include/mysql\',pkgincludedir=\'${STAGING_INCDIR}\', ${STAGING_BINDIR_CROSS}/mysql_config
- sed -i -es,^pkglibdir=\'/usr/lib/mysql\',pkglibdir=\'${STAGING_LIBDIR}\', ${STAGING_BINDIR_CROSS}/mysql_config
+ sed -i -es,^pkgincludedir=\'/usr/include/mysql\',pkgincludedir=\'${STAGING_INCDIR}\', ${SYSROOT_DESTDIR}${STAGING_BINDIR_CROSS}/mysql_config
+ sed -i -es,^pkglibdir=\'/usr/lib/mysql\',pkglibdir=\'${STAGING_LIBDIR}\', ${SYSROOT_DESTDIR}${STAGING_BINDIR_CROSS}/mysql_config
}
do_install() {