aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucian Ion <lucian_ion_2000@yahoo.com>2009-06-08 01:42:54 +0000
committerHolger Hans Peter Freyther <zecke@selfish.org>2010-01-28 14:19:49 +0100
commit44d263d7bf5d07a3c992ea44a4cbb39f73f3a5c5 (patch)
tree261ee90d847337d7d242b32eaca18f078bbf181a
parent5951a93a820197fdca5318cec9fca1b121697530 (diff)
downloadopenembedded-44d263d7bf5d07a3c992ea44a4cbb39f73f3a5c5.tar.gz
update apr util library to version 1.3.7
+[http://www.apache.org/dist/apr/apr-util-1.3.7.tar.gz] +md5=0a6802ef6d874db645150ae4a75f41fa +sha256=fadd6a0c55596b2c21375942e3acefc33715e647ed4770dc398d08d8783a39e0 + >From de8a775aac5dda2997cb8c132070b12cb2e13dd0 Mon Sep 17 00:00:00 2001 From: Lucian Ion <lucian_ion_2000@yahoo.com> Date: Mon, 8 Jun 2009 12:14:21 +0100 Subject: [PATCH] apr-util update to version 1.3.7 - new recipe
-rw-r--r--recipes/apr/apr-util_1.3.7.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes/apr/apr-util_1.3.7.bb b/recipes/apr/apr-util_1.3.7.bb
new file mode 100644
index 0000000000..6b2e9cc903
--- /dev/null
+++ b/recipes/apr/apr-util_1.3.7.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "Apache Portable Runtime (APR) companion library"
+SECTION = "libs"
+DEPENDS = "apr expat gdbm"
+LICENSE = "Apache License, Version 2.0"
+
+PR = "r5"
+
+SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.gz \
+ file://configfix.patch;patch=1 \
+ file://configure_fixes.patch;patch=1"
+
+EXTRA_OECONF = "--with-apr=${STAGING_BINDIR_CROSS}/apr-1-config \
+ --with-dbm=gdbm \
+ --with-gdbm=${STAGING_DIR_HOST}${layout_prefix} \
+ --without-sqlite2 \
+ --without-sqlite3 \
+ --with-expat=${STAGING_DIR_HOST}${layout_prefix}"
+
+
+inherit autotools_stage lib_package binconfig
+
+OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'"
+
+do_configure_prepend() {
+ cp ${STAGING_DATADIR}/apr/apr_rules.mk ${S}/build/rules.mk
+ echo "AC_PROG_LIBTOOL" >> ${S}/configure.in
+}
+
+do_configure_append() {
+ sed -i -e s:apr_builders=/usr/share/build-1:apr_builders=${STAGING_DATADIR}/build-1:g ${S}/build/rules.mk
+ sed -i /^LIBTOOL/d ${S}/build/rules.mk
+ echo LIBTOOL="${STAGING_BINDIR_NATIVE}/${TARGET_PREFIX}libtool --tag=CC" >> ${S}/build/rules.mk
+}
+