aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Lübbe <jluebbe@debian.org>2009-02-26 17:19:17 +0000
committerJan Luebbe <jluebbe@debian.org>2009-03-26 11:29:53 +0100
commit03b733eb9e71661ba69225098c1628b4d25aa6e1 (patch)
tree3de53cece577fbe37e1f27b4c736d0f2fd0e6634
parent45fa1f32b30ce6d36e0085f255e9a943e5bf51c7 (diff)
downloadopenembedded-03b733eb9e71661ba69225098c1628b4d25aa6e1.tar.gz
menu-freesmartphone: create a simple XDG menu for illume which shows all applications
-rw-r--r--recipes/freesmartphone/menu-freesmartphone.bb18
-rw-r--r--recipes/freesmartphone/menu-freesmartphone/applications.menu17
2 files changed, 35 insertions, 0 deletions
diff --git a/recipes/freesmartphone/menu-freesmartphone.bb b/recipes/freesmartphone/menu-freesmartphone.bb
new file mode 100644
index 0000000000..2d1f6145c4
--- /dev/null
+++ b/recipes/freesmartphone/menu-freesmartphone.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "XDG menu file for the freesmartphone.org project"
+LICENSE = "PD"
+PV = "0.1"
+PR = "r0"
+
+SRC_URI = "file://applications.menu"
+
+do_install() {
+ install -d ${D}/${sysconfdir}/xdg/menus
+ install -m 644 ${WORKDIR}/applications.menu ${D}/${sysconfdir}/xdg/menus/
+}
+
+RPROVIDES_${PN} = "e-wm-menu"
+CONFFILES_${PN} = "${sysconfdir}/xdg/menus/applications.menu"
+FILES_${PN} = "${sysconfdir}/xdg/menus/applications.menu"
+
+PACKAGE_ARCH_${PN} = "all"
+
diff --git a/recipes/freesmartphone/menu-freesmartphone/applications.menu b/recipes/freesmartphone/menu-freesmartphone/applications.menu
new file mode 100644
index 0000000000..58b6c1c96b
--- /dev/null
+++ b/recipes/freesmartphone/menu-freesmartphone/applications.menu
@@ -0,0 +1,17 @@
+<?xml version="1.0"?>
+<!DOCTYPE Menu PUBLIC "-//freedesktop//DTD Menu 1.0//EN" "http://standards.freedesktop.org/menu-spec/menu-1.0.dtd">
+<Menu>
+ <Name>Applications</Name>
+
+ <!-- Read standard .directory and .desktop file locations -->
+ <DefaultAppDirs>/usr/share/applications</DefaultAppDirs>
+ <DefaultDirectoryDirs/>
+
+ <Menu>
+ <Name>All</Name>
+ <Include>
+ <All/>
+ </Include>
+ </Menu>
+</Menu>
+