aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChia-I Wu <olv@openmoko.com>2008-11-18 16:50:36 +0800
committerJohn Lee <john_lee@openmoko.org>2009-01-12 14:35:40 +0800
commit5c898f6e20d5d27a1cc0747746d35f706fd6dfff (patch)
treeec24779b5ed382cbd3077595cd54a62fad4741c7
parentdcd288f6787e3e4210efebd79acf047f7be505a1 (diff)
downloadopenembedded-5c898f6e20d5d27a1cc0747746d35f706fd6dfff.tar.gz
fastboot: task-base.bb, task-boot.bb: customize openmoko distro more.john_lee/fastboot-devel
Remove avahi. Use hardcoded packages for bluetooth and usbgadget support. Use initscripts-openmoko instead of initscripts. Increase the PRs of task-base and task-boot to reflect the changes.
-rw-r--r--conf/distro/include/angstrom-2007-for-openmoko.inc2
-rw-r--r--conf/distro/openmoko.conf13
-rw-r--r--packages/tasks/task-base.bb2
-rw-r--r--packages/tasks/task-boot.bb2
4 files changed, 15 insertions, 4 deletions
diff --git a/conf/distro/include/angstrom-2007-for-openmoko.inc b/conf/distro/include/angstrom-2007-for-openmoko.inc
index 34fbc52cfe..5675e75723 100644
--- a/conf/distro/include/angstrom-2007-for-openmoko.inc
+++ b/conf/distro/include/angstrom-2007-for-openmoko.inc
@@ -230,8 +230,6 @@ DISTRO_EXTRA_RRECOMMENDS += " \
kernel-module-vfat \
kernel-module-ext2 \
kernel-module-af-packet \
- avahi-daemon \
- avahi-autoipd \
openssh-sftp-server \
"
diff --git a/conf/distro/openmoko.conf b/conf/distro/openmoko.conf
index 7e7aa1d022..844bb29e4b 100644
--- a/conf/distro/openmoko.conf
+++ b/conf/distro/openmoko.conf
@@ -30,6 +30,19 @@ DISTRO_FEED_URI ?= "http://downloads.openmoko.org/repository/testing"
AB_DEPLOY_EXTRA ?= ""
DEPLOY_DIR_IMAGE = "${DEPLOY_DIR}/images/${MACHINE_ARCH}/${AB_DEPLOY_EXTRA}"
+DISTRO_INITSCRIPTS = "initscripts-openmoko"
+
+# We try to minimize the distro features in the default image.
+DISTRO_FEATURES = "wifi ppp alsa ext2 vfat usbhost"
+
+# Some features (bluetooth, usbgadget) include packages we do not like.
+# Pick some of the packages manually.
+DISTRO_EXTRA_RDEPENDS += " \
+ bluez-utils \
+ bluez-utils-compat \
+ kernel-module-g-ether \
+ "
+
# 2.18 seems to break badly on 64-bit systems
PREFERRED_VERSION_binutils ?= "2.17.50.0.12"
PREFERRED_VERSION_binutils-cross ?= "2.17.50.0.12"
diff --git a/packages/tasks/task-base.bb b/packages/tasks/task-base.bb
index 220ae48168..60f0908c21 100644
--- a/packages/tasks/task-base.bb
+++ b/packages/tasks/task-base.bb
@@ -1,5 +1,5 @@
DESCRIPTION = "Merge machine and distro options to create a basic machine task/package"
-PR = "r76"
+PR = "r77"
inherit task
diff --git a/packages/tasks/task-boot.bb b/packages/tasks/task-boot.bb
index 46f80f0d59..7cd347284e 100644
--- a/packages/tasks/task-boot.bb
+++ b/packages/tasks/task-boot.bb
@@ -1,5 +1,5 @@
DESCRIPTION = "Basic task to get a device booting"
-PR = "r45"
+PR = "r46"
inherit task