aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-07-14 12:58:31 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-07-18 10:18:48 +0200
commit06b5d4e3322c71df19712be8f1fffde29a509015 (patch)
tree059ff0805054e0b4ccbfcfebbd94223cd6e3912b
parent328c6515cb4363a4fc8233ac4e649c5661e9155c (diff)
downloadopenembedded-06b5d4e3322c71df19712be8f1fffde29a509015.tar.gz
linux(-kexecboot)_git: bump SRCREV, add fix for bug 16310
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes/kexecboot/linux-kexecboot/fix.module.loading.16310.patch28
-rw-r--r--recipes/kexecboot/linux-kexecboot_git.bb3
-rw-r--r--recipes/linux/linux/fix.module.loading.16310.patch28
-rw-r--r--recipes/linux/linux_git.bb3
4 files changed, 60 insertions, 2 deletions
diff --git a/recipes/kexecboot/linux-kexecboot/fix.module.loading.16310.patch b/recipes/kexecboot/linux-kexecboot/fix.module.loading.16310.patch
new file mode 100644
index 0000000000..cd2fa6ca2d
--- /dev/null
+++ b/recipes/kexecboot/linux-kexecboot/fix.module.loading.16310.patch
@@ -0,0 +1,28 @@
+From 1cb348e903f81bb34abe00c9a06b42009ddca819 Mon Sep 17 00:00:00 2001
+From: Michal Marek <mmarek@suse.cz>
+Date: Fri, 2 Jul 2010 13:17:37 +0200
+Subject: [PATCH] arm: Build with -fno-dwarf2-cfi-asm
+
+Commit d0679c7 restricted this workaround to powerpc only, but it turns
+out that ARM needs it as well. Fixes
+https://bugzilla.kernel.org/show_bug.cgi?id=16310 .
+
+Reported-by: Robert Nelson <robertcnelson@gmail.com>
+Signed-off-by: Michal Marek <mmarek@suse.cz>
+
+diff --git a/arch/arm/Makefile b/arch/arm/Makefile
+index 64ba313..862d4ba 100644
+--- a/arch/arm/Makefile
++++ b/arch/arm/Makefile
+@@ -21,6 +21,11 @@ GZFLAGS :=-9
+ # Explicitly specifiy 32-bit ARM ISA since toolchain default can be -mthumb:
+ KBUILD_CFLAGS +=$(call cc-option,-marm,)
+
++# FIXME: the module load should be taught about the additional relocs
++# generated by this.
++# revert to pre-gcc-4.4 behaviour of .eh_frame
++KBUILD_CFLAGS += $(call cc-option,-fno-dwarf2-cfi-asm)
++
+ # Do not use arch/arm/defconfig - it's always outdated.
+ # Select a platform tht is kept up-to-date
+ KBUILD_DEFCONFIG := versatile_defconfig
diff --git a/recipes/kexecboot/linux-kexecboot_git.bb b/recipes/kexecboot/linux-kexecboot_git.bb
index 869fcc7231..d53baf9842 100644
--- a/recipes/kexecboot/linux-kexecboot_git.bb
+++ b/recipes/kexecboot/linux-kexecboot_git.bb
@@ -1,10 +1,11 @@
require linux-kexecboot.inc
KERNEL_RELEASE = "2.6.35-rc5"
-SRCREV = "1c5474a65bf15a4cb162dfff86d6d0b5a08a740c"
+SRCREV = "f469461df6ff822f71b8737bda86eea20f16ff93"
PV = "${KERNEL_RELEASE}+gitr${SRCPV}"
SRC_URI += "git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux-2.6.git;protocol=git;branch=master \
+ file://fix.module.loading.16310.patch \
file://defconfig"
S = "${WORKDIR}/git"
diff --git a/recipes/linux/linux/fix.module.loading.16310.patch b/recipes/linux/linux/fix.module.loading.16310.patch
new file mode 100644
index 0000000000..cd2fa6ca2d
--- /dev/null
+++ b/recipes/linux/linux/fix.module.loading.16310.patch
@@ -0,0 +1,28 @@
+From 1cb348e903f81bb34abe00c9a06b42009ddca819 Mon Sep 17 00:00:00 2001
+From: Michal Marek <mmarek@suse.cz>
+Date: Fri, 2 Jul 2010 13:17:37 +0200
+Subject: [PATCH] arm: Build with -fno-dwarf2-cfi-asm
+
+Commit d0679c7 restricted this workaround to powerpc only, but it turns
+out that ARM needs it as well. Fixes
+https://bugzilla.kernel.org/show_bug.cgi?id=16310 .
+
+Reported-by: Robert Nelson <robertcnelson@gmail.com>
+Signed-off-by: Michal Marek <mmarek@suse.cz>
+
+diff --git a/arch/arm/Makefile b/arch/arm/Makefile
+index 64ba313..862d4ba 100644
+--- a/arch/arm/Makefile
++++ b/arch/arm/Makefile
+@@ -21,6 +21,11 @@ GZFLAGS :=-9
+ # Explicitly specifiy 32-bit ARM ISA since toolchain default can be -mthumb:
+ KBUILD_CFLAGS +=$(call cc-option,-marm,)
+
++# FIXME: the module load should be taught about the additional relocs
++# generated by this.
++# revert to pre-gcc-4.4 behaviour of .eh_frame
++KBUILD_CFLAGS += $(call cc-option,-fno-dwarf2-cfi-asm)
++
+ # Do not use arch/arm/defconfig - it's always outdated.
+ # Select a platform tht is kept up-to-date
+ KBUILD_DEFCONFIG := versatile_defconfig
diff --git a/recipes/linux/linux_git.bb b/recipes/linux/linux_git.bb
index 04257534bf..231383e972 100644
--- a/recipes/linux/linux_git.bb
+++ b/recipes/linux/linux_git.bb
@@ -1,10 +1,11 @@
require linux.inc
KERNEL_RELEASE = "2.6.35-rc5"
-SRCREV = "1c5474a65bf15a4cb162dfff86d6d0b5a08a740c"
+SRCREV = "f469461df6ff822f71b8737bda86eea20f16ff93"
PV = "${KERNEL_RELEASE}+gitr${SRCPV}"
SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux-2.6.git;protocol=git;branch=master \
+ file://fix.module.loading.16310.patch \
file://defconfig"
S = "${WORKDIR}/git"