aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-09-13 19:52:36 +0000
committerKhem Raj <raj.khem@gmail.com>2010-09-14 14:07:03 -0700
commit134e90b90d6172449d4875fc031fc5e6cb51167f (patch)
treee7b6cbb368a01b62d666ad1acaaabc65dfb89256
parenteb9f07b76ebf47d1696b525438b872065a0d74a8 (diff)
downloadopenembedded-134e90b90d6172449d4875fc031fc5e6cb51167f.tar.gz
eglibc: Do not specify ports multiple time to --enable-addons
* While building for mips64 I noticed a problem where eglibc configure did not get the mips sub arch correct during configure the reason was we had ports twice in configure commandline which ran a ports configure twice and appended machines multiple times to paths which then were wrong and it failed to select correct ABI to compile eglibc Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes/eglibc/eglibc_2.10.bb2
-rw-r--r--recipes/eglibc/eglibc_2.11.bb2
-rw-r--r--recipes/eglibc/eglibc_2.12.bb2
-rw-r--r--recipes/eglibc/eglibc_2.9.bb2
-rw-r--r--recipes/eglibc/eglibc_svn.bb2
5 files changed, 5 insertions, 5 deletions
diff --git a/recipes/eglibc/eglibc_2.10.bb b/recipes/eglibc/eglibc_2.10.bb
index c2ed43585b..c10db7d86f 100644
--- a/recipes/eglibc/eglibc_2.10.bb
+++ b/recipes/eglibc/eglibc_2.10.bb
@@ -48,7 +48,7 @@ python __anonymous () {
EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
--without-cvs --disable-profile --disable-debug --without-gd \
--enable-clocale=gnu \
- --enable-add-ons=${GLIBC_ADDONS},ports \
+ --enable-add-ons=${GLIBC_ADDONS} \
--with-headers=${STAGING_INCDIR} \
--without-selinux \
${GLIBC_EXTRA_OECONF}"
diff --git a/recipes/eglibc/eglibc_2.11.bb b/recipes/eglibc/eglibc_2.11.bb
index 5d9b8e2d45..bece90f756 100644
--- a/recipes/eglibc/eglibc_2.11.bb
+++ b/recipes/eglibc/eglibc_2.11.bb
@@ -48,7 +48,7 @@ python __anonymous () {
EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
--without-cvs --disable-profile --disable-debug --without-gd \
--enable-clocale=gnu \
- --enable-add-ons=${GLIBC_ADDONS},ports \
+ --enable-add-ons=${GLIBC_ADDONS} \
--with-headers=${STAGING_INCDIR} \
--without-selinux \
${GLIBC_EXTRA_OECONF}"
diff --git a/recipes/eglibc/eglibc_2.12.bb b/recipes/eglibc/eglibc_2.12.bb
index c6b0131591..0d08c561ea 100644
--- a/recipes/eglibc/eglibc_2.12.bb
+++ b/recipes/eglibc/eglibc_2.12.bb
@@ -48,7 +48,7 @@ python __anonymous () {
EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
--without-cvs --disable-profile --disable-debug --without-gd \
--enable-clocale=gnu \
- --enable-add-ons=${GLIBC_ADDONS},ports \
+ --enable-add-ons=${GLIBC_ADDONS} \
--with-headers=${STAGING_INCDIR} \
--without-selinux \
${GLIBC_EXTRA_OECONF}"
diff --git a/recipes/eglibc/eglibc_2.9.bb b/recipes/eglibc/eglibc_2.9.bb
index a7d9aedea1..f83861e55c 100644
--- a/recipes/eglibc/eglibc_2.9.bb
+++ b/recipes/eglibc/eglibc_2.9.bb
@@ -48,7 +48,7 @@ python __anonymous () {
EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
--without-cvs --disable-profile --disable-debug --without-gd \
--enable-clocale=gnu \
- --enable-add-ons=${GLIBC_ADDONS},ports \
+ --enable-add-ons=${GLIBC_ADDONS} \
--with-headers=${STAGING_INCDIR} \
--without-selinux \
${GLIBC_EXTRA_OECONF}"
diff --git a/recipes/eglibc/eglibc_svn.bb b/recipes/eglibc/eglibc_svn.bb
index 0621279032..3b7fb849e3 100644
--- a/recipes/eglibc/eglibc_svn.bb
+++ b/recipes/eglibc/eglibc_svn.bb
@@ -46,7 +46,7 @@ python __anonymous () {
EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
--without-cvs --disable-profile --disable-debug --without-gd \
--enable-clocale=gnu \
- --enable-add-ons=${GLIBC_ADDONS},ports \
+ --enable-add-ons=${GLIBC_ADDONS} \
--with-headers=${STAGING_INCDIR} \
--without-selinux \
${GLIBC_EXTRA_OECONF}"