aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-01-13 11:41:26 +0100
committerKoen Kooi <koen@openembedded.org>2010-01-13 11:44:56 +0100
commit2153070fc51bbb6006c022e8836a46e2a511306f (patch)
tree18000e72de953f9b54ae07fe758431133b2a6ae2
parent76fb223eef55411b6f23b959e35466bd8d943f71 (diff)
downloadopenembedded-2153070fc51bbb6006c022e8836a46e2a511306f.tar.gz
bzip2: add missing symlink
-rw-r--r--recipes/bzip2/bzip2_1.0.5.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/recipes/bzip2/bzip2_1.0.5.bb b/recipes/bzip2/bzip2_1.0.5.bb
index bbb2012c39..dadffde80f 100644
--- a/recipes/bzip2/bzip2_1.0.5.bb
+++ b/recipes/bzip2/bzip2_1.0.5.bb
@@ -1,12 +1,12 @@
DESCRIPTION = "Very high-quality data compression program"
SECTION = "console/utils"
-PR = "r1"
+PR = "r2"
LICENSE = "bzip2"
SRC_URI = "http://www.bzip.org/${PV}/bzip2-${PV}.tar.gz \
file://bzip2-1.0.5-autoconfiscated.patch;patch=1"
-inherit autotools_stage pkgconfig
+inherit autotools pkgconfig
do_configure_prepend () {
if test -f LICENSE ; then sh ./autogen.sh ; fi
@@ -15,6 +15,7 @@ do_configure_prepend () {
do_install_append () {
mv ${D}${bindir}/bunzip2 ${D}${bindir}/bunzip2.${PN}
mv ${D}${bindir}/bzcat ${D}${bindir}/bzcat.${PN}
+ ln -sf libbz2.so.1.0.5 ${D}${libdir}/libbz2.so.1.0
}
PACKAGES =+ "libbz2"