aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteve Sakoman <steve@sakoman.com>2009-08-08 15:12:29 -0700
committerKoen Kooi <koen@openembedded.org>2009-08-09 16:16:39 +0200
commit2215a06d3408f57cf4edd5a072132333111c3830 (patch)
tree473be452e5a0aa208d996ab033637b610b009f62
parent48d4343132b55bb3ae2bd06e602660fc0f584b2f (diff)
downloadopenembedded-2215a06d3408f57cf4edd5a072132333111c3830.tar.gz
gnome-python: add 2.26.1
-rw-r--r--conf/checksums.ini4
-rw-r--r--recipes/gnome/gnome-python_2.26.1.bb22
2 files changed, 26 insertions, 0 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index 9e549ae362..a962f796de 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -8574,6 +8574,10 @@ sha256=ebf81236c9405ba47e7a21767c2372f2c3abb44cc671bac8662d2aeb3e746dbc
md5=02054115dc86617da2a80eb87a1f988b
sha256=559b5d857b4fbc31418bc677f3391182ba1c357cabb8dfee04a1e709a7a63d01
+[http://ftp.gnome.org/pub/GNOME/sources/gnome-python/2.26/gnome-python-2.26.1.tar.bz2]
+md5=e5dcae40b2c291126843680dbed924a8
+sha256=ede0203f1eec22b3ed4a91c7b769e437859e5bc4b89a8f8e80b3f7ca62317098
+
[http://ftp.gnome.org/pub/GNOME/sources/gnome-python-desktop/2.23/gnome-python-desktop-2.23.0.tar.bz2]
md5=d8f8e61d99402e8b0a82d3c8d6e873be
sha256=7ad66f99a1bad1ae0bbb02bd7a7cf8ed17fdc3fd104fa5c68e04961459ad5c50
diff --git a/recipes/gnome/gnome-python_2.26.1.bb b/recipes/gnome/gnome-python_2.26.1.bb
new file mode 100644
index 0000000000..1027437b7a
--- /dev/null
+++ b/recipes/gnome/gnome-python_2.26.1.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "GNOME Python miscellaneous bindings"
+LICENSE = "LGPL"
+DEPENDS = "libgnomeui pyorbit python-pygtk"
+RDEPENDS = "pyorbit"
+
+inherit gnome distutils-base pkgconfig
+
+do_configure() {
+ sed -i -e s:'`$PKG_CONFIG --variable=defsdir pygtk-2.0`':\"${STAGING_DATADIR}/pygtk/2.0/defs\":g ${S}/configure.ac
+ export HOST_SYS=${HOST_SYS}
+ export BUILD_SYS=${BUILD_SYS}
+ autotools_do_configure
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+FILES_${PN} += "${datadir}"
+FILES_${PN}-dbg += "${libdir}/gnome-vfs-2.0/modules/.debug"
+
+