aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-03-19 11:31:00 +0100
committerKoen Kooi <koen@openembedded.org>2009-03-19 11:31:00 +0100
commit2612236bf6abf8ebd98fac5359f3b1b830404ed5 (patch)
treec256773e2d4d59c44b39b9d9988fa2d6aee1692c
parentf608c18453c4a9b39cd755f77c6652bbba741afb (diff)
downloadopenembedded-2612236bf6abf8ebd98fac5359f3b1b830404ed5.tar.gz
abiword: update to 2.6.8
-rw-r--r--conf/checksums.ini4
-rw-r--r--recipes/abiword/abiword-embedded_2.6.8.bb8
-rw-r--r--recipes/abiword/abiword-plugins_2.6.8.bb61
-rw-r--r--recipes/abiword/abiword_2.6.8.bb8
4 files changed, 81 insertions, 0 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index af7d67a058..5afb025312 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -1222,6 +1222,10 @@ sha256=d3ddfd3dbd20ed9bb35dceb06a55ec13d66acb1c3fce28976a8d10929c39a194
md5=3bf973c5a1446ef3eaf980724821d6e9
sha256=ec561e865387fa0a108ac135fc39ef0aa18e0dddd99f1f92749f67b029ba30eb
+[http://www.abiword.org/downloads/abiword/2.6.8/source/abiword-plugins-2.6.8.tar.gz]
+md5=421c49723e209c971ddb0798c1b313a9
+sha256=151517ae94e0f4c26370f31c903078bd0561b8088a63b532408ca128f0e65448
+
[http://www.labyrinth.net.au/~trandor/abuse/files/abuse_sdl-0.7.0.tar.bz2]
md5=59ea4498886642aa975f04233cc92558
sha256=bda8a3c42733853444e1d4bee16e85990b78c2eaafc4b26e0769be2e14dab931
diff --git a/recipes/abiword/abiword-embedded_2.6.8.bb b/recipes/abiword/abiword-embedded_2.6.8.bb
new file mode 100644
index 0000000000..98e69515fa
--- /dev/null
+++ b/recipes/abiword/abiword-embedded_2.6.8.bb
@@ -0,0 +1,8 @@
+require abiword-2.5.inc
+
+EXTRA_OECONF += "--enable-embedded"
+
+S = "${WORKDIR}/abiword-${PV}"
+
+RCONFLICTS = "abiword"
+RPROVIDES += "abiword"
diff --git a/recipes/abiword/abiword-plugins_2.6.8.bb b/recipes/abiword/abiword-plugins_2.6.8.bb
new file mode 100644
index 0000000000..01778ae10f
--- /dev/null
+++ b/recipes/abiword/abiword-plugins_2.6.8.bb
@@ -0,0 +1,61 @@
+DESCRIPTION = "AbiWord is a free word processing program similar to Microsoft(r) Word"
+HOMEPAGE = "http://www.abiword.org"
+SECTION = "x11/office"
+LICENSE = "GPLv2"
+DEPENDS = "asio boost loudmouth libwpd librsvg goffice poppler libglade"
+RDEPENDS = "abiword"
+
+
+SRC_URI = "http://www.abiword.org/downloads/abiword/${PV}/source/abiword-plugins-${PV}.tar.gz \
+ http://www.abiword.org/downloads/abiword/${PV}/source/abiword-${PV}.tar.gz \
+# file://abiword-cxx-for-ld-fix.patch;patch=1 \
+ "
+
+DEFAULT_PREFERENCE = "2"
+
+inherit autotools
+
+PARALLEL_MAKE=""
+
+#export LDFLAGS += " -lstdc++ "
+
+EXTRA_OECONF = " --enable-shared=yes \
+ --enable-static \
+ --without-libwmf \
+ --without-inter7eps \
+ --with-abiword=${WORKDIR}/abiword-${PV} \
+ --with-boost=${STAGING_DIR_HOST} \
+ --with-boost-thread=boost_thread-mt \
+ "
+
+PACKAGES_DYNAMIC = "abiword-plugin-*"
+
+python populate_packages_prepend () {
+ abiword_libdir = bb.data.expand('${libdir}/abiword-2.6/plugins', d)
+ do_split_packages(d, abiword_libdir, '^libAbi(.*)\.so$', 'abiword-plugin-%s', 'Abiword plugin for %s', extra_depends='')
+ do_split_packages(d, abiword_libdir, '^libAbi(.*)\.la$', 'abiword-plugin-%s-dev', 'Abiword plugin for %s', extra_depends='')
+
+ metapkg = "abiword-plugins"
+ bb.data.setVar('ALLOW_EMPTY_' + metapkg, "1", d)
+ bb.data.setVar('FILES_' + metapkg, "", d)
+ blacklist = [ 'abiword-plugins-dbg', 'abiword-plugins', 'abiword-plugins-doc', 'abiword-plugins-dev', 'abiword-plugins-locale' ]
+ metapkg_rdepends = []
+ packages = bb.data.getVar('PACKAGES', d, 1).split()
+ for pkg in packages[1:]:
+ if not pkg in blacklist and not pkg in metapkg_rdepends:
+ print "Modifying ", pkg
+ metapkg_rdepends.append(pkg)
+ bb.data.setVar('RDEPENDS_' + metapkg, ' '.join(metapkg_rdepends), d)
+ bb.data.setVar('DESCRIPTION_' + metapkg, 'abiword-plugin meta package', d)
+ packages.append(metapkg)
+ bb.data.setVar('PACKAGES', ' '.join(packages), d)
+}
+
+
+PACKAGES =+ "abiword-plugin-collab-glade"
+
+FILES_abiword-plugin-collab-glade += "${datadir}"
+RDEPENDS_abiword-plugin-collab-glade = "abiword-plugin-collab"
+
+FILES_${PN}-dbg += "${libdir}/abiword-2.6/plugins/.debug"
+
diff --git a/recipes/abiword/abiword_2.6.8.bb b/recipes/abiword/abiword_2.6.8.bb
new file mode 100644
index 0000000000..d05fc77f70
--- /dev/null
+++ b/recipes/abiword/abiword_2.6.8.bb
@@ -0,0 +1,8 @@
+require abiword-2.5.inc
+
+RCONFLICTS = "abiword-embedded"
+
+FILES_${PN} += "${datadir}/mime-info"
+FILES_abiword-strings += "${datadir}/abiword-${SHRT_VER}/strings"
+FILES_abiword-systemprofiles += "${datadir}/abiword-${SHRT_VER}/system.profile*"
+