aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2010-10-17 12:20:18 +0000
committerHenning Heinold <heinold@inf.fu-berlin.de>2010-10-19 16:16:29 +0200
commit29ed2a74ff82f77a683ba3361db3a87d68329298 (patch)
tree7c5687e5409a88ecc0d7ca101621a95d314ecc03
parent52fad6de31e86a6a91be768cdee9b461e40520f6 (diff)
downloadopenembedded-29ed2a74ff82f77a683ba3361db3a87d68329298.tar.gz
libsdl-directfb: update to 1.2.14
Changes since v1: * removed patches. * use autoreconf to update libtool etc. * inherit lib_package * dropped some unused configure options. * ran oe-stylize.py Signed-off-by: Andreas Oberritter <obi@opendreambox.org> Acked-by:: Henning Heinold <heinold@inf.fu-berlin.de>
-rw-r--r--recipes/libsdl/libsdl-directfb_1.2.14.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/recipes/libsdl/libsdl-directfb_1.2.14.bb b/recipes/libsdl/libsdl-directfb_1.2.14.bb
new file mode 100644
index 0000000000..045600d16d
--- /dev/null
+++ b/recipes/libsdl/libsdl-directfb_1.2.14.bb
@@ -0,0 +1,49 @@
+DESCRIPTION = "Simple DirectMedia Layer (DirectFB and Framebuffer support)"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "LGPL"
+DEPENDS = "alsa-lib directfb"
+PROVIDES = "virtual/libsdl"
+
+SRC_URI = "http://www.libsdl.org/release/SDL-${PV}.tar.gz"
+SRC_URI[md5sum] = "e52086d1b508fa0b76c52ee30b55bec4"
+SRC_URI[sha256sum] = "5d927e287034cb6bb0ebccfa382cb1d185cb113c8ab5115a0759798642eed9b6"
+
+S = "${WORKDIR}/SDL-${PV}"
+
+inherit autotools lib_package binconfig pkgconfig
+
+EXTRA_OECONF = " \
+ --disable-arts \
+ --disable-diskaudio \
+ --disable-esd \
+ --disable-esd-shared \
+ --disable-esdtest \
+ --enable-input-events \
+ --disable-input-tslib \
+ --disable-mintaudio \
+ --disable-nas \
+ --disable-nasm \
+ --disable-video-dga \
+ --disable-video-dummy \
+ --enable-video-directfb \
+ --enable-video-fbcon \
+ --disable-video-opengl \
+ --disable-video-picogui \
+ --disable-video-ps2gs \
+ --disable-video-ps3 \
+ --disable-video-qtopia \
+ --disable-video-x11 \
+"
+EXTRA_AUTORECONF += "--include=acinclude"
+
+# Skip autoheader, because it must not overwrite SDL_config.h.in.
+export AUTOHEADER = "true"
+
+do_configure_prepend () {
+ # Remove old libtool macros.
+ MACROS="libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4"
+ for i in ${MACROS}; do
+ rm acinclude/$i
+ done
+}