aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoger Monk <r-monk@ti.com>2010-09-30 11:21:41 +0100
committerKoen Kooi <koen@openembedded.org>2010-09-30 13:20:27 +0200
commit34f607042e0eb96f0d8120f7810e5dd38574ecf7 (patch)
treea5654261f593e45002b8f40e64c7c55d4e3b26fe
parentf1069136b98118c5f0f89c6e8521ae7c10db6ff0 (diff)
downloadopenembedded-34f607042e0eb96f0d8120f7810e5dd38574ecf7.tar.gz
qt-embedded-widgets-demo: import from arago
Signed-off-by: Roger Monk <r-monk@ti.com> Signed-off-by: Koen Kooi <k-kooi@ti.com>
-rw-r--r--recipes/ti/qt-embedded-widgets-demo_1.1.bb23
-rw-r--r--recipes/ti/qt-embedded-widgets-demo_1.2.bb22
2 files changed, 45 insertions, 0 deletions
diff --git a/recipes/ti/qt-embedded-widgets-demo_1.1.bb b/recipes/ti/qt-embedded-widgets-demo_1.1.bb
new file mode 100644
index 0000000000..9805783d53
--- /dev/null
+++ b/recipes/ti/qt-embedded-widgets-demo_1.1.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Qt Catalog Embedded Widget Demo"
+HOMEPAGE = "https://gforge01.dal.design.ti.com/gf/project/qtembwidget/"
+LICENSE = "Embedded Widgets Demo License Agreement"
+PRIORITY = "optional"
+
+PR = "r0"
+
+SRC_URI = "https://gforge.ti.com/gf/download/frsrelease/338/3627/qt-embedded-widget-demo-v${PV}.tar.gz"
+
+SRC_URI[md5sum] = "9b67430fa9a2f5cbe7f26140a61ee784"
+SRC_URI[sha256sum] = "8b077a0c337e77656173ddf70db7475785d51ccffa87c04a71be62fb68fba277"
+
+S = "${WORKDIR}/qtembwidget"
+
+inherit qt4e
+
+do_install() {
+ install -d ${D}/${bindir}
+ install -m 0755 ${S}/examples/catalog_ti/catalog_ti ${D}/${bindir}/emb_widget
+}
+
+RRECOMMENDS_${PN} = "qt4-embedded-plugin-mousedriver-tslib"
+
diff --git a/recipes/ti/qt-embedded-widgets-demo_1.2.bb b/recipes/ti/qt-embedded-widgets-demo_1.2.bb
new file mode 100644
index 0000000000..375aa5b046
--- /dev/null
+++ b/recipes/ti/qt-embedded-widgets-demo_1.2.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Qt Catalog Embedded Widget Demo"
+HOMEPAGE = "https://gforge.ti.com/gf/project/qt-emb-demos/"
+LICENSE = "Embedded Widgets Demo License Agreement"
+PRIORITY = "optional"
+
+PR = "r1"
+
+SRC_URI = "https://gforge.ti.com/gf/download/frsrelease/342/3644/qt-embedded-widget-demo-v${PV}.tar.gz"
+SRC_URI[md5sum] = "2749d6a0d4ca2a03a763cd1c20b6d178"
+SRC_URI[sha256sum] = "078dd2b3c3e5cccbfefe483d6aa8088c4d14ec9f373c047f8106a72bcfd98535"
+
+S = "${WORKDIR}/qtembwidget"
+
+inherit qt4e
+
+do_install() {
+ install -d ${D}/${bindir}
+ install -m 0755 ${S}/examples/catalog_ti/catalog_ti ${D}/${bindir}/emb_widget
+}
+
+RRECOMMENDS_${PN} = "qt4-embedded-plugin-mousedriver-tslib"
+