aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2009-05-20 23:30:56 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2009-05-20 23:30:59 -0300
commit36d5b6464b18caf961faf61b2f8a4732e40a15f9 (patch)
treecb58e7112020d7fecd0bef28648820a81626c8d4
parenta009dcf2dce41b7028ccc6a3a2d3fd7d49733613 (diff)
downloadopenembedded-36d5b6464b18caf961faf61b2f8a4732e40a15f9.tar.gz
cups: use INC_PR due cups.inc being used in many recipes
To be easier to update the recipes we use a INC_PR in cups.inc that is included in all PR fields in all recipes. Since currently the oldest revision was 'r6' INC_PR starts in 'r7'. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes/cups/cups.inc3
-rw-r--r--recipes/cups/cups_1.1.23.bb2
-rw-r--r--recipes/cups/cups_1.2.12.bb2
-rw-r--r--recipes/cups/cups_1.2.7.bb2
-rw-r--r--recipes/cups/cups_1.3.8.bb2
5 files changed, 6 insertions, 5 deletions
diff --git a/recipes/cups/cups.inc b/recipes/cups/cups.inc
index 56450f78fe..cbec781881 100644
--- a/recipes/cups/cups.inc
+++ b/recipes/cups/cups.inc
@@ -3,6 +3,8 @@ SECTION = "console/utils"
LICENSE = "GPL LGPL"
DEPENDS = "gnutls jpeg dbus dbus-glib libpng zlib fakeroot-native"
+INC_PR = "r7"
+
SRC_URI = "ftp://ftp.easysw.com/pub/cups/${PV}/cups-${PV}-source.tar.bz2 \
"
@@ -89,4 +91,3 @@ FILES_${PN} += "${datadir}/doc/cups/images \
${datadir}/doc/cups/*.css \
${datadir}/icons/ \
"
-
diff --git a/recipes/cups/cups_1.1.23.bb b/recipes/cups/cups_1.1.23.bb
index d6f0de8d7b..bc1053cd9e 100644
--- a/recipes/cups/cups_1.1.23.bb
+++ b/recipes/cups/cups_1.1.23.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "An Internet printing system for Unix."
SECTION = "console/utils"
LICENSE = "GPL LGPL"
DEPENDS = "openssl jpeg libpng zlib fakeroot-native"
-PR = "r6"
+PR = "${INC_PR}.1"
SRC_URI = "ftp://ftp3.easysw.com/pub/cups/${PV}/cups-${PV}-source.tar.bz2 \
file://strftime_fix.patch;patch=1"
diff --git a/recipes/cups/cups_1.2.12.bb b/recipes/cups/cups_1.2.12.bb
index 4f7d0d49b6..773f97e101 100644
--- a/recipes/cups/cups_1.2.12.bb
+++ b/recipes/cups/cups_1.2.12.bb
@@ -1,2 +1,2 @@
require cups.inc
-PR = "r2"
+PR = "${INC_PR}.1"
diff --git a/recipes/cups/cups_1.2.7.bb b/recipes/cups/cups_1.2.7.bb
index 8559bfcf8e..7084032662 100644
--- a/recipes/cups/cups_1.2.7.bb
+++ b/recipes/cups/cups_1.2.7.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "An Internet printing system for Unix."
SECTION = "console/utils"
LICENSE = "GPL LGPL"
DEPENDS = "gnutls jpeg dbus dbus-glib libpng zlib fakeroot-native"
-PR = "r1"
+PR = "${INC_PR}.1"
SRC_URI = "ftp://ftp3.easysw.com/pub/cups/${PV}/cups-${PV}-source.tar.bz2 \
"
diff --git a/recipes/cups/cups_1.3.8.bb b/recipes/cups/cups_1.3.8.bb
index 79cbc32715..c921133c5d 100644
--- a/recipes/cups/cups_1.3.8.bb
+++ b/recipes/cups/cups_1.3.8.bb
@@ -1,7 +1,7 @@
require cups.inc
SRC_URI += "file://use_echo_only_in_init.patch;patch=1"
-PR = "r2"
+PR = "${INC_PR}.1"
DEFAULT_PREFERENCE = "-1"