aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoman I Khimov <khimov@altell.ru>2010-08-20 16:35:29 +0400
committerRoman I Khimov <khimov@altell.ru>2010-08-22 20:09:30 +0400
commit41a480ab2c55179f2eead9bb2929eca9df24d4ca (patch)
treed487333108786e651e9a9f45967b33bb84975358
parent2f60953b76ae9d2a129785d05e92a62075b8a1ef (diff)
downloadopenembedded-41a480ab2c55179f2eead9bb2929eca9df24d4ca.tar.gz
xtables-addons: add version 1.28
Signed-off-by: Roman I Khimov <khimov@altell.ru>
-rw-r--r--recipes/xtables-addons/xtables-addons.inc30
-rw-r--r--recipes/xtables-addons/xtables-addons_1.26.bb33
-rw-r--r--recipes/xtables-addons/xtables-addons_1.28.bb11
3 files changed, 44 insertions, 30 deletions
diff --git a/recipes/xtables-addons/xtables-addons.inc b/recipes/xtables-addons/xtables-addons.inc
new file mode 100644
index 0000000000..6b723d210e
--- /dev/null
+++ b/recipes/xtables-addons/xtables-addons.inc
@@ -0,0 +1,30 @@
+DESCRIPTION = "Xtables-addons contains a set of possibly useful but not included in the mainline kernel nefilter extensions"
+LICENSE = "GPLv2"
+DEPENDS = "virtual/kernel iptables"
+RDEPENDS_${PN} += "kernel update-modules"
+PROVIDES += "ipset ipset-modules"
+RPROVIDES_${PN} += "ipset ipset-modules"
+
+INC_PR = "r0"
+
+SRC_URI = " \
+ ${SOURCEFORGE_MIRROR}/project/${PN}/Xtables-addons/${PV}/${PN}-${PV}.tar.bz2 \
+ "
+inherit autotools module-base
+
+EXTRA_OECONF = "--with-kbuild=${STAGING_KERNEL_DIR}"
+
+FILES_${PN} += "${base_libdir}/modules"
+FILES_${PN}-dbg += "${libexecdir}/xtables/.debug/"
+
+pkg_postinst_${PN} () {
+ if [ -n "$D" ]; then
+ exit 1
+ fi
+ depmod -a
+ update-modules || true
+}
+
+pkg_postrm_${PN} () {
+ update-modules || true
+} \ No newline at end of file
diff --git a/recipes/xtables-addons/xtables-addons_1.26.bb b/recipes/xtables-addons/xtables-addons_1.26.bb
index 057e3dec56..fe7a1cd7a6 100644
--- a/recipes/xtables-addons/xtables-addons_1.26.bb
+++ b/recipes/xtables-addons/xtables-addons_1.26.bb
@@ -1,33 +1,6 @@
-DESCRIPTION = "Xtables-addons contains a set of possibly useful but not included in the mainline kernel nefilter extensions"
-LICENSE = "GPLv2"
-DEPENDS = "virtual/kernel iptables"
-RDEPENDS_${PN} += "kernel update-modules"
-PROVIDES += "ipset ipset-modules"
-RPROVIDES_${PN} += "ipset ipset-modules"
+include xtables-addons.inc
-PR = "r0"
+PR = "${INC_PR}.0"
-SRC_URI = " \
- ${SOURCEFORGE_MIRROR}/project/${PN}/Xtables-addons/${PV}/${PN}-${PV}.tar.bz2 \
- "
SRC_URI[md5sum] = "6091032318ee7fb46d82dec9ae5ae422"
-SRC_URI[sha256sum] = "b05adfc676d5eb5e58c4d273677725d35248c4cb30859a3a53045d03818f591e"
-
-inherit autotools module-base
-
-EXTRA_OECONF = "--with-kbuild=${STAGING_KERNEL_DIR}"
-
-FILES_${PN} += "${base_libdir}/modules"
-FILES_${PN}-dbg += "${libexecdir}/xtables/.debug/"
-
-pkg_postinst_${PN} () {
- if [ -n "$D" ]; then
- exit 1
- fi
- depmod -a
- update-modules || true
-}
-
-pkg_postrm_${PN} () {
- update-modules || true
-} \ No newline at end of file
+SRC_URI[sha256sum] = "b05adfc676d5eb5e58c4d273677725d35248c4cb30859a3a53045d03818f591e" \ No newline at end of file
diff --git a/recipes/xtables-addons/xtables-addons_1.28.bb b/recipes/xtables-addons/xtables-addons_1.28.bb
new file mode 100644
index 0000000000..4a94810c34
--- /dev/null
+++ b/recipes/xtables-addons/xtables-addons_1.28.bb
@@ -0,0 +1,11 @@
+include xtables-addons.inc
+
+PR = "${INC_PR}.0"
+
+do_unpack[depends] += "xz-native:do_populate_staging"
+
+SRC_URI = " \
+ ${SOURCEFORGE_MIRROR}/project/${PN}/Xtables-addons/${PV}/${PN}-${PV}.tar.xz \
+ "
+SRC_URI[md5sum] = "b94fe23370a1294b985e9a06a0f9d129"
+SRC_URI[sha256sum] = "3d06d6d1d8b8adeae7c9edee20ffd3f2a754eb0b187e8b9f397666e26a7dbbcc" \ No newline at end of file