aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Schmidt <stefan@datenfreihafen.org>2010-10-28 15:50:55 +0200
committerStefan Schmidt <stefan@datenfreihafen.org>2010-10-28 18:23:48 +0200
commit44bc5a638065a7ac705c2d7f21c256c7ebda516c (patch)
treec7fd34147e99125e04800fa8795067cb7e5d91fd
parenta3871c241633708f52b64abb1df01a290d4b77ff (diff)
downloadopenembedded-44bc5a638065a7ac705c2d7f21c256c7ebda516c.tar.gz
cacaoh-*native: Try to be libtool version agnostic.
Based on a suggestion from Enrico Scholz we should use libtool --mode=install for install libtool stuff. This fixes a regresion for me that came in with commit 93c4d9d84096c817e74abf3f4c02f82af4c95178 It is working fine again now with libtool 2.2.6b (angstrom-2008), testing with libtool 2.4 would be appreciated. Signed-off-by: Stefan Schmidt <stefan@datenfreihafen.org>
-rw-r--r--recipes/cacao/cacaoh-cldc-native_0.98.bb2
-rw-r--r--recipes/cacao/cacaoh-native.inc4
-rw-r--r--recipes/cacao/cacaoh-openjdk-native.inc2
-rw-r--r--recipes/cacao/cacaoh-openjdk-native_0.99.4.bb2
4 files changed, 5 insertions, 5 deletions
diff --git a/recipes/cacao/cacaoh-cldc-native_0.98.bb b/recipes/cacao/cacaoh-cldc-native_0.98.bb
index 44b81fe94d..977743374d 100644
--- a/recipes/cacao/cacaoh-cldc-native_0.98.bb
+++ b/recipes/cacao/cacaoh-cldc-native_0.98.bb
@@ -5,7 +5,7 @@ SRC_URI = "\
"
do_stage() {
- install -m 0755 src/cacaoh/cacaoh ${STAGING_BINDIR}/cacaoh-cldc-${PV}
+ libtool --mode=install install -m 0755 src/cacaoh/cacaoh ${STAGING_BINDIR}/cacaoh-cldc-${PV}
}
SRC_URI[md5sum] = "8b8907c8b925761c9410bcadb9705346"
diff --git a/recipes/cacao/cacaoh-native.inc b/recipes/cacao/cacaoh-native.inc
index 203edea037..655bb0c54a 100644
--- a/recipes/cacao/cacaoh-native.inc
+++ b/recipes/cacao/cacaoh-native.inc
@@ -3,7 +3,7 @@ HOMEPAGE = "http://www.cacaojvm.org/"
LICENSE = "GPL"
DEPENDS = "libtool-native zlib-native virtual/javac-native classpath-native"
-INC_PR = "r3"
+INC_PR = "r4"
S = "${WORKDIR}/cacao-${PV}"
@@ -24,7 +24,7 @@ do_compile() {
do_install() {
install -d ${D}${bindir}/cacaoh-${PV}
- install -m 0755 src/cacaoh/cacaoh ${D}${bindir}/cacaoh-${PV}
+ libtool --mode=install install -m 0755 src/cacaoh/cacaoh ${D}${bindir}/cacaoh-${PV}
}
NATIVE_INSTALL_WORKS = "1"
diff --git a/recipes/cacao/cacaoh-openjdk-native.inc b/recipes/cacao/cacaoh-openjdk-native.inc
index 4afb955414..0a1481f1e9 100644
--- a/recipes/cacao/cacaoh-openjdk-native.inc
+++ b/recipes/cacao/cacaoh-openjdk-native.inc
@@ -27,5 +27,5 @@ do_compile() {
}
do_install() {
- install -m 0755 src/cacaoh/cacaoh ${STAGING_BINDIR}/cacaoh-openjdk-${PV}
+ libtool --mode=install install -m 0755 src/cacaoh/cacaoh ${STAGING_BINDIR}/cacaoh-openjdk-${PV}
}
diff --git a/recipes/cacao/cacaoh-openjdk-native_0.99.4.bb b/recipes/cacao/cacaoh-openjdk-native_0.99.4.bb
index 27ab6ab006..3f2686fc44 100644
--- a/recipes/cacao/cacaoh-openjdk-native_0.99.4.bb
+++ b/recipes/cacao/cacaoh-openjdk-native_0.99.4.bb
@@ -1,6 +1,6 @@
require cacaoh-openjdk-native.inc
-PR = "r0"
+PR = "r1"
SRC_URI[md5sum] = "63220327925ace13756ae334c55a3baa"
SRC_URI[sha256sum] = "1dfc4903dc0172286df4f1740fd0f12749ac81d51c602290b47cbe83d51e1d56"