aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Kurz <betheg@bitcloner.org>2010-08-21 05:22:50 +0000
committerKhem Raj <raj.khem@gmail.com>2010-08-21 10:42:18 -0700
commit4ffe15ff9878462de454a87cf73c37853f905881 (patch)
tree9b8c76609cf90ed184e9317041cbc153aaeb6159
parent86b84f8efe8de2f0f27286b0121e277789715e37 (diff)
downloadopenembedded-4ffe15ff9878462de454a87cf73c37853f905881.tar.gz
ode_0.9.bb: clean up the recipe and fix some issues.
* remove do_stage and do_install those do not needed. ' fix the missing headerfiles in the dev package. * fix QA: non dev contains .so. * install.patch: adjust the patch a bit so that DESTDIR is used. Signed-off-by: Michael Kurz <betheg@bitcloner.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes/ode/files/install.patch23
-rw-r--r--recipes/ode/ode_0.9.bb25
2 files changed, 17 insertions, 31 deletions
diff --git a/recipes/ode/files/install.patch b/recipes/ode/files/install.patch
index d63229f8ec..2f6cdb0080 100644
--- a/recipes/ode/files/install.patch
+++ b/recipes/ode/files/install.patch
@@ -1,21 +1,22 @@
-Index: ode-0.9/Makefile.am
-===================================================================
---- ode-0.9.orig/Makefile.am
-+++ ode-0.9/Makefile.am
-@@ -25,13 +25,13 @@ dist-zip: ${PACKAGE}-${VERSION}.tar.gz
+--- ode-0.9.orig/Makefile.am 2007-02-21 15:54:54.000000000 +0100
++++ ode-0.9/Makefile.am 2010-08-21 16:15:55.000000000 +0200
+@@ -25,13 +25,13 @@
if USE_SONAME
install-exec-hook:
- ln -s $(libdir)/@ODE_SONAME@.@ODE_REVISION@.@ODE_AGE@ \
-+ ln -sf ./@ODE_SONAME@.@ODE_REVISION@.@ODE_AGE@ \
- $(libdir)/libode.so
+- $(libdir)/libode.so
- ln -s $(libdir)/@ODE_SONAME@.@ODE_REVISION@.@ODE_AGE@ \
-+ ln -sf ./@ODE_SONAME@.@ODE_REVISION@.@ODE_AGE@ \
- $(libdir)/@ODE_SONAME@
+- $(libdir)/@ODE_SONAME@
- ln -s $(libdir)/@ODE_SONAME@.@ODE_REVISION@.@ODE_AGE@ \
-+ ln -sf ./@ODE_SONAME@.@ODE_REVISION@.@ODE_AGE@ \
- $(libdir)/@ODE_SONAME@.@ODE_REVISION@
+- $(libdir)/@ODE_SONAME@.@ODE_REVISION@
- /sbin/ldconfig
++ ln -s @ODE_SONAME@.@ODE_REVISION@.@ODE_AGE@ \
++ $(DESTDIR)/$(libdir)/libode.so
++ ln -s @ODE_SONAME@.@ODE_REVISION@.@ODE_AGE@ \
++ $(DESTDIR)/$(libdir)/@ODE_SONAME@
++ ln -s @ODE_SONAME@.@ODE_REVISION@.@ODE_AGE@ \
++ $(DESTDIR)/$(libdir)/@ODE_SONAME@.@ODE_REVISION@
+ echo /sbin/ldconfig
else
install-exec-hook:
diff --git a/recipes/ode/ode_0.9.bb b/recipes/ode/ode_0.9.bb
index 1383329d2b..a7a8257480 100644
--- a/recipes/ode/ode_0.9.bb
+++ b/recipes/ode/ode_0.9.bb
@@ -2,11 +2,14 @@ DESCRIPTION = "ODE is an Open Source Physics Engine."
SECTION = "libs"
HOMEPAGE = "http://www.ode.org"
LICENSE = "LGPL"
-PR = "r0"
+PR = "r1"
SRC_URI = "${SOURCEFORGE_MIRROR}/opende/ode-src-${PV}.zip \
file://install.patch"
+SRC_URI[md5sum] = "4c03759b76a0649a6d5108c8e172e1e4"
+SRC_URI[sha256sum] = "460d0851b743b1f144ef2a8259004d6774504c95d08e9357a96a296111496feb"
+
inherit autotools binconfig
EXTRA_OECONF = "--disable-demos --enable-soname"
@@ -15,23 +18,5 @@ do_configure_append() {
echo "#define dInfinity DBL_MAX" >>include/ode/config.h
}
-do_stage() {
- oe_runmake install \
- bindir=${STAGING_BINDIR_CROSS} \
- libdir=${STAGING_LIBDIR} \
- includedir=${STAGING_INCDIR} \
- datadir=${STAGING_DATADIR}
-}
+FILES_${PN} = "${libdir}/lib*${SOLIBS}"
-do_install() {
- oe_runmake install \
- bindir=${D}${bindir} \
- libdir=${D}${libdir} \
- includedir=${D}${incdir} \
- datadir=${D}${datadir}
-}
-
-FILES_${PN} = "${libdir}/lib*.so*"
-
-SRC_URI[md5sum] = "4c03759b76a0649a6d5108c8e172e1e4"
-SRC_URI[sha256sum] = "460d0851b743b1f144ef2a8259004d6774504c95d08e9357a96a296111496feb"