aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2010-02-14 13:56:10 +0100
committerAndrea Adami <andrea.adami@gmail.com>2010-02-14 13:56:10 +0100
commit5869b900e0a418707fe93f217f93d2ba2b925ad9 (patch)
treeb1b03a83033c7e7d0ff9bece76899a185763c485
parentb6033e12e6f17243d8995ad582742dc9cd32999d (diff)
downloadopenembedded-5869b900e0a418707fe93f217f93d2ba2b925ad9.tar.gz
initramfs-kexecboot-image: remove deprecated device-table.
* Devices are dynamically recreated by kexecboot by default.
-rw-r--r--recipes/kexecboot/device_table-oldmmc.txt36
-rw-r--r--recipes/kexecboot/initramfs-kexecboot-image.bb9
2 files changed, 3 insertions, 42 deletions
diff --git a/recipes/kexecboot/device_table-oldmmc.txt b/recipes/kexecboot/device_table-oldmmc.txt
deleted file mode 100644
index 2b61c01849..0000000000
--- a/recipes/kexecboot/device_table-oldmmc.txt
+++ /dev/null
@@ -1,36 +0,0 @@
-#<path> <type> <mode> <uid> <gid> <major> <minor> <start> <inc> <count>
-#/dev/mem c 640 0 0 1 1 0 0 -
-#
-#type can be one of:
-# f A regular file
-# d Directory
-# c Character special device file
-# b Block special device file
-# p Fifo (named pipe)
-
-/dev d 755 0 0 - - - - -
-/dev/initctl p 600 0 0 - - - - -
-/dev/apm_bios c 660 0 46 10 134 - - -
-/dev/fb0 c 600 0 0 29 0 - - -
-/dev/hda b 660 0 6 3 0 - - -
-/dev/hda b 660 0 6 3 1 1 1 19
-/dev/kmem c 640 0 15 1 2 - - -
-/dev/mem c 640 0 15 1 1 - - -
-/dev/null c 666 0 0 1 3 - - -
-/dev/ram b 640 0 0 1 0 0 1 4
-/dev/tty c 662 0 5 5 0 - - -
-/dev/tty c 666 0 5 4 0 0 1 9
-/dev/ttyS c 640 0 5 4 64 0 1 1
-/dev/ttySA c 640 0 5 204 5 0 1 1
-/dev/zero c 644 0 0 1 5 - - -
-/dev/mtd c 660 0 6 90 0 0 2 8
-/dev/mtdblock b 640 0 0 31 0 0 1 8
-/dev/console c 662 0 5 5 1 - - -
-/dev/random c 644 0 0 1 8 - - -
-/dev/urandom c 644 0 0 1 9 - - -
-/dev/ptmx c 644 0 0 5 2 - - -
-
-# mmc numbers are assigned dynamicly so if you have other dynamic assigned block devices it may be wrong
-/dev/mmcblk0 b 660 0 6 254 0 - - -
-/dev/mmcblk0p b 660 0 6 254 1 1 1 7
-/dev/event0 c 660 0 0 13 64 - - -
diff --git a/recipes/kexecboot/initramfs-kexecboot-image.bb b/recipes/kexecboot/initramfs-kexecboot-image.bb
index 285640dcf5..c251aa9cf2 100644
--- a/recipes/kexecboot/initramfs-kexecboot-image.bb
+++ b/recipes/kexecboot/initramfs-kexecboot-image.bb
@@ -1,16 +1,11 @@
# Initramfs image providing kexecboot
# a linux as bootloader implementation
-PR = "r2"
+PR = "r3"
ONLINE_PACKAGE_MANAGEMENT = "none"
IMAGE_FSTYPES = "cpio.gz cpio.lzma"
DEPENDS = "lzma-native"
-# Deprecated: device nodes are populated by kexecboot now
-# These devices need mmcblk* to be 254 instead of 179
-IMAGE_DEVICE_TABLES_hx4700 = "device_table-oldmmc.txt"
-IMAGE_DEVICE_TABLES_h2200 = "device_table-oldmmc.txt"
-
export IMAGE_BASENAME = "initramfs-kexecboot-image"
# avoid circular dependencies
@@ -23,5 +18,7 @@ IMAGE_LOGIN_MANAGER = ""
IMAGE_INIT_MANAGER = ""
IMAGE_INITSCRIPTS = ""
IMAGE_DEV_MANAGER = ""
+
FEED_DEPLOYDIR_BASE_URI = ""
+
inherit image