aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Schuster <robertschuster@fsfe.org>2009-09-18 14:45:02 +0200
committerRobert Schuster <robertschuster@fsfe.org>2009-09-18 14:45:02 +0200
commit61af8065e555f57f697689f5092209b0f8f5b51a (patch)
tree242e408bb51ffa5334aff9c4cddc28682804d7ba
parentff52f57646c898b7377cfda8d1365dc9e1ffe946 (diff)
downloadopenembedded-61af8065e555f57f697689f5092209b0f8f5b51a.tar.gz
bsf 2.4.0: New recipe (from Jalimo SVN).
bsf-native 2.4.0: Dito.
-rw-r--r--recipes/jakarta-libs/bsf-native_2.4.0.bb8
-rw-r--r--recipes/jakarta-libs/bsf_2.4.0.bb24
2 files changed, 32 insertions, 0 deletions
diff --git a/recipes/jakarta-libs/bsf-native_2.4.0.bb b/recipes/jakarta-libs/bsf-native_2.4.0.bb
new file mode 100644
index 0000000000..9b3c1dd11c
--- /dev/null
+++ b/recipes/jakarta-libs/bsf-native_2.4.0.bb
@@ -0,0 +1,8 @@
+require bsf_${PV}.bb
+
+S = "${WORKDIR}/bsf-${PV}"
+
+inherit java-native
+
+DEPENDS = "fastjar-native jacl-native commons-logging-native rhino-native xalan-j-native bcel-native"
+
diff --git a/recipes/jakarta-libs/bsf_2.4.0.bb b/recipes/jakarta-libs/bsf_2.4.0.bb
new file mode 100644
index 0000000000..e853ea1381
--- /dev/null
+++ b/recipes/jakarta-libs/bsf_2.4.0.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Bean Scripting Framework package"
+LICENSES = "AL2.0"
+AUTHOR = "Apache Software Foundation"
+
+SRC_URI = "http://archive.apache.org/dist/jakarta/bsf/source/bsf-src-${PV}.tar.gz"
+
+inherit java-library
+
+DEPENDS = "fastjar-native jacl commons-logging rhino xalan-j bcel"
+
+do_compile() {
+ mkdir -p build
+
+ oe_makeclasspath cp -s commons-logging jacl rhino bcel xalan2
+
+ # Remove netrexx and jython support
+ rm -Rf src/org/apache/bsf/engines/netrexx
+ rm -Rf src/org/apache/bsf/engines/jython
+
+ javac -sourcepath src -cp $cp -d build `find src -name "*.java"`
+
+ fastjar -C build -c -f ${JARFILENAME} .
+}
+