aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-08-17 08:41:27 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-08-20 20:23:24 +0200
commit63951fbda2ed1bc05bf0095eabececceddf9c1c3 (patch)
tree52e51a0d7a9869d2d627c360de491c08e599032a
parentfd7ebfaeadb60ff04dd4eac73609c14c00b1e630 (diff)
downloadopenembedded-63951fbda2ed1bc05bf0095eabececceddf9c1c3.tar.gz
webkit-efl: bump SRCREV
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes/webkit/webkit-efl/CMakeLists.txt1
-rw-r--r--recipes/webkit/webkit-efl/install-efl-launcher.patch8
-rw-r--r--recipes/webkit/webkit-efl/set-so-version.patch11
-rw-r--r--recipes/webkit/webkit-efl_svn.bb7
4 files changed, 9 insertions, 18 deletions
diff --git a/recipes/webkit/webkit-efl/CMakeLists.txt b/recipes/webkit/webkit-efl/CMakeLists.txt
index 996b457634..99b63830b9 100644
--- a/recipes/webkit/webkit-efl/CMakeLists.txt
+++ b/recipes/webkit/webkit-efl/CMakeLists.txt
@@ -27,6 +27,7 @@ OPTION(PORT "choose which WebKit port to build (one of ${ALL_PORTS})" "NOPORT")
# -----------------------------------------------------------------------------
FIND_PACKAGE(BISON REQUIRED)
FIND_PACKAGE(FLEX REQUIRED)
+FIND_PACKAGE(Gperf REQUIRED)
FIND_PACKAGE(Perl REQUIRED)
FIND_PACKAGE(PythonInterp REQUIRED)
diff --git a/recipes/webkit/webkit-efl/install-efl-launcher.patch b/recipes/webkit/webkit-efl/install-efl-launcher.patch
index 8f059be282..6c74b3e5b1 100644
--- a/recipes/webkit/webkit-efl/install-efl-launcher.patch
+++ b/recipes/webkit/webkit-efl/install-efl-launcher.patch
@@ -1,7 +1,7 @@
-diff -ru webkit.original/WebKit/CMakeListsEfl.txt webkit/WebKit/CMakeListsEfl.txt
---- webkit.original/WebKit/CMakeListsEfl.txt 2010-07-21 09:20:50.000000000 +0200
-+++ webkit/WebKit/CMakeListsEfl.txt 2010-07-21 11:51:21.000000000 +0200
-@@ -118,3 +118,6 @@
+diff -uNr src.orig/WebKit/efl/CMakeListsEfl.txt src/WebKit/efl/CMakeListsEfl.txt
+--- src.orig/WebKit/efl/CMakeListsEfl.txt 2010-08-17 08:29:07.000000000 +0200
++++ src/WebKit/efl/CMakeListsEfl.txt 2010-08-17 08:33:54.000000000 +0200
+@@ -211,3 +211,6 @@
INSTALL(FILES ${EWebKit_HEADERS}
DESTINATION include/EWebKit)
diff --git a/recipes/webkit/webkit-efl/set-so-version.patch b/recipes/webkit/webkit-efl/set-so-version.patch
deleted file mode 100644
index 7cf81a2f4c..0000000000
--- a/recipes/webkit/webkit-efl/set-so-version.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -ru webkit.original/WebKit/CMakeLists.txt webkit/WebKit/CMakeLists.txt
---- webkit.original/WebKit/CMakeLists.txt 2010-07-24 00:14:06.000000000 +0200
-+++ webkit/WebKit/CMakeLists.txt 2010-07-23 23:55:01.000000000 +0200
-@@ -59,6 +59,7 @@
- ADD_LIBRARY(${WebKit_LIBRARY_NAME} ${WebKit_LIBRARY_TYPE} ${WebKit_SOURCES})
- TARGET_LINK_LIBRARIES(${WebKit_LIBRARY_NAME} ${WebKit_LIBRARIES})
- ADD_TARGET_PROPERTIES(${WebKit_LIBRARY_NAME} LINK_FLAGS "${WebKit_LINK_FLAGS}")
-+SET_TARGET_PROPERTIES(${WebKit_LIBRARY_NAME} PROPERTIES VERSION 0.0.0 SOVERSION 0)
-
- INSTALL(TARGETS ${WebKit_LIBRARY_NAME} DESTINATION lib)
-
diff --git a/recipes/webkit/webkit-efl_svn.bb b/recipes/webkit/webkit-efl_svn.bb
index f2c6e80025..13a895b666 100644
--- a/recipes/webkit/webkit-efl_svn.bb
+++ b/recipes/webkit/webkit-efl_svn.bb
@@ -4,7 +4,7 @@ DEPENDS = "icu libxslt sqlite3 gperf-native bison-native flex-native jpeg \
libpng libxt fontconfig cairo freetype glib-2.0 libsoup-2.4 \
libxml2 pango eina ecore evas edje"
-SRCREV = "64079"
+SRCREV = "65655"
PV = "1.1.11+svnr${SRCPV}"
PR = "r9"
@@ -21,14 +21,14 @@ SRC_URI = "\
file://cmakeconfig.h.cmake \
file://CMakeLists.txt \
file://install-efl-launcher.patch \
- file://set-so-version.patch \
"
S = "${WORKDIR}/src"
inherit cmake lib_package pkgconfig
-EXTRA_OECMAKE = "-DPORT=Efl"
+#EXTRA_OECMAKE = "-DPORT=Efl"
+EXTRA_OECMAKE = "-DPORT=Efl -DSHARED_CORE=ON"
do_unpack_append() {
bb.build.exec_func('do_move_files', d)
@@ -39,6 +39,7 @@ do_move_files() {
mv "${WORKDIR}/CMakeLists.txt" "${S}"
}
+LEAD_SONAME = "libewebkit.so"
PACKAGES =+ "${PN}launcher-dbg ${PN}launcher"
FILES_${PN} += "${datadir}/webkit-1.0/theme/default.edj"