aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Rini <trini@embeddedalley.com>2009-05-11 13:54:01 -0700
committerTom Rini <trini@embeddedalley.com>2009-05-11 13:54:01 -0700
commit6502b7b61fce9681f565972754e14530a6c120fd (patch)
tree3f66d96811dca1b076c36da7b257a325154a73a2
parentefb7a4954e62730b8dc077c429f9a9043111f82c (diff)
downloadopenembedded-6502b7b61fce9681f565972754e14530a6c120fd.tar.gz
gcc*4.2.4: Switch to using INC_PR (r6).
-rw-r--r--recipes/gcc/gcc-4.2.4.inc2
-rw-r--r--recipes/gcc/gcc-canadian-sdk_4.2.4.bb2
-rw-r--r--recipes/gcc/gcc-cross-sdk_4.2.4.bb2
-rw-r--r--recipes/gcc/gcc-cross_4.2.4.bb2
-rw-r--r--recipes/gcc/gcc_4.2.4.bb2
5 files changed, 6 insertions, 4 deletions
diff --git a/recipes/gcc/gcc-4.2.4.inc b/recipes/gcc/gcc-4.2.4.inc
index 6bffa54265..80d38f91cf 100644
--- a/recipes/gcc/gcc-4.2.4.inc
+++ b/recipes/gcc/gcc-4.2.4.inc
@@ -3,6 +3,8 @@ LICENSE = "GPLv3"
DEPENDS = "mpfr gmp"
+INC_PR = "r6"
+
SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
file://100-uclibc-conf.patch;patch=1 \
file://103-uclibc-conf-noupstream.patch;patch=1 \
diff --git a/recipes/gcc/gcc-canadian-sdk_4.2.4.bb b/recipes/gcc/gcc-canadian-sdk_4.2.4.bb
index ab0a1f7ccb..409970be5f 100644
--- a/recipes/gcc/gcc-canadian-sdk_4.2.4.bb
+++ b/recipes/gcc/gcc-canadian-sdk_4.2.4.bb
@@ -1,6 +1,6 @@
inherit canadian-sdk
-PR = "r3"
+PR = "${INC_PR}.1"
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gcc-${PV}"
diff --git a/recipes/gcc/gcc-cross-sdk_4.2.4.bb b/recipes/gcc/gcc-cross-sdk_4.2.4.bb
index 0a3af9e469..c5a0a1aa88 100644
--- a/recipes/gcc/gcc-cross-sdk_4.2.4.bb
+++ b/recipes/gcc/gcc-cross-sdk_4.2.4.bb
@@ -1,4 +1,4 @@
-PR = "r5"
+PR = "${INC_PR}.1"
inherit sdk
diff --git a/recipes/gcc/gcc-cross_4.2.4.bb b/recipes/gcc/gcc-cross_4.2.4.bb
index 11e04594fc..4e7fc479d1 100644
--- a/recipes/gcc/gcc-cross_4.2.4.bb
+++ b/recipes/gcc/gcc-cross_4.2.4.bb
@@ -1,4 +1,4 @@
-PR = "r6"
+PR = "${INC_PR}.1"
require gcc-${PV}.inc
require gcc-cross4.inc
diff --git a/recipes/gcc/gcc_4.2.4.bb b/recipes/gcc/gcc_4.2.4.bb
index 318ccd3775..6b20b47f1a 100644
--- a/recipes/gcc/gcc_4.2.4.bb
+++ b/recipes/gcc/gcc_4.2.4.bb
@@ -1,4 +1,4 @@
-PR = "r4"
+PR = "${INC_PR}.1"
require gcc-${PV}.inc
require gcc-configure-target.inc