aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCliff Brake <cbrake@bec-systems.com>2008-10-24 08:34:22 -0400
committerCliff Brake <cbrake@bec-systems.com>2008-10-24 08:34:22 -0400
commit703cea83a1859db8c18b75a7911dc99f1dc2095a (patch)
treeaa373fca39923837156a6468c13d87a5323b1631
parent97f239bff818c4836572495c05f983a9fab09202 (diff)
parent8655c6c036a930bd0767efcf512ddb8dd654c6b9 (diff)
downloadopenembedded-703cea83a1859db8c18b75a7911dc99f1dc2095a.tar.gz
Merge commit 'openembedded.org/org.openembedded.dev' into org.openembedded.dev
-rw-r--r--classes/package_ipk.bbclass5
-rw-r--r--conf/machine/davinci-dvevm.conf3
-rw-r--r--conf/machine/i586-generic.conf2
-rw-r--r--conf/machine/i686-generic.conf2
-rw-r--r--conf/machine/neuros-osd2.conf5
-rw-r--r--conf/machine/om-gta01.conf2
-rw-r--r--conf/machine/om-gta02.conf2
-rw-r--r--packages/gnutls/gnutls.inc5
-rw-r--r--packages/gnutls/gnutls_1.4.5.bb5
-rw-r--r--packages/gnutls/gnutls_1.6.3.bb5
-rw-r--r--packages/gnutls/gnutls_2.4.2.bb2
-rw-r--r--packages/linux/linux-bd-neon-2.6_2.6.22.bb1
-rw-r--r--packages/ppp-dialin/ppp-dialin_0.1.bb6
-rw-r--r--packages/tasks/task-base.bb2
14 files changed, 24 insertions, 23 deletions
diff --git a/classes/package_ipk.bbclass b/classes/package_ipk.bbclass
index 438d4a15da..e0636eef70 100644
--- a/classes/package_ipk.bbclass
+++ b/classes/package_ipk.bbclass
@@ -16,7 +16,7 @@ python package_ipk_install () {
# Warning - this function is not multimachine safe (see stagingdir reference)!
#
- import os, sys
+ import os, sys, bb
pkg = bb.data.getVar('PKG', d, 1)
pkgfn = bb.data.getVar('PKGFN', d, 1)
rootfs = bb.data.getVar('IMAGE_ROOTFS', d, 1)
@@ -118,7 +118,7 @@ package_generate_ipkg_conf () {
}
python do_package_ipk () {
- import sys, re, copy
+ import sys, re, copy, bb
workdir = bb.data.getVar('WORKDIR', d, 1)
if not workdir:
@@ -305,6 +305,7 @@ python () {
}
python do_package_write_ipk () {
+ import bb
packages = bb.data.getVar('PACKAGES', d, True)
if not packages:
bb.debug(1, "No PACKAGES defined, nothing to package")
diff --git a/conf/machine/davinci-dvevm.conf b/conf/machine/davinci-dvevm.conf
index c926c6ff8a..50c6561a95 100644
--- a/conf/machine/davinci-dvevm.conf
+++ b/conf/machine/davinci-dvevm.conf
@@ -21,8 +21,5 @@ EXTRA_IMAGECMD_jffs2 = "--pad --little-endian --eraseblock=0x20000 -n"
MACHINE_FEATURES = "kernel26 pcmcia usbhost alsa"
-MACHINE_EXTRA_RDEPENDS = "dsplink"
-MACHINE_EXTRA_RRECOMMENDS = "dsplink-module"
-
require conf/machine/include/tune-arm926ejs.inc
diff --git a/conf/machine/i586-generic.conf b/conf/machine/i586-generic.conf
index e715eeb83b..7918131cd3 100644
--- a/conf/machine/i586-generic.conf
+++ b/conf/machine/i586-generic.conf
@@ -6,7 +6,7 @@
TARGET_ARCH = "i586"
-PACKAGE_EXTRA_ARCHS = "x86 i386 i486"
+PACKAGE_EXTRA_ARCHS = "x86"
PREFERRED_PROVIDER_virtual/kernel = "linux"
diff --git a/conf/machine/i686-generic.conf b/conf/machine/i686-generic.conf
index 685d763e6d..b4d254ca50 100644
--- a/conf/machine/i686-generic.conf
+++ b/conf/machine/i686-generic.conf
@@ -6,7 +6,7 @@
TARGET_ARCH = "i686"
-PACKAGE_EXTRA_ARCHS = "x86 i386 i486 i586"
+PACKAGE_EXTRA_ARCHS = "x86"
PREFERRED_PROVIDER_virtual/kernel = "linux"
PREFERRED_PROVIDER_virtual/xserver = "xserver-kdrive"
diff --git a/conf/machine/neuros-osd2.conf b/conf/machine/neuros-osd2.conf
index f852a9e82b..b751cbcac2 100644
--- a/conf/machine/neuros-osd2.conf
+++ b/conf/machine/neuros-osd2.conf
@@ -7,10 +7,6 @@ TARGET_ARCH = "arm"
PREFERRED_PROVIDER_xserver = "xserver-kdrive"
PREFERRED_PROVIDER_virtual/kernel = "linux-neuros"
-
-module_autoload_cmem = "cmemk phys_start=0x8EA00000 phys_end=0x8F200000 pools=1x3145728,5x829440,1x61440,1x10240"
-module_autoload_dsplink = "dsplinkk"
-
KERNEL_IMAGETYPE = "uImage"
UBOOT_ENTRYPOINT = "0x80008000"
@@ -31,4 +27,3 @@ MACHINE_FEATURES = "kernel26 pcmcia usbhost screen"
require conf/machine/include/tune-arm926ejs.inc
require conf/machine/include/neuros.inc
-MACHINE_EXTRA_RRECOMMENDS = " dsplink-cmemk-module dsplink-module"
diff --git a/conf/machine/om-gta01.conf b/conf/machine/om-gta01.conf
index 57d81c2ade..a45380f606 100644
--- a/conf/machine/om-gta01.conf
+++ b/conf/machine/om-gta01.conf
@@ -6,7 +6,7 @@
TARGET_ARCH = "arm"
MACHINE_CLASS = "neo1973"
-PACKAGE_EXTRA_ARCHS = "armv4t fic-gta01 ${MACHINE_CLASS}"
+PACKAGE_EXTRA_ARCHS = "fic-gta01 ${MACHINE_CLASS}"
PREFERRED_PROVIDER_virtual/kernel ?= "linux-openmoko"
UBOOT_ENTRYPOINT = "30008000"
diff --git a/conf/machine/om-gta02.conf b/conf/machine/om-gta02.conf
index 88aa3881c7..9876ebecbd 100644
--- a/conf/machine/om-gta02.conf
+++ b/conf/machine/om-gta02.conf
@@ -6,7 +6,7 @@
TARGET_ARCH = "arm"
MACHINE_CLASS = "neo1973"
-PACKAGE_EXTRA_ARCHS = "armv4t fic-gta02 ${MACHINE_CLASS}"
+PACKAGE_EXTRA_ARCHS = "fic-gta02 ${MACHINE_CLASS}"
PREFERRED_PROVIDER_virtual/kernel ?= "linux-openmoko"
PREFERRED_PROVIDER_virtual/xserver = "xserver-kdrive-glamo"
diff --git a/packages/gnutls/gnutls.inc b/packages/gnutls/gnutls.inc
index 6400e80b11..e438423c9c 100644
--- a/packages/gnutls/gnutls.inc
+++ b/packages/gnutls/gnutls.inc
@@ -9,11 +9,6 @@ inherit autotools binconfig pkgconfig
EXTRA_OECONF = "--with-included-opencdk --with-included-libtasn1"
-# fix wrong dependency
-do_configure_prepend() {
- sed -i s,gcrypt,libgcrypt, lib/gnutls.pc.in
-}
-
do_stage() {
oe_libinstall -C lib/.libs -so -a libgnutls ${STAGING_LIBDIR}
oe_libinstall -C libextra/.libs -so -a libgnutls-extra ${STAGING_LIBDIR}
diff --git a/packages/gnutls/gnutls_1.4.5.bb b/packages/gnutls/gnutls_1.4.5.bb
index 749064af65..a5e58735a0 100644
--- a/packages/gnutls/gnutls_1.4.5.bb
+++ b/packages/gnutls/gnutls_1.4.5.bb
@@ -1,3 +1,8 @@
require gnutls.inc
+# fix wrong dependency
+do_configure_prepend() {
+ sed -i s,gcrypt,libgcrypt, lib/gnutls.pc.in
+}
+
PR = "r3"
diff --git a/packages/gnutls/gnutls_1.6.3.bb b/packages/gnutls/gnutls_1.6.3.bb
index ce10a4b6cf..7a89835237 100644
--- a/packages/gnutls/gnutls_1.6.3.bb
+++ b/packages/gnutls/gnutls_1.6.3.bb
@@ -6,4 +6,9 @@ SRC_URI += "\
file://configure_madness.patch;patch=1 \
"
+# fix wrong dependency
+do_configure_prepend() {
+ sed -i s,gcrypt,libgcrypt, lib/gnutls.pc.in
+}
+
PR = "r6"
diff --git a/packages/gnutls/gnutls_2.4.2.bb b/packages/gnutls/gnutls_2.4.2.bb
index 3313a456a1..15614fbe5a 100644
--- a/packages/gnutls/gnutls_2.4.2.bb
+++ b/packages/gnutls/gnutls_2.4.2.bb
@@ -5,3 +5,5 @@ SRC_URI += "\
file://gnutls-texinfo-euro.patch;patch=1 \
file://configure_madness.patch;patch=1 \
"
+
+PR = "r1"
diff --git a/packages/linux/linux-bd-neon-2.6_2.6.22.bb b/packages/linux/linux-bd-neon-2.6_2.6.22.bb
index 05ceb28ee5..400fe782db 100644
--- a/packages/linux/linux-bd-neon-2.6_2.6.22.bb
+++ b/packages/linux/linux-bd-neon-2.6_2.6.22.bb
@@ -2,6 +2,7 @@ DESCRIPTION = "2.6 Linux Kernel for Boundary Devices NEON Board"
SECTION = "kernel"
HOMEPAGE = "N/A"
LICENSE = "GPL"
+COMPATIBLE_MACHINE = "bd-neon"
DEPENDS += "u-boot-utils-native"
PR = "r2"
diff --git a/packages/ppp-dialin/ppp-dialin_0.1.bb b/packages/ppp-dialin/ppp-dialin_0.1.bb
index 6861d8ad44..51a4a2b32d 100644
--- a/packages/ppp-dialin/ppp-dialin_0.1.bb
+++ b/packages/ppp-dialin/ppp-dialin_0.1.bb
@@ -2,7 +2,7 @@ SECTION = "console/network"
DESCRIPTION = "Enables PPP dial-in through a serial connection"
DEPENDS = "ppp"
RDEPENDS = "ppp"
-PR = "r5"
+PR = "r6"
LICENSE = "MIT"
SRC_URI = "file://host-peer \
@@ -22,7 +22,7 @@ pkg_postinst() {
if test "x$D" != "x"; then
exit 1
else
- adduser --system --home /dev/null --no-create-home --empty-password --ingroup nogroup -s ${sbindir}/ppp-dialin ppp
+ grep "^ppp:" /etc/passwd > /dev/null || adduser --system --home /dev/null --no-create-home --empty-password --ingroup nogroup -s ${sbindir}/ppp-dialin ppp
fi
}
@@ -30,6 +30,6 @@ pkg_postrm() {
if test "x$D" != "x"; then
exit 1
else
- deluser ppp
+ deluser ppp || true
fi
}
diff --git a/packages/tasks/task-base.bb b/packages/tasks/task-base.bb
index 57a711577c..9d3bc8ebdd 100644
--- a/packages/tasks/task-base.bb
+++ b/packages/tasks/task-base.bb
@@ -1,5 +1,5 @@
DESCRIPTION = "Merge machine and distro options to create a basic machine task/package"
-PR = "r73"
+PR = "r74"
inherit task