aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteve Sakoman <steve@sakoman.com>2009-08-08 14:39:14 -0700
committerKoen Kooi <koen@openembedded.org>2009-08-09 16:16:06 +0200
commit70924feaeca6e418bdbe80ae53ca99f755e20a99 (patch)
tree64a446f8d4b6302b30497c33d48402e3a6feea34
parent691e173d1979387337e4973db8213ab22f64ba69 (diff)
downloadopenembedded-70924feaeca6e418bdbe80ae53ca99f755e20a99.tar.gz
gnome-common: restructure recipes to use gnome-common.inc, add 2.26.0
-rw-r--r--conf/checksums.ini4
-rw-r--r--recipes/gnome/gnome-common.inc28
-rw-r--r--recipes/gnome/gnome-common/omf.patch (renamed from recipes/gnome/gnome-common-2.20.0/omf.patch)0
-rw-r--r--recipes/gnome/gnome-common_2.18.0.bb29
-rw-r--r--recipes/gnome/gnome-common_2.20.0.bb29
-rw-r--r--recipes/gnome/gnome-common_2.26.0.bb1
6 files changed, 35 insertions, 56 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index dbfe5195a1..f5f07ffccb 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -8338,6 +8338,10 @@ sha256=ba28c1017e7e4212db16ada3f44cb446b6637c9c4fe16c0e2c2a51c94c46bc5b
md5=89e47677fb72695c75d2cefac84ff9f1
sha256=0e807cfe74a684c494a0949b7f96d231660f323253a89053e3ec32c4f518c8d9
+[http://ftp.gnome.org/pub/GNOME/sources/gnome-common/2.26/gnome-common-2.26.0.tar.bz2]
+md5=196daa38cb21d91da1d6ec085f1e158b
+sha256=f6233ee73886c5ac31890c1a9b9f216e5f14558467dea7b0a61ef3c4cf51d84d
+
[http://ftp.gnome.org/pub/GNOME/sources/gnome-common/2.4/gnome-common-2.4.0.tar.bz2]
md5=9f5163e616b2a02af633de9c82557fa0
sha256=9509137496606b101c6f570579b9d10ae11f531a8f8d9bfc5d113534b62376d7
diff --git a/recipes/gnome/gnome-common.inc b/recipes/gnome/gnome-common.inc
new file mode 100644
index 0000000000..9d1cdb00bf
--- /dev/null
+++ b/recipes/gnome/gnome-common.inc
@@ -0,0 +1,28 @@
+LICENSE = "GPL"
+SECTION = "x11/gnome"
+DESCRIPTION = "Common macros for building GNOME applications"
+
+inherit gnome
+
+# The omf.make file failed if scrollkeeper doesn't happen to be
+# installed
+
+SRC_URI += "file://omf.patch;patch=1"
+
+EXTRA_AUTORECONF = ""
+DEPENDS = ""
+
+FILES_${PN} += "${datadir}/aclocal"
+FILES_${PN}-dev = ""
+
+do_stage () {
+ rm -rf ${STAGE_TEMP}
+ mkdir -p ${STAGE_TEMP}
+ make DESTDIR="${STAGE_TEMP}" install
+ cp -pPR ${STAGE_TEMP}${bindir}/* ${STAGING_BINDIR_NATIVE}
+ install -d ${STAGING_DATADIR}/gnome-common
+ install -d ${STAGING_DATADIR}/aclocal
+ cp -pPR ${STAGE_TEMP}${datadir}/gnome-common/* ${STAGING_DATADIR}/gnome-common
+ cp -pPR ${STAGE_TEMP}${datadir}/aclocal/* ${STAGING_DATADIR}/aclocal
+ rm -rf ${STAGE_TEMP}
+}
diff --git a/recipes/gnome/gnome-common-2.20.0/omf.patch b/recipes/gnome/gnome-common/omf.patch
index 0d85b001e0..0d85b001e0 100644
--- a/recipes/gnome/gnome-common-2.20.0/omf.patch
+++ b/recipes/gnome/gnome-common/omf.patch
diff --git a/recipes/gnome/gnome-common_2.18.0.bb b/recipes/gnome/gnome-common_2.18.0.bb
index 41c25b69c2..252b1c25a9 100644
--- a/recipes/gnome/gnome-common_2.18.0.bb
+++ b/recipes/gnome/gnome-common_2.18.0.bb
@@ -1,28 +1 @@
-LICENSE = "GPL"
-SECTION = "x11/gnome"
-PR = "r0"
-DESCRIPTION = "Common macros for building GNOME applications"
-inherit gnome
-
-# The omf.make file failed if scrollkeeper doesn't happen to be
-# installed
-
-SRC_URI += "file://omf.patch;patch=1"
-
-EXTRA_AUTORECONF = ""
-DEPENDS = ""
-
-FILES_${PN} += "${datadir}/aclocal"
-FILES_${PN}-dev = ""
-
-do_stage () {
- rm -rf ${STAGE_TEMP}
- mkdir -p ${STAGE_TEMP}
- make DESTDIR="${STAGE_TEMP}" install
- cp -pPR ${STAGE_TEMP}${bindir}/* ${STAGING_BINDIR_NATIVE}
- install -d ${STAGING_DATADIR}/gnome-common
- install -d ${STAGING_DATADIR}/aclocal
- cp -pPR ${STAGE_TEMP}${datadir}/gnome-common/* ${STAGING_DATADIR}/gnome-common
- cp -pPR ${STAGE_TEMP}${datadir}/aclocal/* ${STAGING_DATADIR}/aclocal
- rm -rf ${STAGE_TEMP}
-}
+require gnome-common.inc
diff --git a/recipes/gnome/gnome-common_2.20.0.bb b/recipes/gnome/gnome-common_2.20.0.bb
index 41c25b69c2..252b1c25a9 100644
--- a/recipes/gnome/gnome-common_2.20.0.bb
+++ b/recipes/gnome/gnome-common_2.20.0.bb
@@ -1,28 +1 @@
-LICENSE = "GPL"
-SECTION = "x11/gnome"
-PR = "r0"
-DESCRIPTION = "Common macros for building GNOME applications"
-inherit gnome
-
-# The omf.make file failed if scrollkeeper doesn't happen to be
-# installed
-
-SRC_URI += "file://omf.patch;patch=1"
-
-EXTRA_AUTORECONF = ""
-DEPENDS = ""
-
-FILES_${PN} += "${datadir}/aclocal"
-FILES_${PN}-dev = ""
-
-do_stage () {
- rm -rf ${STAGE_TEMP}
- mkdir -p ${STAGE_TEMP}
- make DESTDIR="${STAGE_TEMP}" install
- cp -pPR ${STAGE_TEMP}${bindir}/* ${STAGING_BINDIR_NATIVE}
- install -d ${STAGING_DATADIR}/gnome-common
- install -d ${STAGING_DATADIR}/aclocal
- cp -pPR ${STAGE_TEMP}${datadir}/gnome-common/* ${STAGING_DATADIR}/gnome-common
- cp -pPR ${STAGE_TEMP}${datadir}/aclocal/* ${STAGING_DATADIR}/aclocal
- rm -rf ${STAGE_TEMP}
-}
+require gnome-common.inc
diff --git a/recipes/gnome/gnome-common_2.26.0.bb b/recipes/gnome/gnome-common_2.26.0.bb
new file mode 100644
index 0000000000..252b1c25a9
--- /dev/null
+++ b/recipes/gnome/gnome-common_2.26.0.bb
@@ -0,0 +1 @@
+require gnome-common.inc