aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2010-10-20 12:28:13 -0700
committerChris Larson <chris_larson@mentor.com>2010-10-20 13:31:53 -0700
commit8708532de0c060714856c7cf211d86202296f3a5 (patch)
tree426f9385c62e5df81b282aae7ed170dd90a4895d
parent0c9b1efb3d2bab4df466936592048d5a56c5b0bb (diff)
downloadopenembedded-8708532de0c060714856c7cf211d86202296f3a5.tar.gz
expat: use INC_PR, set acpaths
Signed-off-by: Chris Larson <chris_larson@mentor.com>
-rw-r--r--recipes/expat/expat.inc2
-rw-r--r--recipes/expat/expat_1.95.6.bb3
-rw-r--r--recipes/expat/expat_1.95.7.bb2
-rw-r--r--recipes/expat/expat_2.0.1.bb2
4 files changed, 5 insertions, 4 deletions
diff --git a/recipes/expat/expat.inc b/recipes/expat/expat.inc
index b254f08b74..bc568287a7 100644
--- a/recipes/expat/expat.inc
+++ b/recipes/expat/expat.inc
@@ -11,3 +11,5 @@ export LTCC = "${CC}"
inherit autotools
+acpaths =+ "-I${S}/conftools"
+INC_PR = "r3"
diff --git a/recipes/expat/expat_1.95.6.bb b/recipes/expat/expat_1.95.6.bb
index 64eb2a78b8..aaf6a07122 100644
--- a/recipes/expat/expat_1.95.6.bb
+++ b/recipes/expat/expat_1.95.6.bb
@@ -1,6 +1,5 @@
require expat.inc
-
-PR = "r2"
+PR = "${INC_PR}.0"
do_install () {
oe_runmake prefix="${D}${prefix}" \
diff --git a/recipes/expat/expat_1.95.7.bb b/recipes/expat/expat_1.95.7.bb
index 61b2c5d597..d78fd67f70 100644
--- a/recipes/expat/expat_1.95.7.bb
+++ b/recipes/expat/expat_1.95.7.bb
@@ -1,5 +1,5 @@
require expat.inc
-PR = "r3"
+PR = "${INC_PR}.0"
SRC_URI += "file://autotools.patch \
file://expat-XMLCALL.patch \
diff --git a/recipes/expat/expat_2.0.1.bb b/recipes/expat/expat_2.0.1.bb
index 5ff9f1ed9e..63d34215e9 100644
--- a/recipes/expat/expat_2.0.1.bb
+++ b/recipes/expat/expat_2.0.1.bb
@@ -1,5 +1,5 @@
require expat.inc
-PR = "r3"
+PR = "${INC_PR}.0"
BBCLASSEXTEND = "native nativesdk"