aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <k-kooi@ti.com>2010-01-21 09:23:07 +0100
committerKoen Kooi <koen@openembedded.org>2010-04-12 19:43:13 +0200
commit8d6e6182ecebc4300a77ba5ac66f437e54c9a36a (patch)
treec859a8ed4fbd753d902238815312f7ec96395098
parent93e1f588ae07613878b2efcc11edac4a09336047 (diff)
downloadopenembedded-8d6e6182ecebc4300a77ba5ac66f437e54c9a36a.tar.gz
ti-dmai: remove ti-dmai.inc and put everything in a single recipe
Signed-off-by: Koen Kooi <k-kooi@ti.com>
-rw-r--r--recipes/ti/ti-dmai.inc30
-rw-r--r--recipes/ti/ti-dmai_svn.bb36
2 files changed, 33 insertions, 33 deletions
diff --git a/recipes/ti/ti-dmai.inc b/recipes/ti/ti-dmai.inc
deleted file mode 100644
index 5a61065567..0000000000
--- a/recipes/ti/ti-dmai.inc
+++ /dev/null
@@ -1,30 +0,0 @@
-DESCRIPTION = "DMAI for TI ARM/DSP processors"
-
-BRANCH = "branches/BRANCH_BRIJESH_DMAI_DEV_2_xx"
-BRANCH_omapl138 = "trunk"
-BRANCH_omapl137 = "trunk"
-BRANCH_dm6467 = "branches/GITPSP_INT_101009"
-BRANCH_dm355 = "branches/GITPSP_INT_101009"
-BRANCH_dm365 = "branches/GITPSP_INT_101009"
-
-SRCREV = "423"
-SRCREV_dm6467 = "424"
-SRCREV_dm355 = "424"
-SRCREV_dm365 = "424"
-
-SRC_URI = "svn://gforge.ti.com/svn/dmai/;module=${BRANCH};proto=https;user=anonymous;pswd='' \
- file://loadmodules-ti-dmai-dm355_al.sh \
- file://loadmodules-ti-dmai-dm365_al.sh \
- file://loadmodules-ti-dmai-dm6446_al.sh \
- file://loadmodules-ti-dmai-dm6467_al.sh \
- file://loadmodules-ti-dmai-o3530_al.sh \
- file://loadmodules-ti-dmai-ol138_al.sh \
- "
-
-S = "${WORKDIR}/${BRANCH}/davinci_multimedia_application_interface"
-
-# Yes, the xdc stuff still breaks with a '.' in PWD
-PE = "1"
-PV = "1.0+svnr${SRCPV}"
-
-INHIBIT_PACKAGE_STRIP = "1"
diff --git a/recipes/ti/ti-dmai_svn.bb b/recipes/ti/ti-dmai_svn.bb
index 429beb63ee..8724872fa7 100644
--- a/recipes/ti/ti-dmai_svn.bb
+++ b/recipes/ti/ti-dmai_svn.bb
@@ -1,10 +1,40 @@
-require ti-dmai.inc
-require ti-paths.inc
+DESCRIPTION = "DMAI for TI ARM/DSP processors"
+require ti-paths.inc
inherit module-base
#This is a kernel module, don't set PR directly
-MACHINE_KERNEL_PR_append = "c"
+MACHINE_KERNEL_PR_append = "d"
+
+# Yes, the xdc stuff still breaks with a '.' in PWD
+PE = "1"
+PV = "1.0+svnr${SRCPV}"
+
+BRANCH = "branches/BRANCH_BRIJESH_DMAI_DEV_2_xx"
+BRANCH_omapl138 = "trunk"
+BRANCH_omapl137 = "trunk"
+BRANCH_dm6467 = "branches/GITPSP_INT_101009"
+BRANCH_dm355 = "branches/GITPSP_INT_101009"
+BRANCH_dm365 = "branches/GITPSP_INT_101009"
+BRANCH_omap3 = "trunk"
+
+SRCREV = "423"
+SRCREV_dm6467 = "424"
+SRCREV_dm355 = "424"
+SRCREV_dm365 = "424"
+
+SRC_URI = "svn://gforge.ti.com/svn/dmai/;module=${BRANCH};proto=https;user=anonymous;pswd='' \
+ file://loadmodules-ti-dmai-dm355_al.sh \
+ file://loadmodules-ti-dmai-dm365_al.sh \
+ file://loadmodules-ti-dmai-dm6446_al.sh \
+# file://loadmodules-ti-dmai-dm6467_al.sh \
+ file://loadmodules-ti-dmai-o3530_al.sh \
+ file://loadmodules-ti-dmai-ol138_al.sh \
+ "
+
+S = "${WORKDIR}/${BRANCH}/davinci_multimedia_application_interface"
+
+INHIBIT_PACKAGE_STRIP = "1"
# compile time dependencies
DEPENDS = "alsa-lib ti-framework-components ti-codec-engine ti-xdctools"