aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteve Sakoman <steve@sakoman.com>2009-08-04 11:08:53 -0700
committerKoen Kooi <koen@openembedded.org>2009-08-08 11:20:02 +0200
commit8e40f0f867f6c00bccb225df67598e992086eb0b (patch)
tree267e54b489ce38124c13edd1f8b16f87656bc94a
parentdb6f9ba936fc76e83d9f32a73ea76b17a1f797c5 (diff)
downloadopenembedded-8e40f0f867f6c00bccb225df67598e992086eb0b.tar.gz
alsa-plugins: add 1.0.20
-rw-r--r--conf/checksums.ini4
-rw-r--r--recipes/alsa/alsa-plugins_1.0.20.bb22
2 files changed, 26 insertions, 0 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index 26edb2eb4b..0ddfe28dd4 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -1486,6 +1486,10 @@ sha256=deb7652a3c1360febbbffb5d0150e5ad8547063d37969ad24d13359f75a424ba
md5=29ae9cac05423cf6a49f66eeb1a79eb6
sha256=67be087c24af9d2a380b29d6e90b7187b337a0c484c31438a0d38ff429c71100
+[ftp://ftp.alsa-project.org/pub/plugins/alsa-plugins-1.0.20.tar.bz2]
+md5=819c4f21e3e913eacefd32993a8fbed7
+sha256=210ceedcb84bf3030e9f362d55b734312632ce72e348bd758536ec62a37aac97
+
[ftp://ftp.alsa-project.org/pub/utils/alsa-utils-1.0.11.tar.bz2]
md5=ba9b8010120701d0f6daf061d392cfa2
sha256=4b33229437ddab4196b8fd0bdfaf074314185a5afd3e24bbe28025022b42d01b
diff --git a/recipes/alsa/alsa-plugins_1.0.20.bb b/recipes/alsa/alsa-plugins_1.0.20.bb
new file mode 100644
index 0000000000..cc48e3c50b
--- /dev/null
+++ b/recipes/alsa/alsa-plugins_1.0.20.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "ALSA Plugins"
+HOMEPAGE = "http://www.alsa-project.org"
+SECTION = "multimedia/alsa/plugins"
+LICENSE = "GPL"
+DEPENDS = "alsa-lib pulseaudio ffmpeg"
+PR = "r1"
+
+SRC_URI = "ftp://ftp.alsa-project.org/pub/plugins/alsa-plugins-${PV}.tar.bz2"
+
+inherit autotools
+
+CFLAGS += "-lavutil"
+
+PACKAGES_DYNAMIC = "libasound-module*"
+
+python populate_packages_prepend() {
+ plugindir = bb.data.expand('${libdir}/alsa-lib/', d)
+ do_split_packages(d, plugindir, '^libasound_module_(.*)\.so$', 'libasound-module-%s', 'Alsa plugin for %s', extra_depends='' )
+}
+
+FILES_${PN}-dev += "${libdir}/alsa-lib/libasound*.a ${libdir}/alsa-lib/libasound*.la"
+FILES_${PN}-dbg += "${libdir}/alsa-lib/.debug"