aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-03-19 10:45:34 +0100
committerKoen Kooi <koen@openembedded.org>2010-03-19 10:45:34 +0100
commit96b8c73a385eaf72685d99295e892367956c9118 (patch)
tree759e24ab5c45c99a610732e4adda5d1fa6681154
parentb34c4a2a273c29b788f1bcdcd54b43529755aa3c (diff)
downloadopenembedded-96b8c73a385eaf72685d99295e892367956c9118.tar.gz
pixman git: revert a commit that breaks thumb, reported by Martin Jansa
-rw-r--r--recipes/xorg-lib/pixman/0006-Revert-ARM-SIMD-Try-without-any-CFLAGS-before-forcin.patch53
-rw-r--r--recipes/xorg-lib/pixman_git.bb3
2 files changed, 55 insertions, 1 deletions
diff --git a/recipes/xorg-lib/pixman/0006-Revert-ARM-SIMD-Try-without-any-CFLAGS-before-forcin.patch b/recipes/xorg-lib/pixman/0006-Revert-ARM-SIMD-Try-without-any-CFLAGS-before-forcin.patch
new file mode 100644
index 0000000000..3d8d4e8292
--- /dev/null
+++ b/recipes/xorg-lib/pixman/0006-Revert-ARM-SIMD-Try-without-any-CFLAGS-before-forcin.patch
@@ -0,0 +1,53 @@
+From 7f0adaef68c5b0bb1c5eb9f5db5792b71b8b8beb Mon Sep 17 00:00:00 2001
+From: Koen Kooi <koen@dominion.thruhere.net>
+Date: Fri, 19 Mar 2010 10:44:09 +0100
+Subject: [PATCH 6/6] Revert "ARM: SIMD: Try without any CFLAGS before forcing -mcpu="
+
+This forces -marm that results in runtime SIGILL on thumb userspace
+
+This reverts commit 18f0de452dc7e12e4cb544d761a626d5c6031663.
+---
+ configure.ac | 20 +++++---------------
+ 1 files changed, 5 insertions(+), 15 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index fc3ee24..f84a4dc 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -363,28 +363,18 @@ AM_CONDITIONAL(USE_VMX, test $have_vmx_intrinsics = yes)
+
+ dnl ===========================================================================
+ dnl Check for ARM SIMD instructions
+-ARM_SIMD_CFLAGS=""
++ARM_SIMD_CFLAGS="-mcpu=arm1136j-s"
+
+ have_arm_simd=no
+ AC_MSG_CHECKING(whether to use ARM SIMD assembler)
+-# check with default CFLAGS in case the toolchain turns on a sufficiently recent -mcpu=
++xserver_save_CFLAGS=$CFLAGS
++CFLAGS="$ARM_SIMD_CFLAGS $CFLAGS"
+ AC_COMPILE_IFELSE([
+ int main () {
+ asm("uqadd8 r1, r1, r2");
+ return 0;
+-}], have_arm_simd=yes,
+- # check again with an explicit -mcpu= in case the toolchain defaults to an
+- # older one; note that uqadd8 isn't available in Thumb mode on arm1136j-s
+- # so we force ARM mode
+- ARM_SIMD_CFLAGS="-mcpu=arm1136j-s -marm"
+- xserver_save_CFLAGS=$CFLAGS
+- CFLAGS="$ARM_SIMD_CFLAGS $CFLAGS"
+- AC_COMPILE_IFELSE([
+- int main () {
+- asm("uqadd8 r1, r1, r2");
+- return 0;
+- }], have_arm_simd=yes)
+- CFLAGS=$xserver_save_CFLAGS)
++}], have_arm_simd=yes)
++CFLAGS=$xserver_save_CFLAGS
+
+ AC_ARG_ENABLE(arm-simd,
+ [AC_HELP_STRING([--disable-arm-simd],
+--
+1.6.6.1
+
diff --git a/recipes/xorg-lib/pixman_git.bb b/recipes/xorg-lib/pixman_git.bb
index 52224ef4fe..543cf50f9f 100644
--- a/recipes/xorg-lib/pixman_git.bb
+++ b/recipes/xorg-lib/pixman_git.bb
@@ -4,7 +4,7 @@ DESCRIPTION = "Low-level pixel manipulation library."
LICENSE = "X11"
PV = "0.17.13"
-PR = "r0"
+PR = "r1"
PR_append = "+gitr${SRCREV}"
BBCLASSEXTEND="native"
@@ -19,6 +19,7 @@ SRC_URI = "git://anongit.freedesktop.org/pixman;protocol=git;branch=master \
file://0003-Support-of-overlapping-src-dst-for-pixman_blt_sse2.patch;patch=1 \
file://0004-Support-of-overlapping-src-dst-for-pixman_blt_neon.patch;patch=1 \
file://0005-ARM-added-NEON-optimizations-for-fetch-store-r5g6b5-.patch;patch=1 \
+ file://0006-Revert-ARM-SIMD-Try-without-any-CFLAGS-before-forcin.patch;patch=1 \
file://over-n-8-0565.patch;patch=1 \
file://src-8888-0565.patch;patch=1 \
"