aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGraham Gower <graham.gower@gmail.com>2010-10-18 20:14:06 +0000
committerKhem Raj <raj.khem@gmail.com>2010-10-20 18:30:22 -0700
commitb72db8f97f6c060aeb2a33ffacefccd7a3df9889 (patch)
treea7565ac91fd126eb81303fc84232702b3b412f87
parentf4bd3c4532c849d85cea1f0649d37334fe1384ac (diff)
downloadopenembedded-b72db8f97f6c060aeb2a33ffacefccd7a3df9889.tar.gz
nail_11.21.bb: Fix build failure due to dumbness in a configure-like script.
Presumably this build failure is due to a race condition, whereby the LIBS file contains some garbage when it is autogenerated by the 'makeconfig' script. mipsel-oe-linux-gcc -march=mips32 -L/mnt/oe/tmp/sysroots/mipsel-oe-linux/usr/lib -Wl,-rpath-link,/mnt/oe/tmp/sysroots/mipsel-oe-linux/usr/lib -Wl,-O1 aux.o base64.o cache.o cmd1.o cmd2.o cmd3.o cmdtab.o collect.o dotlock.o edit.o fio.o getname.o getopt.o head.o hmac.o imap.o imap_search.o junk.o lex.o list.o lzw.o macro.o maildir.o main.o md5.o mime.o names.o nss.o openssl.o pop3.o popen.o quit.o send.o sendout.o smtp.o ssl.o strings.o temp.o thread.o tty.o v7.local.o vars.o version.o `grep '^[^#]' LIBS` -o nail mipsel-oe-linux-gcc: o: No such file or directory mipsel-oe-linux-gcc: make: No such file or directory mipsel-oe-linux-gcc: grep: No such file or directory mipsel-oe-linux-gcc: happy: No such file or directory make: *** [nail] Error 1 Signed-off-by: Graham Gower <graham.gower@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes/nail/files/makeconfig.FILES.patch22
-rw-r--r--recipes/nail/nail_11.21.bb5
2 files changed, 25 insertions, 2 deletions
diff --git a/recipes/nail/files/makeconfig.FILES.patch b/recipes/nail/files/makeconfig.FILES.patch
new file mode 100644
index 0000000000..cddd14f5fe
--- /dev/null
+++ b/recipes/nail/files/makeconfig.FILES.patch
@@ -0,0 +1,22 @@
+--- nail-11.21/makeconfig.orig 2010-10-19 12:16:14.000000000 +1030
++++ nail-11.21/makeconfig 2010-10-19 12:16:39.000000000 +1030
+@@ -74,7 +74,7 @@
+ echo '************************************************************'
+ msg "checking $topic ... "
+ echo "/* checked $topic */" >>$out
+- cp $lib $tmp2
++# cp $lib $tmp2
+ rm -f $tmp $tmp.o
+ echo '*** test program is'
+ tee $tmp.c
+@@ -86,8 +86,8 @@
+ then
+ msg "okay\\n"
+ echo "$define" >>$out
+- echo "$libs" >$lib
+- cat $tmp2 >>$lib
++ echo "$libs" >>$lib
++# cat $tmp2 >>$lib
+ return 0
+ else
+ msg "no\\n"
diff --git a/recipes/nail/nail_11.21.bb b/recipes/nail/nail_11.21.bb
index 26eece030a..29456c2a41 100644
--- a/recipes/nail/nail_11.21.bb
+++ b/recipes/nail/nail_11.21.bb
@@ -2,11 +2,12 @@ DESCRIPTION = "Enhanced mailx client."
SECTION = "console/network"
PRIORITY = "optional"
DEPENDS = "openssl"
-PR = "r2"
+PR = "r3"
LICENSE = "GPL"
SRC_URI = "http://optusnet.dl.sourceforge.net/sourceforge/nail/nail-11.21.tar.bz2 \
- file://nail.spec.diff"
+ file://nail.spec.diff \
+ file://makeconfig.FILES.patch"
S = "${WORKDIR}/nail-11.21/"