aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGraham Gower <graham.gower@gmail.com>2010-09-29 15:00:12 +0000
committerKhem Raj <raj.khem@gmail.com>2010-09-30 13:15:07 -0700
commitf4d1cd6975bc224b32a6f0350658147244ce4ada (patch)
treedf627fe5d429009ea87029f8db12e48f925b8e5e
parent6ccae1e558a51eb919a59b19e480742b88f1224e (diff)
downloadopenembedded-f4d1cd6975bc224b32a6f0350658147244ce4ada.tar.gz
gdb: Don't clobber files installed by binutils.
Also, move INC_PR into gdb-common.inc and propagate it into all recipes. Signed-off-by: Graham Gower <graham.gower@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes/gdb/gdb-canadian-sdk_6.8.bb2
-rw-r--r--recipes/gdb/gdb-canadian-sdk_7.0.bb2
-rw-r--r--recipes/gdb/gdb-canadian-sdk_7.1.bb2
-rw-r--r--recipes/gdb/gdb-common.inc9
-rw-r--r--recipes/gdb/gdb-cross-sdk.inc2
-rw-r--r--recipes/gdb/gdb-cross_6.3.bb2
-rw-r--r--recipes/gdb/gdb-cross_6.4.bb2
-rw-r--r--recipes/gdb/gdb-cross_6.6.bb2
-rw-r--r--recipes/gdb/gdb-cross_6.7.1.bb2
-rw-r--r--recipes/gdb/gdb-cross_6.8.bb2
-rw-r--r--recipes/gdb/gdb-cross_7.0.bb2
-rw-r--r--recipes/gdb/gdb-cross_7.1.bb2
-rw-r--r--recipes/gdb/gdb_6.3.bb2
-rw-r--r--recipes/gdb/gdb_6.4.bb2
-rw-r--r--recipes/gdb/gdb_6.6.bb2
-rw-r--r--recipes/gdb/gdb_6.7.1.bb2
-rw-r--r--recipes/gdb/gdb_6.8.bb2
-rw-r--r--recipes/gdb/gdb_7.0.bb2
-rw-r--r--recipes/gdb/gdb_7.1.bb2
-rw-r--r--recipes/gdb/gdbserver.inc2
20 files changed, 27 insertions, 20 deletions
diff --git a/recipes/gdb/gdb-canadian-sdk_6.8.bb b/recipes/gdb/gdb-canadian-sdk_6.8.bb
index 8051b02d21..8c9567bf4f 100644
--- a/recipes/gdb/gdb-canadian-sdk_6.8.bb
+++ b/recipes/gdb/gdb-canadian-sdk_6.8.bb
@@ -7,7 +7,7 @@ SRC_URI += "file://gcc-4.3-build-error.patch;striplevel=0 \
file://gdb-6.8-fix-compile-karmic.patch \
file://gdb-6.8-mips-mingw-sim-fixup.patch"
-PR = "r1"
+PR = "${INC_PR}.1"
SRC_URI[md5sum] = "925695333524108291dc4012c4c9cbb8"
SRC_URI[sha256sum] = "a3c5455f30ffb3e6eeafb9e54598b48f9fbf46e3e99f431120360c183ddcc889"
diff --git a/recipes/gdb/gdb-canadian-sdk_7.0.bb b/recipes/gdb/gdb-canadian-sdk_7.0.bb
index b9001cdcbd..22e94a6255 100644
--- a/recipes/gdb/gdb-canadian-sdk_7.0.bb
+++ b/recipes/gdb/gdb-canadian-sdk_7.0.bb
@@ -7,5 +7,7 @@ SRC_URI += "\
file://gdb-6.8-fix-compile-karmic.patch \
"
+PR = "${INC_PR}.0"
+
SRC_URI[md5sum] = "67b4144db385620d7b93f7b0c26800f7"
SRC_URI[sha256sum] = "ccff6cab0e847c486d30b70bdddac4e6646bafcecaa3b63134d6e3d4d5a4b91d"
diff --git a/recipes/gdb/gdb-canadian-sdk_7.1.bb b/recipes/gdb/gdb-canadian-sdk_7.1.bb
index 95b91951e4..a166f8ff39 100644
--- a/recipes/gdb/gdb-canadian-sdk_7.1.bb
+++ b/recipes/gdb/gdb-canadian-sdk_7.1.bb
@@ -7,5 +7,7 @@ SRC_URI += "\
file://gdb-6.8-fix-compile-karmic.patch \
"
+PR = "${INC_PR}.0"
+
SRC_URI[md5sum] = "01a6ce13bab5307cfac5c405e4afd1cf"
SRC_URI[sha256sum] = "fc839b5226b94e58a5c7a526e67b7f8f93c7829d05dae1b6247f1bfe3829f291"
diff --git a/recipes/gdb/gdb-common.inc b/recipes/gdb/gdb-common.inc
index c3eef690d7..344c10b4db 100644
--- a/recipes/gdb/gdb-common.inc
+++ b/recipes/gdb/gdb-common.inc
@@ -4,6 +4,8 @@ LICENSE="GPL"
SECTION = "devel"
PRIORITY = "optional"
+INC_PR = "r8"
+
inherit autotools
SRC_URI = "${GNU_MIRROR}/gdb/gdb-${PV}.tar.gz"
@@ -31,7 +33,12 @@ do_install_append() {
# We use libiberty from binutils
rm -f ${D}${prefix}/${TARGET_SYS}/lib/libiberty.a
- rm -f ${D}${libdir}/libiberty.a
+ rm -f ${D}${prefix}/lib{,64}/libiberty.a
+
+ # Use libbfd from binutils.
+ rm -f ${D}${prefix}/lib/libbfd.{,l}a
+ # Use libopcodes from binutils.
+ rm -f ${D}${prefix}/lib/libopcodes.{,l}a
}
diff --git a/recipes/gdb/gdb-cross-sdk.inc b/recipes/gdb/gdb-cross-sdk.inc
index 3e214fe957..bd7f0dfa98 100644
--- a/recipes/gdb/gdb-cross-sdk.inc
+++ b/recipes/gdb/gdb-cross-sdk.inc
@@ -1,8 +1,6 @@
require gdb-cross.inc
LICENSE = "GPLv3"
-INC_PR = "r7"
-
inherit sdk
DEPENDS = "ncurses-sdk zlib-sdk flex-native"
diff --git a/recipes/gdb/gdb-cross_6.3.bb b/recipes/gdb/gdb-cross_6.3.bb
index dd066fbe5e..c3e5cc0d39 100644
--- a/recipes/gdb/gdb-cross_6.3.bb
+++ b/recipes/gdb/gdb-cross_6.3.bb
@@ -1,7 +1,7 @@
require gdb-cross.inc
LICENSE = "GPLv2"
-PR = "r4"
+PR = "${INC_PR}.4"
SRC_URI += "file://sim-install-makefile.patch \
file://sim-install-makefile-common.patch"
diff --git a/recipes/gdb/gdb-cross_6.4.bb b/recipes/gdb/gdb-cross_6.4.bb
index 268e210021..a91d15427f 100644
--- a/recipes/gdb/gdb-cross_6.4.bb
+++ b/recipes/gdb/gdb-cross_6.4.bb
@@ -1,7 +1,7 @@
require gdb-cross.inc
LICENSE = "GPLv2"
-PR = "r2"
+PR = "${INC_PR}.2"
SRC_URI[md5sum] = "7dc98022ee96bba5331f195dc8a5491a"
SRC_URI[sha256sum] = "719f2bbd79d55cdd6f5e31b49cec49df71ddb32a4439dba678de0e09330096da"
diff --git a/recipes/gdb/gdb-cross_6.6.bb b/recipes/gdb/gdb-cross_6.6.bb
index d91c030474..733c1a424f 100644
--- a/recipes/gdb/gdb-cross_6.6.bb
+++ b/recipes/gdb/gdb-cross_6.6.bb
@@ -1,7 +1,7 @@
require gdb-cross.inc
LICENSE = "GPLv2"
-PR = "r4"
+PR = "${INC_PR}.4"
SRC_URI += "file://early_debug_in_nptl.patch;striplevel=0"
diff --git a/recipes/gdb/gdb-cross_6.7.1.bb b/recipes/gdb/gdb-cross_6.7.1.bb
index ccc01d120f..2d3d1f8ab4 100644
--- a/recipes/gdb/gdb-cross_6.7.1.bb
+++ b/recipes/gdb/gdb-cross_6.7.1.bb
@@ -1,7 +1,7 @@
require gdb-cross.inc
LICENSE = "GPLv3"
-PR = "r1"
+PR = "${INC_PR}.1"
DEFAULT_PREFERENCE_avr32 = "99"
SRC_URI_avr32 = " http://avr32linux.org/twiki/pub/Main/GDBPatches/gdb-6.7.1.atmel.1.0.3.tar.bz2"
diff --git a/recipes/gdb/gdb-cross_6.8.bb b/recipes/gdb/gdb-cross_6.8.bb
index dba7c48481..ca0f09f338 100644
--- a/recipes/gdb/gdb-cross_6.8.bb
+++ b/recipes/gdb/gdb-cross_6.8.bb
@@ -4,7 +4,7 @@ LICENSE = "GPLv3"
SRC_URI += "file://gcc-4.3-build-error.patch;striplevel=0 \
file://gdb-6.8-fix-compile-karmic.patch"
-PR = "r4"
+PR = "${INC_PR}.4"
SRC_URI[md5sum] = "925695333524108291dc4012c4c9cbb8"
SRC_URI[sha256sum] = "a3c5455f30ffb3e6eeafb9e54598b48f9fbf46e3e99f431120360c183ddcc889"
diff --git a/recipes/gdb/gdb-cross_7.0.bb b/recipes/gdb/gdb-cross_7.0.bb
index 026a7c05ce..46f27aba1e 100644
--- a/recipes/gdb/gdb-cross_7.0.bb
+++ b/recipes/gdb/gdb-cross_7.0.bb
@@ -1,7 +1,7 @@
require gdb-cross.inc
LICENSE = "GPLv3"
-PR = "r1"
+PR = "${INC_PR}.1"
SRC_URI += " \
file://gdb-6.8-fix-compile-karmic.patch"
diff --git a/recipes/gdb/gdb-cross_7.1.bb b/recipes/gdb/gdb-cross_7.1.bb
index 64a1b5799b..97ac04cba9 100644
--- a/recipes/gdb/gdb-cross_7.1.bb
+++ b/recipes/gdb/gdb-cross_7.1.bb
@@ -1,7 +1,7 @@
require gdb-cross.inc
LICENSE = "GPLv3"
-PR = "r1"
+PR = "${INC_PR}.1"
SRC_URI += " \
file://gdb-6.8-fix-compile-karmic.patch \
diff --git a/recipes/gdb/gdb_6.3.bb b/recipes/gdb/gdb_6.3.bb
index 0ebc2e00cf..e49dd25e64 100644
--- a/recipes/gdb/gdb_6.3.bb
+++ b/recipes/gdb/gdb_6.3.bb
@@ -1,7 +1,7 @@
require gdb.inc
LICENSE = "GPLv2"
-PR = "r6"
+PR = "${INC_PR}.6"
SRC_URI[md5sum] = "812de9e756d53c749ea5516d9ffa5905"
SRC_URI[sha256sum] = "c06bf9715436b3a28c189163aa5ca42b46af8286659827f033eaaf7d8b1fc342"
diff --git a/recipes/gdb/gdb_6.4.bb b/recipes/gdb/gdb_6.4.bb
index 9eff83f0e9..db65203895 100644
--- a/recipes/gdb/gdb_6.4.bb
+++ b/recipes/gdb/gdb_6.4.bb
@@ -1,7 +1,7 @@
require gdb.inc
LICENSE = "GPLv2"
-PR = "r4"
+PR = "${INC_PR}.4"
SRC_URI[md5sum] = "7dc98022ee96bba5331f195dc8a5491a"
SRC_URI[sha256sum] = "719f2bbd79d55cdd6f5e31b49cec49df71ddb32a4439dba678de0e09330096da"
diff --git a/recipes/gdb/gdb_6.6.bb b/recipes/gdb/gdb_6.6.bb
index 24c193f9ca..b630bed4eb 100644
--- a/recipes/gdb/gdb_6.6.bb
+++ b/recipes/gdb/gdb_6.6.bb
@@ -1,7 +1,7 @@
require gdb.inc
LICENSE = "GPLv2"
-PR = "r7"
+PR = "${INC_PR}.7"
SRC_URI += "file://early_debug_in_nptl.patch;striplevel=0"
diff --git a/recipes/gdb/gdb_6.7.1.bb b/recipes/gdb/gdb_6.7.1.bb
index 9f599782c2..d1512a1fa5 100644
--- a/recipes/gdb/gdb_6.7.1.bb
+++ b/recipes/gdb/gdb_6.7.1.bb
@@ -1,7 +1,7 @@
require gdb.inc
LICENSE = "GPLv3"
-PR = "r3"
+PR = "${INC_PR}.3"
DEFAULT_PREFERENCE_avr32 = "99"
SRC_URI_avr32 = " http://avr32linux.org/twiki/pub/Main/GDBPatches/gdb-6.7.1.atmel.1.0.3.tar.bz2"
diff --git a/recipes/gdb/gdb_6.8.bb b/recipes/gdb/gdb_6.8.bb
index 630ca9ec09..616da7256b 100644
--- a/recipes/gdb/gdb_6.8.bb
+++ b/recipes/gdb/gdb_6.8.bb
@@ -4,7 +4,7 @@ LICENSE = "GPLv3"
SRC_URI += "file://gcc-4.3-build-error.patch;striplevel=0 \
file://gdb-6.8-fix-compile-karmic.patch"
-PR = "r5"
+PR = "${INC_PR}.5"
SRC_URI[md5sum] = "925695333524108291dc4012c4c9cbb8"
SRC_URI[sha256sum] = "a3c5455f30ffb3e6eeafb9e54598b48f9fbf46e3e99f431120360c183ddcc889"
diff --git a/recipes/gdb/gdb_7.0.bb b/recipes/gdb/gdb_7.0.bb
index 96c267cdd0..abcde9548f 100644
--- a/recipes/gdb/gdb_7.0.bb
+++ b/recipes/gdb/gdb_7.0.bb
@@ -1,7 +1,7 @@
require gdb.inc
LICENSE = "GPLv3"
-PR = "r2"
+PR = "${INC_PR}.2"
SRC_URI += "\
file://gdb-6.8-fix-compile-karmic.patch"
diff --git a/recipes/gdb/gdb_7.1.bb b/recipes/gdb/gdb_7.1.bb
index 8caab0fb11..5b0f5c9c96 100644
--- a/recipes/gdb/gdb_7.1.bb
+++ b/recipes/gdb/gdb_7.1.bb
@@ -1,7 +1,7 @@
require gdb.inc
LICENSE = "GPLv3"
-PR = "r4"
+PR = "${INC_PR}.4"
# there is a bug in GCC for SH4 it ICE's at Optlevel >O1
# so workaround that for now.
diff --git a/recipes/gdb/gdbserver.inc b/recipes/gdb/gdbserver.inc
index 115f293578..a976000418 100644
--- a/recipes/gdb/gdbserver.inc
+++ b/recipes/gdb/gdbserver.inc
@@ -1,7 +1,5 @@
require gdb-common.inc
-INC_PR = "r2"
-
DEFAULT_PREFERENCE_avr32 = "-99"
FILES_gdbserver = "${bindir}/gdbserver"