aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2009-03-24 15:44:58 -0700
committerKhem Raj <raj.khem@gmail.com>2009-03-24 15:44:58 -0700
commitff0001fd335d2dd49dd34001afdf97e6fa974fef (patch)
tree005492be2c197e48aceef54f3949ddd0f48e768f
parentba18a4e16b0082c45c3b5486b4d5ac2891b8642e (diff)
downloadopenembedded-ff0001fd335d2dd49dd34001afdf97e6fa974fef.tar.gz
strace_4.5.15: Replace the use of linux/dirent{64].h
-rw-r--r--recipes/strace/strace-4.5.15/strace-dont-include-linux-dirent-h.patch23
-rw-r--r--recipes/strace/strace_4.5.15.bb2
2 files changed, 25 insertions, 0 deletions
diff --git a/recipes/strace/strace-4.5.15/strace-dont-include-linux-dirent-h.patch b/recipes/strace/strace-4.5.15/strace-dont-include-linux-dirent-h.patch
new file mode 100644
index 0000000000..1d50251417
--- /dev/null
+++ b/recipes/strace/strace-4.5.15/strace-dont-include-linux-dirent-h.patch
@@ -0,0 +1,23 @@
+Index: strace-4.5.14/file.c
+===================================================================
+--- strace-4.5.14.orig/file.c 2009-03-24 08:35:13.000000000 -0700
++++ strace-4.5.14/file.c 2009-03-24 08:39:43.000000000 -0700
+@@ -35,12 +35,12 @@
+
+ #include <dirent.h>
+ #ifdef LINUX
+-#define dirent kernel_dirent
+-#define dirent64 kernel_dirent64
+-#include <linux/types.h>
+-#include <linux/dirent.h>
+-#undef dirent
+-#undef dirent64
++struct kernel_dirent {
++ unsigned long d_ino;
++ unsigned long d_off;
++ unsigned short d_reclen;
++ char d_name[1];
++};
+ #else
+ #define kernel_dirent dirent
+ #endif
diff --git a/recipes/strace/strace_4.5.15.bb b/recipes/strace/strace_4.5.15.bb
index e73fb0f732..049706c6ff 100644
--- a/recipes/strace/strace_4.5.15.bb
+++ b/recipes/strace/strace_4.5.15.bb
@@ -1,12 +1,14 @@
DESCRIPTION = "strace is a system call tracing tool."
SECTION = "console/utils"
LICENSE = "GPL"
+PR = "r1"
# this recipe is missing patches for arm and sh
DEFAULT_PREFERENCE = "-1"
DEFAULT_PREFERENCE_avr32 = "1"
SRC_URI = "${SOURCEFORGE_MIRROR}/strace/strace-${PV}.tar.bz2 \
+ file://strace-dont-include-linux-dirent-h.patch;patch=1 \
"
SRC_URI_avr32 = "${SOURCEFORGE_MIRROR}/strace/strace-${PV}.tar.bz2 \