aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-09-04 22:59:20 +0000
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-09-09 21:09:59 +0200
commit141f355dcc7410efe3bf23b3dfa7c4ac20062d3d (patch)
tree4d52fef0d15486c8d1ff21f0412fe57054f3b7c4
parent8cbafd29ff0ddc4f26af2d0d891f0eaa2bb19779 (diff)
downloadopenembedded-141f355dcc7410efe3bf23b3dfa7c4ac20062d3d.tar.gz
js: fixed libtermcap
the new ncurses does not have libtermcap this patches -ltermcap into -lncurses also added ncurses to DEPENDS Signed-off-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
-rw-r--r--recipes/js/files/libtermcap.patch13
-rw-r--r--recipes/js/js_1.5.bb5
2 files changed, 16 insertions, 2 deletions
diff --git a/recipes/js/files/libtermcap.patch b/recipes/js/files/libtermcap.patch
new file mode 100644
index 0000000000..045b4fb565
--- /dev/null
+++ b/recipes/js/files/libtermcap.patch
@@ -0,0 +1,13 @@
+Index: src/Makefile.ref
+===================================================================
+--- src.orig/Makefile.ref
++++ src/Makefile.ref
+@@ -127,7 +127,7 @@ endif
+ ifdef JS_READLINE
+ # For those platforms with the readline library installed.
+ DEFINES += -DEDITLINE
+-PROG_LIBS += -lreadline -ltermcap
++PROG_LIBS += -lreadline -lncurses
+ else
+ ifdef JS_EDITLINE
+ # Use the editline library, built locally.
diff --git a/recipes/js/js_1.5.bb b/recipes/js/js_1.5.bb
index eb92b24a63..f9aba904aa 100644
--- a/recipes/js/js_1.5.bb
+++ b/recipes/js/js_1.5.bb
@@ -1,11 +1,12 @@
DESCRIPTION = "A JavaScript engine"
LICENSE = "GPL"
SECTION = "libs/network"
-DEPENDS = "readline"
+DEPENDS = "readline ncurses"
-PR = "r1"
+PR = "r2"
SRC_URI = "http://ftp.mozilla.org/pub/mozilla.org/js/older-packages/js-1.5.tar.gz \
+ file://libtermcap.patch \
file://jsautocfg.h"
S = "${WORKDIR}/js/src"