aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-09-26 09:24:51 -0700
committerKhem Raj <raj.khem@gmail.com>2010-09-26 09:43:18 -0700
commit62130292afa62528c479857289baebabd4ca3e03 (patch)
treec539fda4e2532b54c5609c9ff1a00ec783aec6d4
parent91d2b176602f95f07573f3025466105497f24bb4 (diff)
downloadopenembedded-62130292afa62528c479857289baebabd4ca3e03.tar.gz
gcc: Make use of INC_PR consistently.
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes/gcc/gcc-cross-sdk_4.5.bb3
-rw-r--r--recipes/gcc/gcc-cross-sdk_svn.bb3
-rw-r--r--recipes/gcc/gcc-cross_4.5.bb3
-rw-r--r--recipes/gcc/gcc-cross_svn.bb2
-rw-r--r--recipes/gcc/gcc-svn.inc2
-rw-r--r--recipes/gcc/gcc_svn.bb2
6 files changed, 7 insertions, 8 deletions
diff --git a/recipes/gcc/gcc-cross-sdk_4.5.bb b/recipes/gcc/gcc-cross-sdk_4.5.bb
index e8ef4e2616..f96607e64e 100644
--- a/recipes/gcc/gcc-cross-sdk_4.5.bb
+++ b/recipes/gcc/gcc-cross-sdk_4.5.bb
@@ -1,9 +1,8 @@
-PR = "r4"
-
inherit sdk
require gcc-${PV}.inc
require gcc-cross-sdk.inc
+PR = "${INC_PR}.0"
EXTRA_OECONF += " --disable-libunwind-exceptions --with-mpfr=${STAGING_DIR_NATIVE}${prefix_native} --with-system-zlib"
diff --git a/recipes/gcc/gcc-cross-sdk_svn.bb b/recipes/gcc/gcc-cross-sdk_svn.bb
index 48d8a0d1ed..847aada8d6 100644
--- a/recipes/gcc/gcc-cross-sdk_svn.bb
+++ b/recipes/gcc/gcc-cross-sdk_svn.bb
@@ -1,11 +1,10 @@
-PR = "r1"
-
inherit sdk
require gcc-${PV}.inc
require gcc-cross-sdk.inc
require gcc-configure-sdk.inc
require gcc-package-sdk.inc
+PR = "${INC_PR}.0"
DEPENDS += "libmpc-native gmp-native mpfr-native"
diff --git a/recipes/gcc/gcc-cross_4.5.bb b/recipes/gcc/gcc-cross_4.5.bb
index a2da4a88e8..2719145b38 100644
--- a/recipes/gcc/gcc-cross_4.5.bb
+++ b/recipes/gcc/gcc-cross_4.5.bb
@@ -1,7 +1,8 @@
-PR = "r1"
require gcc-${PV}.inc
require gcc-cross4.inc
+PR = "${INC_PR}.0"
+
NATIVEDEPS += "libmpc-native libelf-native"
SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch "
diff --git a/recipes/gcc/gcc-cross_svn.bb b/recipes/gcc/gcc-cross_svn.bb
index 825a7bde8a..820829d42d 100644
--- a/recipes/gcc/gcc-cross_svn.bb
+++ b/recipes/gcc/gcc-cross_svn.bb
@@ -1,6 +1,6 @@
-PR = "r0"
require gcc-${PV}.inc
require gcc-cross4.inc
+PR = "${INC_PR}.0"
DEPENDS += "libmpc-native"
diff --git a/recipes/gcc/gcc-svn.inc b/recipes/gcc/gcc-svn.inc
index 2e24d63c1a..468f62b1f9 100644
--- a/recipes/gcc/gcc-svn.inc
+++ b/recipes/gcc/gcc-svn.inc
@@ -1,6 +1,6 @@
DEFAULT_PREFERENCE = "-999"
ARM_INSTRUCTION_SET = "arm"
-
+INC_PR = "r0"
SRCREV = "158653"
require gcc-common.inc
diff --git a/recipes/gcc/gcc_svn.bb b/recipes/gcc/gcc_svn.bb
index 40e1f7c3e5..9b69a23d11 100644
--- a/recipes/gcc/gcc_svn.bb
+++ b/recipes/gcc/gcc_svn.bb
@@ -1,7 +1,7 @@
-PR = "r0"
require gcc-${PV}.inc
require gcc-configure-target.inc
require gcc-package-target.inc
+PR = "${INC_PR}.0"
# Gcc 4.3.3 installs crt* in a '4.3.1' dir....
FILES_${PN} += "\