aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEnrico Scholz <enrico.scholz@informatik.tu-chemnitz.de>2010-03-28 12:29:01 +0200
committerEnrico Scholz <enrico.scholz@sigma-chemnitz.de>2010-07-15 11:38:00 +0200
commit9b5d718684ee37bfd117e02ea3af763847368788 (patch)
tree8c3a047614e5f872c80a2d9ac45cecf5750f974c
parent41a1d746604c9025873c61e223e7fceea4253ae9 (diff)
downloadopenembedded-9b5d718684ee37bfd117e02ea3af763847368788.tar.gz
dbus: use $(LIBTOOL) to install 'dbus-daemon'
Depending on autotools/libtool version and configure flags, dbus-daemon will be built sometimes below .libs/ and sometimes in base directory. Using 'libtool --mode=install' is a portable way to deal with this. Changing Makefile.am to use native automake methods to install this files would be a better but more invasive fix. Signed-off-by: Enrico Scholz <enrico.scholz@sigma-chemnitz.de>
-rw-r--r--recipes/dbus/dbus-1.2.24/fix-install-daemon.patch2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes/dbus/dbus-1.2.24/fix-install-daemon.patch b/recipes/dbus/dbus-1.2.24/fix-install-daemon.patch
index c31786357d..5e25d1227d 100644
--- a/recipes/dbus/dbus-1.2.24/fix-install-daemon.patch
+++ b/recipes/dbus/dbus-1.2.24/fix-install-daemon.patch
@@ -7,7 +7,7 @@ Index: dbus-0.94/bus/Makefile.am
chmod 755 $(DESTDIR)$(DBUS_DAEMONDIR); \
fi
- $(INSTALL_PROGRAM) dbus-daemon $(DESTDIR)$(DBUS_DAEMONDIR)
-+ $(INSTALL_PROGRAM) .libs/dbus-daemon $(DESTDIR)$(DBUS_DAEMONDIR)
++ $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) dbus-daemon $(DESTDIR)$(DBUS_DAEMONDIR)
$(mkinstalldirs) $(DESTDIR)$(localstatedir)/run/dbus
$(mkinstalldirs) $(DESTDIR)$(configdir)/system.d
$(mkinstalldirs) $(DESTDIR)$(datadir)/dbus-1/services