aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Schmidt <stefan@buglabs.net>2010-08-09 17:26:00 +0200
committerStefan Schmidt <stefan@datenfreihafen.org>2010-08-09 17:30:42 +0200
commit9b1a9d8fd143fdab0a169dfda77a5309d52f76a4 (patch)
treefb66a17d170e8d866aa3b05aa24affba37bed0ed
parent9d0e260c6020be6fb652dc0b637c05f05fda7af0 (diff)
downloadopenembedded-9b1a9d8fd143fdab0a169dfda77a5309d52f76a4.tar.gz
firmware: Add recipe to work with the marvell-sdio-tf-fw
-rw-r--r--recipes/firmwares/marvell-sdio-tf-fw_9.0.7-p2.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes/firmwares/marvell-sdio-tf-fw_9.0.7-p2.bb b/recipes/firmwares/marvell-sdio-tf-fw_9.0.7-p2.bb
new file mode 100644
index 0000000000..ff4272a58b
--- /dev/null
+++ b/recipes/firmwares/marvell-sdio-tf-fw_9.0.7-p2.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Firmware for Marvel 8686 gspi wifi chipset"
+LICENCE = "closed"
+
+SRC_URI = "file://${PV}.tar.gz \
+ file://Marvell-Licence.txt"
+
+S = "${WORKDIR}/${PV}/FwImage"
+
+do_install() {
+
+ install -d ${D}${base_libdir}/firmware
+ install -m 0644 sd8686tf.bin sd8686_helper.bin ${D}${base_libdir}/firmware
+ install -m 0644 ${WORKDIR}/Marvell-Licence.txt ${D}${base_libdir}/firmware
+}
+
+PACKAGES = "${PN}"
+FILES_${PN} += "${base_libdir}/firmware"
+
+PACKAGE_ARCH = "all"