aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-10-26 18:25:04 +0100
committerKoen Kooi <koen@openembedded.org>2009-10-26 18:25:04 +0100
commitced897b1749014a08b0627de84ba086afab002f8 (patch)
tree1508d176de12d4c5dc29635d22dc15dd7f487941
parent7056d05cfe6e80c6e584dab56da43b9a93474feb (diff)
downloadopenembedded-ced897b1749014a08b0627de84ba086afab002f8.tar.gz
gnome-panel: refresh idl-sysroot patch for 2.28.0
-rw-r--r--recipes/gnome/gnome-panel-2.28.0/idl-sysroot.patch22
-rw-r--r--recipes/gnome/gnome-panel_2.28.0.bb4
2 files changed, 26 insertions, 0 deletions
diff --git a/recipes/gnome/gnome-panel-2.28.0/idl-sysroot.patch b/recipes/gnome/gnome-panel-2.28.0/idl-sysroot.patch
new file mode 100644
index 0000000000..de4cd8486c
--- /dev/null
+++ b/recipes/gnome/gnome-panel-2.28.0/idl-sysroot.patch
@@ -0,0 +1,22 @@
+--- /tmp/Makefile.am 2009-10-26 16:53:20.000000000 +0100
++++ gnome-panel-2.28.0/gnome-panel/Makefile.am 2009-10-26 16:53:51.000000000 +0100
+@@ -43,7 +43,7 @@
+ $(NULL)
+
+ $(CORBA_SRCLIST): $(top_srcdir)/idl/GNOME_Panel.idl $(ORBIT_IDL)
+- $(AM_V_GEN)$(ORBIT_IDL) -I $(BONOBO_IDLDIR) -I $(BONOBO_ACT_IDLDIR) $(top_srcdir)/idl/GNOME_Panel.idl
++ $(AM_V_GEN)$(ORBIT_IDL) -I $(SYSROOT)$(BONOBO_IDLDIR) -I $(SYSROOT)$(BONOBO_ACT_IDLDIR) $(top_srcdir)/idl/GNOME_Panel.idl
+
+ BUILT_SOURCES = \
+ $(CORBA_SRCLIST) \
+--- /tmp/Makefile.am 2009-10-26 16:54:17.000000000 +0100
++++ gnome-panel-2.28.0/libpanel-applet/Makefile.am 2009-10-26 16:54:34.000000000 +0100
+@@ -45,7 +45,7 @@
+ GNOME_Panel.h
+
+ $(CORBA_SRCLIST): $(top_srcdir)/idl/GNOME_Panel.idl $(ORBIT_IDL)
+- $(AM_V_GEN)$(ORBIT_IDL) -I $(BONOBO_IDLDIR) -I $(BONOBO_ACT_IDLDIR) $(top_srcdir)/idl/GNOME_Panel.idl
++ $(AM_V_GEN)$(ORBIT_IDL) -I $(SYSROOT)$(BONOBO_IDLDIR) -I $(SYSROOT)$(BONOBO_ACT_IDLDIR) $(top_srcdir)/idl/GNOME_Panel.idl
+
+ noinst_PROGRAMS = test-bonobo-applet
+
diff --git a/recipes/gnome/gnome-panel_2.28.0.bb b/recipes/gnome/gnome-panel_2.28.0.bb
index a7bd3304e7..13f0056030 100644
--- a/recipes/gnome/gnome-panel_2.28.0.bb
+++ b/recipes/gnome/gnome-panel_2.28.0.bb
@@ -3,8 +3,12 @@ LICENSE = "GPL"
SECTION = "x11/gnome"
DEPENDS = "gconf librsvg libgweather startup-notification libwnck orbit2 gtk+ libbonoboui libglade libgnome libgnomeui gnome-desktop libglade gnome-menus orbit2-native"
+PR = "r1"
+
inherit gnome pkgconfig
+SRC_URI += "file://idl-sysroot.patch;patch=1"
+
CPPFLAGS += " -I${STAGING_INCDIR}/gnome-desktop-2.0"
export SYSROOT = "${STAGING_DIR_HOST}"