aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2009-05-17 00:41:05 +0100
committerGraeme Gregory <dp@xora.org.uk>2009-05-17 00:41:05 +0100
commit83cb9a11a2b04f954575bf4f2bc35d0d1743c393 (patch)
tree9ff1006ff17a64fb6f2e8caca1bf621b46870162
parent25c0e5fe636260f8c86c3adf22cc20ec2c4fcb77 (diff)
downloadopenembedded-83cb9a11a2b04f954575bf4f2bc35d0d1743c393.tar.gz
linux-kirkwood_2.6.29.2.bb : add CPUIDLE support so hopefully we waste
less power while idle
-rw-r--r--conf/machine/include/kirkwood.inc2
-rw-r--r--recipes/linux/linux-kirkwood/0001--ARM-Kirkwood-CPU-idle-driver.patch162
-rw-r--r--recipes/linux/linux-kirkwood/0002--ARM-Kirkwood-peripherals-clock-gating-for-power-m.patch131
-rw-r--r--recipes/linux/linux-kirkwood/defconfig6
-rw-r--r--recipes/linux/linux-kirkwood_2.6.29.2.bb2
5 files changed, 300 insertions, 3 deletions
diff --git a/conf/machine/include/kirkwood.inc b/conf/machine/include/kirkwood.inc
index 3f0b8003f5..9e6f130c35 100644
--- a/conf/machine/include/kirkwood.inc
+++ b/conf/machine/include/kirkwood.inc
@@ -11,7 +11,7 @@ USE_DEVFS = "0"
PREFERRED_PROVIDER_virtual/bootloader = ""
PREFERRED_PROVIDER_virtual/kernel = "linux-kirkwood"
-MACHINE_KERNEL_PR = "r4"
+MACHINE_KERNEL_PR = "r5"
IMAGE_FSTYPES += "tar.gz ubi"
SERIAL_CONSOLE = "ttyS0 115200"
diff --git a/recipes/linux/linux-kirkwood/0001--ARM-Kirkwood-CPU-idle-driver.patch b/recipes/linux/linux-kirkwood/0001--ARM-Kirkwood-CPU-idle-driver.patch
new file mode 100644
index 0000000000..29e7851c7f
--- /dev/null
+++ b/recipes/linux/linux-kirkwood/0001--ARM-Kirkwood-CPU-idle-driver.patch
@@ -0,0 +1,162 @@
+From 286f96f0b2e1ee5a124effba59a01f8d4bf69ddf Mon Sep 17 00:00:00 2001
+From: Rabeeh Khoury <rabeeh@marvell.com>
+Date: Tue, 24 Mar 2009 16:10:15 +0200
+Subject: [PATCH] [ARM] Kirkwood: CPU idle driver
+
+The patch adds support for Kirkwood cpu idle.
+Two idle states are defined:
+1. Wait-for-interrupt (replacing default kirkwood wfi)
+2. Wait-for-interrupt and DDR self refresh
+
+Signed-off-by: Rabeeh Khoury <rabeeh@marvell.com>
+Signed-off-by: Nicolas Pitre <nico@marvell.com>
+---
+ arch/arm/configs/kirkwood_defconfig | 4 +-
+ arch/arm/mach-kirkwood/Makefile | 2 +
+ arch/arm/mach-kirkwood/cpuidle.c | 96 ++++++++++++++++++++++++
+ arch/arm/mach-kirkwood/include/mach/kirkwood.h | 1 +
+ 4 files changed, 102 insertions(+), 1 deletions(-)
+ create mode 100644 arch/arm/mach-kirkwood/cpuidle.c
+
+diff --git a/arch/arm/configs/kirkwood_defconfig b/arch/arm/configs/kirkwood_defconfig
+index c367ae4..a99b3eb 100644
+--- a/arch/arm/configs/kirkwood_defconfig
++++ b/arch/arm/configs/kirkwood_defconfig
+@@ -263,7 +263,9 @@ CONFIG_CMDLINE=""
+ #
+ # CPU Power Management
+ #
+-# CONFIG_CPU_IDLE is not set
++CONFIG_CPU_IDLE=y
++CONFIG_CPU_IDLE_GOV_LADDER=y
++CONFIG_CPU_IDLE_GOV_MENU=y
+
+ #
+ # Floating point emulation
+diff --git a/arch/arm/mach-kirkwood/Makefile b/arch/arm/mach-kirkwood/Makefile
+index 8f03c9b..f21f35d 100644
+--- a/arch/arm/mach-kirkwood/Makefile
++++ b/arch/arm/mach-kirkwood/Makefile
+@@ -5,3 +5,5 @@ obj-$(CONFIG_MACH_RD88F6192_NAS) += rd88f6192-nas-setup.o
+ obj-$(CONFIG_MACH_RD88F6281) += rd88f6281-setup.o
+ obj-$(CONFIG_MACH_SHEEVAPLUG) += sheevaplug-setup.o
+ obj-$(CONFIG_MACH_TS219) += ts219-setup.o
++
++obj-$(CONFIG_CPU_IDLE) += cpuidle.o
+diff --git a/arch/arm/mach-kirkwood/cpuidle.c b/arch/arm/mach-kirkwood/cpuidle.c
+new file mode 100644
+index 0000000..43052c7
+--- /dev/null
++++ b/arch/arm/mach-kirkwood/cpuidle.c
+@@ -0,0 +1,96 @@
++/*
++ * arch/arm/mach-kirkwood/cpuidle.c
++ *
++ * CPU idle Marvell Kirkwood SoCs
++ *
++ * This file is licensed under the terms of the GNU General Public
++ * License version 2. This program is licensed "as is" without any
++ * warranty of any kind, whether express or implied.
++ *
++ * The cpu idle uses wait-for-interrupt and DDR self refresh in order
++ * to implement two idle states -
++ * #1 wait-for-interrupt
++ * #2 wait-for-interrupt and DDR self refresh
++ */
++
++#include <linux/kernel.h>
++#include <linux/init.h>
++#include <linux/platform_device.h>
++#include <linux/cpuidle.h>
++#include <asm/io.h>
++#include <asm/proc-fns.h>
++#include <mach/kirkwood.h>
++
++#define KIRKWOOD_MAX_STATES 2
++
++static struct cpuidle_driver kirkwood_idle_driver = {
++ .name = "kirkwood_idle",
++ .owner = THIS_MODULE,
++};
++
++static DEFINE_PER_CPU(struct cpuidle_device, kirkwood_cpuidle_device);
++
++/* Actual code that puts the SoC in different idle states */
++static int kirkwood_enter_idle(struct cpuidle_device *dev,
++ struct cpuidle_state *state)
++{
++ struct timeval before, after;
++ int idle_time;
++
++ local_irq_disable();
++ do_gettimeofday(&before);
++ if (state == &dev->states[0])
++ /* Wait for interrupt state */
++ cpu_do_idle();
++ else if (state == &dev->states[1]) {
++ /*
++ * Following write will put DDR in self refresh.
++ * Note that we have 256 cycles before DDR puts it
++ * self in self-refresh, so the wait-for-interrupt
++ * call afterwards won't get the DDR from self refresh
++ * mode.
++ */
++ writel(0x7, DDR_OPERATION_BASE);
++ cpu_do_idle();
++ }
++ do_gettimeofday(&after);
++ local_irq_enable();
++ idle_time = (after.tv_sec - before.tv_sec) * USEC_PER_SEC +
++ (after.tv_usec - before.tv_usec);
++ return idle_time;
++}
++
++/* Initialize CPU idle by registering the idle states */
++static int kirkwood_init_cpuidle(void)
++{
++ struct cpuidle_device *device;
++
++ cpuidle_register_driver(&kirkwood_idle_driver);
++
++ device = &per_cpu(kirkwood_cpuidle_device, smp_processor_id());
++ device->state_count = KIRKWOOD_MAX_STATES;
++
++ /* Wait for interrupt state */
++ device->states[0].enter = kirkwood_enter_idle;
++ device->states[0].exit_latency = 1;
++ device->states[0].target_residency = 10000;
++ device->states[0].flags = CPUIDLE_FLAG_TIME_VALID;
++ strcpy(device->states[0].name, "WFI");
++ strcpy(device->states[0].desc, "Wait for interrupt");
++
++ /* Wait for interrupt and DDR self refresh state */
++ device->states[1].enter = kirkwood_enter_idle;
++ device->states[1].exit_latency = 10;
++ device->states[1].target_residency = 10000;
++ device->states[1].flags = CPUIDLE_FLAG_TIME_VALID;
++ strcpy(device->states[1].name, "DDR SR");
++ strcpy(device->states[1].desc, "WFI and DDR Self Refresh");
++
++ if (cpuidle_register_device(device)) {
++ printk(KERN_ERR "kirkwood_init_cpuidle: Failed registering\n");
++ return -EIO;
++ }
++ return 0;
++}
++
++device_initcall(kirkwood_init_cpuidle);
+diff --git a/arch/arm/mach-kirkwood/include/mach/kirkwood.h b/arch/arm/mach-kirkwood/include/mach/kirkwood.h
+index 38c9868..e9ae73d 100644
+--- a/arch/arm/mach-kirkwood/include/mach/kirkwood.h
++++ b/arch/arm/mach-kirkwood/include/mach/kirkwood.h
+@@ -86,6 +86,7 @@
+ */
+ #define DDR_VIRT_BASE (KIRKWOOD_REGS_VIRT_BASE | 0x00000)
+ #define DDR_WINDOW_CPU_BASE (DDR_VIRT_BASE | 0x1500)
++#define DDR_OPERATION_BASE (DDR_VIRT_BASE | 0x1418)
+
+ #define DEV_BUS_PHYS_BASE (KIRKWOOD_REGS_PHYS_BASE | 0x10000)
+ #define DEV_BUS_VIRT_BASE (KIRKWOOD_REGS_VIRT_BASE | 0x10000)
+--
+1.6.0.4
+
diff --git a/recipes/linux/linux-kirkwood/0002--ARM-Kirkwood-peripherals-clock-gating-for-power-m.patch b/recipes/linux/linux-kirkwood/0002--ARM-Kirkwood-peripherals-clock-gating-for-power-m.patch
new file mode 100644
index 0000000000..b1c7f7ce00
--- /dev/null
+++ b/recipes/linux/linux-kirkwood/0002--ARM-Kirkwood-peripherals-clock-gating-for-power-m.patch
@@ -0,0 +1,131 @@
+From 17589962c1787310e6373478a9fcb7641184cd91 Mon Sep 17 00:00:00 2001
+From: Rabeeh Khoury <rabeeh@marvell.com>
+Date: Sun, 22 Mar 2009 17:30:32 +0200
+Subject: [PATCH] [ARM] Kirkwood: peripherals clock gating for power management
+
+1. Enabling clock gating of unused peripherals
+2. PLL and PHY of the units are also disabled (when possible.
+
+Signed-off-by: Rabeeh Khoury <rabeeh@marvell.com>
+
+[ This needs to be revisited to make power handling dynamic and
+ per device. -- Nico ]
+---
+ arch/arm/mach-kirkwood/common.c | 32 ++++++++++++++++++++++++
+ arch/arm/mach-kirkwood/common.h | 1 +
+ arch/arm/mach-kirkwood/include/mach/kirkwood.h | 23 +++++++++++++++++
+ arch/arm/mach-kirkwood/sheevaplug-setup.c | 2 +
+ 4 files changed, 58 insertions(+), 0 deletions(-)
+
+Index: git/arch/arm/mach-kirkwood/common.c
+===================================================================
+--- git.orig/arch/arm/mach-kirkwood/common.c
++++ git/arch/arm/mach-kirkwood/common.c
+@@ -779,6 +779,38 @@ static void __init kirkwood_l2_init(void
+ #endif
+ }
+
++void __init kirkwood_clock_gate(u32 reg)
++{
++ printk(KERN_INFO "Kirkwood: Gating clock using mask 0x%x\n", reg);
++ /* First make sure that the units are accessible */
++ writel(readl(CLOCK_GATING_CTRL) | reg, CLOCK_GATING_CTRL);
++ /* For SATA first shutdown the phy */
++ if (reg & CGC_SATA0) {
++ /* Disable PLL and IVREF */
++ writel(readl(SATA0_PHY_MODE_2) & ~0xf, SATA0_PHY_MODE_2);
++ /* Disable PHY */
++ writel(readl(SATA0_IF_CTRL) | 0x200, SATA0_IF_CTRL);
++ }
++ if (reg & CGC_SATA1) {
++ /* Disable PLL and IVREF */
++ writel(readl(SATA1_PHY_MODE_2) & ~0xf, SATA1_PHY_MODE_2);
++ /* Disable PHY */
++ writel(readl(SATA1_IF_CTRL) | 0x200, SATA1_IF_CTRL);
++ }
++ /* For PCI-E first shutdown the phy */
++ if (reg & CGC_PEX0) {
++ writel(readl(PCIE_LINK_CTRL) | 0x10, PCIE_LINK_CTRL);
++ while (1) {
++ if (readl(PCIE_STATUS) & 0x1)
++ break;
++ }
++ writel(readl(PCIE_LINK_CTRL) & ~0x10, PCIE_LINK_CTRL);
++ }
++ /* Now gate clock the required units */
++ writel(readl(CLOCK_GATING_CTRL) & ~reg, CLOCK_GATING_CTRL);
++ return;
++}
++
+ void __init kirkwood_init(void)
+ {
+ printk(KERN_INFO "Kirkwood: %s, TCLK=%d.\n",
+Index: git/arch/arm/mach-kirkwood/common.h
+===================================================================
+--- git.orig/arch/arm/mach-kirkwood/common.h
++++ git/arch/arm/mach-kirkwood/common.h
+@@ -22,6 +22,7 @@ struct mvsdio_platform_data;
+ void kirkwood_map_io(void);
+ void kirkwood_init(void);
+ void kirkwood_init_irq(void);
++void __init kirkwood_clock_gate(u32 reg);
+
+ extern struct mbus_dram_target_info kirkwood_mbus_dram_info;
+ void kirkwood_setup_cpu_mbus(void);
+Index: git/arch/arm/mach-kirkwood/include/mach/kirkwood.h
+===================================================================
+--- git.orig/arch/arm/mach-kirkwood/include/mach/kirkwood.h
++++ git/arch/arm/mach-kirkwood/include/mach/kirkwood.h
+@@ -65,6 +65,8 @@
+ #define BRIDGE_VIRT_BASE (KIRKWOOD_REGS_VIRT_BASE | 0x20000)
+
+ #define PCIE_VIRT_BASE (KIRKWOOD_REGS_VIRT_BASE | 0x40000)
++#define PCIE_LINK_CTRL (PCIE_VIRT_BASE | 0x70)
++#define PCIE_STATUS (PCIE_VIRT_BASE | 0x1a04)
+
+ #define USB_PHYS_BASE (KIRKWOOD_REGS_PHYS_BASE | 0x50000)
+
+@@ -81,9 +83,30 @@
+ #define GE01_PHYS_BASE (KIRKWOOD_REGS_PHYS_BASE | 0x74000)
+
+ #define SATA_PHYS_BASE (KIRKWOOD_REGS_PHYS_BASE | 0x80000)
++#define SATA_VIRT_BASE (KIRKWOOD_REGS_VIRT_BASE | 0x80000)
++#define SATA0_IF_CTRL (SATA_VIRT_BASE | 0x2050)
++#define SATA0_PHY_MODE_2 (SATA_VIRT_BASE | 0x2330)
++#define SATA1_IF_CTRL (SATA_VIRT_BASE | 0x4050)
++#define SATA1_PHY_MODE_2 (SATA_VIRT_BASE | 0x4330)
+
+ #define SDIO_PHYS_BASE (KIRKWOOD_REGS_PHYS_BASE | 0x90000)
+
++#define CLOCK_GATING_CTRL (BRIDGE_VIRT_BASE | 0x11c)
++#define CGC_GE0 0x1
++#define CGC_PEX0 0x4
++#define CGC_USB0 0x8
++#define CGC_SDIO 0x10
++#define CGC_TSU 0x20
++#define CGC_NAND_SPI 0x80
++#define CGC_XOR0 0x100
++#define CGC_AUDIO 0x200
++#define CGC_SATA0 0x4000
++#define CGC_SATA1 0x8000
++#define CGC_XOR1 0x10000
++#define CGC_CRYPTO 0x20000
++#define CGC_GE1 0x80000
++#define CGC_TDM 0x100000
++
+ /*
+ * Supported devices and revisions.
+ */
+Index: git/arch/arm/mach-kirkwood/sheevaplug-setup.c
+===================================================================
+--- git.orig/arch/arm/mach-kirkwood/sheevaplug-setup.c
++++ git/arch/arm/mach-kirkwood/sheevaplug-setup.c
+@@ -122,6 +122,8 @@ static void __init sheevaplug_init(void)
+
+ platform_device_register(&sheevaplug_nand_flash);
+ platform_device_register(&sheevaplug_leds);
++ kirkwood_clock_gate(CGC_PEX0 | CGC_TSU | CGC_AUDIO | CGC_SATA0 |\
++ CGC_SATA1 | CGC_CRYPTO | CGC_GE1 | CGC_TDM);
+ }
+
+ MACHINE_START(SHEEVAPLUG, "Marvell SheevaPlug Reference Board")
diff --git a/recipes/linux/linux-kirkwood/defconfig b/recipes/linux/linux-kirkwood/defconfig
index 23bf5d9820..c28a803478 100644
--- a/recipes/linux/linux-kirkwood/defconfig
+++ b/recipes/linux/linux-kirkwood/defconfig
@@ -1,7 +1,7 @@
#
# Automatically generated make config: don't edit
# Linux kernel version: 2.6.29.2
-# Sat May 16 20:08:52 2009
+# Sun May 17 00:12:54 2009
#
CONFIG_ARM=y
CONFIG_SYS_SUPPORTS_APM_EMULATION=y
@@ -267,7 +267,9 @@ CONFIG_ATAGS_PROC=y
#
# CPU Power Management
#
-# CONFIG_CPU_IDLE is not set
+CONFIG_CPU_IDLE=y
+CONFIG_CPU_IDLE_GOV_LADDER=y
+CONFIG_CPU_IDLE_GOV_MENU=y
#
# Floating point emulation
diff --git a/recipes/linux/linux-kirkwood_2.6.29.2.bb b/recipes/linux/linux-kirkwood_2.6.29.2.bb
index 4dceb7601b..b3b87a632e 100644
--- a/recipes/linux/linux-kirkwood_2.6.29.2.bb
+++ b/recipes/linux/linux-kirkwood_2.6.29.2.bb
@@ -14,6 +14,8 @@ SRCREV = "10a12868405319fbf114af2bde9789aa64c34144"
SRC_URI = "git://git.marvell.com/orion.git;protocol=git;branch=stable-2.6.29 \
file://fw.patch;patch=1 \
file://mvsdio.patch;patch=1 \
+ file://0001--ARM-Kirkwood-CPU-idle-driver.patch;patch=1 \
+ file://0002--ARM-Kirkwood-peripherals-clock-gating-for-power-m.patch;patch=1 \
file://defconfig \
"