aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteve Sakoman <steve@sakoman.com>2009-10-13 19:57:29 -0700
committerKoen Kooi <koen@openembedded.org>2009-10-14 14:09:48 +0200
commitb7057abc73021352857275114d6564383a6de95e (patch)
tree23830561e05b52dd3b293505ce2b9de4d7b00030
parent38fba64100d8a820d05c1a650ad48763de502746 (diff)
downloadopenembedded-b7057abc73021352857275114d6564383a6de95e.tar.gz
gnome-panel: add 2.28.0
-rw-r--r--conf/checksums.ini4
-rw-r--r--recipes/gnome/gnome-panel_2.28.0.bb37
2 files changed, 41 insertions, 0 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index 86a3d56551..45f1d584e0 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -8946,6 +8946,10 @@ sha256=6d6d0f013594f1d5f685bc9d35ad2c64d7817339a932d8e17eede5b8a3c8196a
md5=27965de9b12952b22b7e232af6acb0de
sha256=e8e21b008d4afcebfc3241d0f91dd2dcc0b171b16f5675fc1b7ed699e79b56f3
+[http://ftp.gnome.org/pub/GNOME/sources/gnome-panel/2.28/gnome-panel-2.28.0.tar.bz2]
+md5=9f0ea283d44bbcce67dc2e8a02fe9fad
+sha256=c1168c0c8f84692002557d60870c782f4831635080d2c52cd2a3665fb7718465
+
[http://downloads.sourceforge.net/gnome-power/gnome-power-0.0.5.tar.gz]
md5=db310dadcc958a781a2752a6a7748e60
sha256=78f7dc6946e178513202f06afc19496c8ac1e3ac6c43c56c40f4db1a23762179
diff --git a/recipes/gnome/gnome-panel_2.28.0.bb b/recipes/gnome/gnome-panel_2.28.0.bb
new file mode 100644
index 0000000000..a7bd3304e7
--- /dev/null
+++ b/recipes/gnome/gnome-panel_2.28.0.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "GNOME panel"
+LICENSE = "GPL"
+SECTION = "x11/gnome"
+DEPENDS = "gconf librsvg libgweather startup-notification libwnck orbit2 gtk+ libbonoboui libglade libgnome libgnomeui gnome-desktop libglade gnome-menus orbit2-native"
+
+inherit gnome pkgconfig
+
+CPPFLAGS += " -I${STAGING_INCDIR}/gnome-desktop-2.0"
+export SYSROOT = "${STAGING_DIR_HOST}"
+
+EXTRA_OEMAKE = "ORBIT_IDL=${STAGING_BINDIR_NATIVE}/orbit-idl-2 SYSROOT=${SYSROOT}"
+EXTRA_OECONF = "--disable-scrollkeeper --disable-eds"
+
+do_configure_prepend() {
+ sed -i -e s:help:: ${S}/Makefile.am
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+pkg_postinst_append () {
+ gconftool-2 --config-source=xml:readwrite:/etc/gconf/gconf.xml.defaults \
+ --direct --load /etc/gconf/schemas/panel-default-setup.entries
+}
+
+PACKAGES =+ "libpanel-applet"
+FILES_libpanel-applet = "${libdir}/libpanel-applet-2.so.*"
+
+FILES_${PN} =+ "${datadir}/gnome* \
+ ${datadir}/dbus-1 \
+ ${datadir}/icons \
+ ${datadir}/PolicyKit \
+ ${libdir}/bonobo \
+ "
+
+