aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon Woestenberg <leon@sidebranch.com>2009-11-24 12:20:49 +0100
committerLeon Woestenberg <leon@sidebranch.com>2009-11-24 13:49:21 +0100
commit45c6c8a0f1c1696d7df57ec090791594b62afdc7 (patch)
tree4871b168b5846f1b89403339003dbffa5fa5f3ef
parent5dddf0f910b6783832ae4ca0d5c6168c2d8bf435 (diff)
downloadopenembedded-45c6c8a0f1c1696d7df57ec090791594b62afdc7.tar.gz
binutils-nios2-2.15.bb: Use target_{in,lib}dir from cross.bbclass.
Signed-off-by: Leon Woestenberg <leon@sidebranch.com>
-rw-r--r--recipes/binutils/binutils_nios2-2.15.bb38
1 files changed, 23 insertions, 15 deletions
diff --git a/recipes/binutils/binutils_nios2-2.15.bb b/recipes/binutils/binutils_nios2-2.15.bb
index 0fdf0c6359..436d33de96 100644
--- a/recipes/binutils/binutils_nios2-2.15.bb
+++ b/recipes/binutils/binutils_nios2-2.15.bb
@@ -6,10 +6,9 @@ PR = "r5"
inherit autotools gettext
-# prepend this path for files in SRC_URI
FILESPATHPKG =. "binutils-2.15.94.0.1:"
-PACKAGES = "${PN} ${PN}-dev ${PN}-doc ${PN}-symlinks"
+PACKAGES += "${PN}-symlinks"
FILES_${PN} = " \
${bindir}/${TARGET_PREFIX}* \
@@ -83,30 +82,32 @@ export LD_FOR_TARGET = "${TARGET_PREFIX}ld"
export NM_FOR_TARGET = "${TARGET_PREFIX}nm"
export RANLIB_FOR_TARGET = "${TARGET_PREFIX}ranlib"
-export CC_FOR_HOST = "${CCACHE} ${HOST_PREFIX}gcc ${HOST_CC_ARCH}"
-export CXX_FOR_HOST = "${CCACHE} ${HOST_PREFIX}gcc ${HOST_CC_ARCH}"
+export CC_FOR_HOST = "${CCACHE}${HOST_PREFIX}gcc ${HOST_CC_ARCH}"
+export CXX_FOR_HOST = "${CCACHE}${HOST_PREFIX}gcc ${HOST_CC_ARCH}"
export CC_FOR_BUILD = "${BUILD_CC}"
export CPP_FOR_BUILD = "${BUILD_CPP}"
export CFLAGS_FOR_BUILD = "${BUILD_CFLAGS}"
-export CC = "${CCACHE} ${HOST_PREFIX}gcc ${HOST_CC_ARCH}"
+export CC = "${CCACHE}${HOST_PREFIX}gcc ${HOST_CC_ARCH}"
do_configure () {
(cd ${S}; gnu-configize) || die "Failed to run gnu-configize"
oe_runconf
}
-do_stage () {
- oe_libinstall -so -a -C opcodes libopcodes ${STAGING_LIBDIR}/
- oe_libinstall -a -C libiberty libiberty ${STAGING_LIBDIR}/
- oe_libinstall -so -a -C bfd libbfd ${STAGING_LIBDIR}/
- install -m 0644 ${S}/include/dis-asm.h ${STAGING_INCDIR}/
- install -m 0644 ${S}/include/symcat.h ${STAGING_INCDIR}/
- install -m 0644 ${S}/include/libiberty.h ${STAGING_INCDIR}/
- install -m 0644 ${S}/include/ansidecl.h ${STAGING_INCDIR}/
- install -m 0644 ${S}/include/bfdlink.h ${STAGING_INCDIR}/
- install -m 0644 bfd/bfd.h ${STAGING_INCDIR}/
+do_stage_append () {
+ oe_libinstall -a -C opcodes libopcodes ${target_libdir}/
+ oe_libinstall -a -C libiberty libiberty ${target_libdir}/
+ oe_libinstall -a -C bfd libbfd ${target_libdir}/
+ install -d ${target_includedir}
+ install -m 0644 ${S}/include/ansidecl.h ${target_includedir}/
+ install -m 0644 ${S}/include/libiberty.h ${target_includedir}
+
+ install -m 0644 ${S}/include/dis-asm.h ${target_includedir}
+ install -m 0644 ${S}/include/symcat.h ${target_includedir}
+ install -m 0644 ${S}/include/bfdlink.h ${target_includedir}
+ install -m 0644 bfd/bfd.h ${target_includedir}
}
do_install () {
@@ -128,6 +129,13 @@ do_install () {
install -m 644 ${S}/include/ansidecl.h ${D}${includedir}
install -m 644 ${S}/include/libiberty.h ${D}${includedir}
+ install -m 644 ${S}/include/dis-asm.h ${D}${includedir}
+ install -m 644 ${S}/include/symcat.h ${D}${includedir}
+ install -m 644 ${S}/include/libiberty.h ${D}${includedir}
+ install -m 644 ${S}/include/ansidecl.h ${D}${includedir}
+ install -m 644 ${S}/include/bfdlink.h ${D}${includedir}
+ install -m 644 bfd/bfd.h ${D}${includedir}
+
cd ${D}${bindir}
# Symlinks for ease of running these on the native target