aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteve Sakoman <steve@sakoman.com>2009-10-13 16:42:24 -0700
committerKoen Kooi <koen@openembedded.org>2009-10-14 14:09:29 +0200
commit7d118bb0789b1ac196cd1a6b9b58278cd34b15f3 (patch)
tree12a9b6b5e4be1b93d06d70b30842f2c5b0873555
parentcdf28da4dbf84716fbf7b9d54f1d94ac977c013c (diff)
downloadopenembedded-7d118bb0789b1ac196cd1a6b9b58278cd34b15f3.tar.gz
gnome-media: add 2.28.0
-rw-r--r--conf/checksums.ini4
-rw-r--r--recipes/gnome/gnome-media_2.28.0.bb30
2 files changed, 34 insertions, 0 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index f228f0564b..0e8adf46cb 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -8854,6 +8854,10 @@ sha256=1b3234f1feac6a619a9a61a0b5f67ab8cd89d94aeeec9a5cc2d78b81d9d8cab4
md5=3d519bc7d812aed8f6e4288b6d3cdf26
sha256=39e7646d0790e05a010da1eb2d7552dcb5311abd72f001477c9c465d7146b9f7
+[http://ftp.gnome.org/pub/GNOME/sources/gnome-media/2.28/gnome-media-2.28.0.tar.bz2]
+md5=1a1dc2638012d47f67c0ccac9e3ac719
+sha256=f715947e42f166c4dba1caeb36f897018d638fcd8031fbc2f077e0cd1d6a1a55
+
[http://ftp.gnome.org/pub/GNOME/sources/gnome-menus/2.10/gnome-menus-2.10.2.tar.bz2]
md5=97b0ad03ea219cc8f5c02585db1d237e
sha256=0968a399590d94cf9e1640b647cc10f972a3a802cbd9602c0839f56fd2864193
diff --git a/recipes/gnome/gnome-media_2.28.0.bb b/recipes/gnome/gnome-media_2.28.0.bb
new file mode 100644
index 0000000000..5426aec651
--- /dev/null
+++ b/recipes/gnome/gnome-media_2.28.0.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "GNOME Media Tools"
+LICENSE = "GPL"
+SECTION = "x11/gnome"
+DEPENDS = "gconf glib-2.0 gstreamer gst-plugins-base gtk+ gdk-pixbuf-csource-native libcanberra libglade libgnomeui libunique libxml2"
+# optional for volume control:
+DEPENDS += "pulseaudio"
+# optional for gnome-cd and cddbslave (deprecated, needs --enable-gnomecd separate package for gnome-cd and cddb-slave2):
+#DEPENDS += "nautilus-cd-burner"
+inherit gnome
+
+EXTRA_OECONF = "--disable-static --disable-gtk-doc --disable-scrollkeeper"
+
+# FIXME: Native doc processing with xsltproc using docbook needs additional work:
+do_configure_prepend() {
+ sed -i 's/^\(SUBDIRS = .*\)\(doc\|help\)/\1/' */Makefile.am
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+do_install_append() {
+ rm ${D}${libdir}/libglade/2.0/libgnome-media-profiles.la
+}
+
+FILES_${PN} += "${libdir}/libglade/2.0/libgnome-media-profiles.so \
+ ${datadir}/gstreamer-properties \
+ ${datadir}/gnome-sound-recorder"
+
+FILES_${PN}-dbg += "${libdir}/libglade/2.0/.debug"