aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Boor <florian.boor@kernelconcepts.de>2012-01-01 16:49:41 +0100
committerFlorian Boor <florian.boor@kernelconcepts.de>2012-09-27 18:06:56 +0200
commit6059c64e49fdda23c9fa59630e8522c56e145ff1 (patch)
treeaa6806b6461cad3be49a83120f4afc4e17ef9004
parent9ecf1f9fa8c60dd47b4a4970f8fa88ef73cac769 (diff)
downloadopenembedded-6059c64e49fdda23c9fa59630e8522c56e145ff1.tar.gz
flac: Apply patch and configuration option to disable Altivec support
Required on ppce300c3 which does not have support for it. It defaults to be on and does not seem to be disabled correctly on PPC platforms without Altivec. Signed-off-by: Florian Boor <florian.boor@kernelconcepts.de>
-rw-r--r--recipes/flac/files/no-altivec.patch18
-rw-r--r--recipes/flac/flac.inc6
-rw-r--r--recipes/flac/flac_1.2.1.bb3
3 files changed, 25 insertions, 2 deletions
diff --git a/recipes/flac/files/no-altivec.patch b/recipes/flac/files/no-altivec.patch
new file mode 100644
index 0000000000..dc2dc0a5d9
--- /dev/null
+++ b/recipes/flac/files/no-altivec.patch
@@ -0,0 +1,18 @@
+--- a/src/libFLAC/Makefile.am 2011-02-04 10:53:28.715634068 +0100
++++ b/src/libFLAC/Makefile.am 2011-02-04 10:55:45.838299710 +0100
+@@ -36,12 +36,13 @@
+ # The -force_cpusubtype_ALL is needed to insert a ppc64 instruction
+ # into cpu.c with an asm().
+ if FLaC__SYS_DARWIN
+-#@@@ PPC optimizations temporarily disabled
++# @@@ PPC optimizations temporarily disabled
+ CPUCFLAGS = -faltivec -force_cpusubtype_ALL -DFLAC__NO_ASM
+ else
+ # Linux-gcc for PPC does not have -force_cpusubtype_ALL, it is Darwin-specific
+ #@@@ PPC optimizations temporarily disabled
+-CPUCFLAGS = -maltivec -mabi=altivec -DFLAC__NO_ASM
++#CPUCFLAGS = -maltivec -mabi=altivec -DFLAC__NO_ASM
++CPUCFLAGS = -DFLAC__NO_ASM
+ endif
+ endif
+
diff --git a/recipes/flac/flac.inc b/recipes/flac/flac.inc
index 2b35d641e4..6ba2d45859 100644
--- a/recipes/flac/flac.inc
+++ b/recipes/flac/flac.inc
@@ -7,7 +7,7 @@ DEPENDS = "libogg"
SRC_URI = "${SOURCEFORGE_MIRROR}/flac/flac-${PV}.tar.gz \
file://xmms.m4"
-INC_PR = "r2"
+INC_PR = "r3"
inherit autotools gettext
@@ -21,6 +21,10 @@ EXTRA_OECONF = "--disable-oggtest --disable-id3libtest \
--without-id3lib \
"
+# Not supported by this platform but defaults to be on for PowerPC
+EXTRA_OECONF_append_ppce300c3 = " --disable-altivec"
+
+
do_configure () {
install -d ${S}/m4
install -m 0644 ${WORKDIR}/xmms.m4 ${S}/m4/
diff --git a/recipes/flac/flac_1.2.1.bb b/recipes/flac/flac_1.2.1.bb
index 9628352c53..c2e0f50f52 100644
--- a/recipes/flac/flac_1.2.1.bb
+++ b/recipes/flac/flac_1.2.1.bb
@@ -4,7 +4,8 @@ PR = "${INC_PR}.2"
# fixes from openSUSE:
SRC_URI += "file://flac-gcc43-fixes.diff;striplevel=0 \
- file://flac-printf-format-fix.diff;striplevel=0"
+ file://flac-printf-format-fix.diff;striplevel=0 \
+ file://no-altivec.patch"
SRC_URI[md5sum] = "153c8b15a54da428d1f0fadc756c22c7"
SRC_URI[sha256sum] = "9635a44bceb478bbf2ee8a785cf6986fba525afb5fad1fd4bba73cf71f2d3edf"