aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2007-02-06 07:38:17 +0000
committerRod Whitby <rod@whitby.id.au>2007-02-06 07:38:17 +0000
commit493255c0ada70a916c0cd8604ac40a7011ba728f (patch)
treeb2498068252e8bf5c6f583c31ecfbf6ddb6a68b6
parent811260be4d7df7424f1827410116378929d50da3 (diff)
parentd0a0461f3a8b58803e4637a8991501c9c8565e14 (diff)
downloadopenembedded-493255c0ada70a916c0cd8604ac40a7011ba728f.tar.gz
merge of '1322f90b18589872dfe43f3e8fb8fafff1f58e20'
and '1e9ea5837bfd496b91787865dfdb897abb24e773'
-rw-r--r--conf/distro/include/angstrom.inc1
-rw-r--r--packages/arm-kernel-shim/arm-kernel-shim_1.2.bb (renamed from packages/arm-kernel-shim/arm-kernel-shim_1.4.11.bb)13
-rw-r--r--packages/arm-kernel-shim/files/config-dsmg600.h2
-rw-r--r--packages/arm-kernel-shim/files/config-fsg3.h2
-rw-r--r--packages/arm-kernel-shim/files/config-nas100d.h6
-rw-r--r--packages/arm-kernel-shim/files/config-nslu2.h6
-rw-r--r--packages/linux/ixp4xx-kernel.inc32
-rw-r--r--packages/linux/ixp4xx-kernel/2.6.19/series5
-rw-r--r--packages/linux/ixp4xx-kernel/2.6.20/series5
-rw-r--r--packages/linux/ixp4xx-kernel_2.6.19.bb13
-rw-r--r--packages/linux/ixp4xx-kernel_2.6.20.bb13
11 files changed, 41 insertions, 57 deletions
diff --git a/conf/distro/include/angstrom.inc b/conf/distro/include/angstrom.inc
index c057d1a05e..79ec27af72 100644
--- a/conf/distro/include/angstrom.inc
+++ b/conf/distro/include/angstrom.inc
@@ -50,3 +50,4 @@ DISTRO_CHECK := "${@bb.data.getVar("DISTRO_VERSION",d,1) or bb.fatal('Remove thi
# We want images supporting the following features (for task-base)
DISTRO_FEATURES = "nfs smbfs wifi ppp alsa bluetooth ext2 irda pcmcia usbgadget usbhost pci"
+DISTRO_FEATURES_nslu2le = "nfs smbfs alsa bluetooth ext2 usbhost pci"
diff --git a/packages/arm-kernel-shim/arm-kernel-shim_1.4.11.bb b/packages/arm-kernel-shim/arm-kernel-shim_1.2.bb
index e994e13814..aa7c7cd64c 100644
--- a/packages/arm-kernel-shim/arm-kernel-shim_1.4.11.bb
+++ b/packages/arm-kernel-shim/arm-kernel-shim_1.2.bb
@@ -3,20 +3,23 @@ SECTION = ""
PRIORITY = "optional"
HOMEPAGE = "http://wiki.buici.com/twiki/bin/view/Main/ApexBootloader"
LICENSE = "GPL"
-PR = "r2"
+PR = "r1"
-SRC_URI = "ftp://ftp.buici.com/pub/apex/apex-${PV}.tar.gz \
- file://disable-commandline.patch;patch=1 \
+COMPATIBLE_MACHINE = "(ixp4xx|nslu2)"
+
+SRC_URI = "ftp://ftp.buici.com/pub/arm/arm-kernel-shim/arm-kernel-shim-${PV}.tar.gz \
+ file://place-boot-section.patch;patch=1 \
file://config-nslu2.h \
file://config-nas100d.h \
file://config-dsmg600.h \
file://config-fsg3.h"
-S = ${WORKDIR}/apex-${PV}/arm-kernel-shim
+S = ${WORKDIR}/arm-kernel-shim-${PV}
EXTRA_OEMAKE_append = " CROSS_COMPILE=${CROSS_DIR}/bin/${HOST_PREFIX}"
oe_runmake() {
+ mv ${S}/config.h ${S}/config.h.orig
# NSLU2
cp ${WORKDIR}/config-nslu2.h ${S}/config.h
rm -f ${S}/main.o
@@ -37,11 +40,11 @@ oe_runmake() {
rm -f ${S}/main.o
oenote make ${PARALLEL_MAKE} TOOLS=${CROSS_DIR}/bin/${TARGET_PREFIX} PACKAGE=arm-kernel-shim-fsg3
make ${PARALLEL_MAKE} TOOLS=${CROSS_DIR}/bin/${TARGET_PREFIX} PACKAGE=arm-kernel-shim-fsg3 || die "oe_runmake failed"
+ mv ${S}/config.h.orig ${S}/config.h
}
do_populate_staging() {
install -d ${STAGING_LOADER_DIR}
- . ${CONFIG_SITE}
cp ${S}/arm-kernel-shim-nslu2.bin ${STAGING_LOADER_DIR}/
cp ${S}/arm-kernel-shim-nas100d.bin ${STAGING_LOADER_DIR}/
cp ${S}/arm-kernel-shim-dsmg600.bin ${STAGING_LOADER_DIR}/
diff --git a/packages/arm-kernel-shim/files/config-dsmg600.h b/packages/arm-kernel-shim/files/config-dsmg600.h
index b0f37b3e3b..cd331159e0 100644
--- a/packages/arm-kernel-shim/files/config-dsmg600.h
+++ b/packages/arm-kernel-shim/files/config-dsmg600.h
@@ -14,7 +14,7 @@
#if !defined (__CONFIG_H__)
# define __CONFIG_H__
-#define PHYS_PARAMS 0xc0000100 /* Address for the parameter list */
+#define PHYS_PARAMS 0x00000100 /* Address for the parameter list */
#define RAM_BANK0_START 0x00000000
#define RAM_BANK0_LENGTH 0x04000000
diff --git a/packages/arm-kernel-shim/files/config-fsg3.h b/packages/arm-kernel-shim/files/config-fsg3.h
index 1222d959c2..e2cdf8abd4 100644
--- a/packages/arm-kernel-shim/files/config-fsg3.h
+++ b/packages/arm-kernel-shim/files/config-fsg3.h
@@ -14,7 +14,7 @@
#if !defined (__CONFIG_H__)
# define __CONFIG_H__
-#define PHYS_PARAMS 0xc0000100 /* Address for the parameter list */
+#define PHYS_PARAMS 0x00000100 /* Address for the parameter list */
#define RAM_BANK0_START 0x00000000
#define RAM_BANK0_LENGTH 0x04000000
diff --git a/packages/arm-kernel-shim/files/config-nas100d.h b/packages/arm-kernel-shim/files/config-nas100d.h
index 5f148a666a..4389644cf0 100644
--- a/packages/arm-kernel-shim/files/config-nas100d.h
+++ b/packages/arm-kernel-shim/files/config-nas100d.h
@@ -14,7 +14,7 @@
#if !defined (__CONFIG_H__)
# define __CONFIG_H__
-#define PHYS_PARAMS 0xc0000100 /* Address for the parameter list */
+#define PHYS_PARAMS 0x00000100 /* Address for the parameter list */
#define RAM_BANK0_START 0x00000000
#define RAM_BANK0_LENGTH 0x04000000
@@ -22,8 +22,8 @@
//#define RAM_BANK1_START 0xd0000000
//#define RAM_BANK1_LENGTH 0x10000000
-//#define COMMANDLINE\
-// "console=ttyAMA0 root=/dev/memblk0 rootfstype=jffs"
+#define COMMANDLINE\
+ "init=/linuxrc root=/dev/mtdblock2 rootfstype=jffs rw noirqdebug console=ttyS0,115200n8"
#define MACH_TYPE 865
diff --git a/packages/arm-kernel-shim/files/config-nslu2.h b/packages/arm-kernel-shim/files/config-nslu2.h
index 7547061165..2262b57668 100644
--- a/packages/arm-kernel-shim/files/config-nslu2.h
+++ b/packages/arm-kernel-shim/files/config-nslu2.h
@@ -14,7 +14,7 @@
#if !defined (__CONFIG_H__)
# define __CONFIG_H__
-#define PHYS_PARAMS 0xc0000100 /* Address for the parameter list */
+#define PHYS_PARAMS 0x00000100 /* Address for the parameter list */
#define RAM_BANK0_START 0x00000000
#define RAM_BANK0_LENGTH 0x02000000
@@ -22,8 +22,8 @@
//#define RAM_BANK1_START 0xd0000000
//#define RAM_BANK1_LENGTH 0x10000000
-//#define COMMANDLINE\
-// "console=ttyAMA0 root=/dev/memblk0 rootfstype=jffs"
+#define COMMANDLINE\
+ "init=/linuxrc root=/dev/mtdblock4 rootfstype=jffs rw noirqdebug console=ttyS0,115200n8"
#define MACH_TYPE 597
diff --git a/packages/linux/ixp4xx-kernel.inc b/packages/linux/ixp4xx-kernel.inc
index 3a80703420..d2cb649437 100644
--- a/packages/linux/ixp4xx-kernel.inc
+++ b/packages/linux/ixp4xx-kernel.inc
@@ -26,6 +26,8 @@ SECTION = "kernel"
DESCRIPTION = "Linux kernel for the Intel IXP4xx device"
LICENSE = "GPL"
+DEPENDS += "arm-kernel-shim"
+
# Linux kernel source has the general form linux-X.Y.Z-patchP,
# X.Y is the major version number, Z (which may have multiple
# parts) is a sub-version and 'patch' is something like 'mm' or
@@ -316,18 +318,20 @@ pkg_postrm_kernel () {
# copy the zImage and append the appropriate shim
# dest: where to copy to
# cmdline: command line to pass to image
-# machine-id: decimal machine id to prepend, empty for none
+# machine: machine shim to prepend, empty for none
copy_image() {
- local setmach
+ local shim
- setmach=""
- test -n "$2" && setmach="wb $2 . 256/ 255& 0xe3a01c00+, 4; wb 255& 0xe3811000+, 4;"
+ shim="/dev/null"
+ test -n "$2" && shim="${STAGING_LOADER_DIR}/arm-kernel-shim-$2.bin"
- rm -f "$1".new
- devio '<<${KERNEL_OUTPUT}' >"$1".new "$setmach"'${FIXUP}' || {
+ rm -f "$1".new "$1".shim
+ cat $shim ${KERNEL_OUTPUT} > "$1".shim
+ devio '<<'"$1"'.shim' >"$1".new '${FIXUP}' || {
echo 'ERROR: ${KERNEL_OUTPUT}: failed to copy zImage' >&2
return 1
}
+ rm -f "$1".shim
mv "$1".new "$1"
}
@@ -342,10 +346,10 @@ do_install_append() {
install_image '${MACHINE_ARCH}'
# Add the machine specific images, with appropriate suffixes
- install_image 'nslu2${SITEINFO_ENDIANESS}' '${nslu2_MACHID}'
- install_image 'nas100d${SITEINFO_ENDIANESS}' '${nas100d_MACHID}'
- install_image 'dsmg600${SITEINFO_ENDIANESS}' '${dsmg600_MACHID}'
- install_image 'fsg3${SITEINFO_ENDIANESS}' '${fsg3_MACHID}'
+ install_image 'nslu2${SITEINFO_ENDIANESS}' 'nslu2'
+ install_image 'nas100d${SITEINFO_ENDIANESS}' 'nas100d'
+ install_image 'dsmg600${SITEINFO_ENDIANESS}' 'dsmg600'
+ install_image 'fsg3${SITEINFO_ENDIANESS}' 'fsg3'
}
do_deploy[dirs] = "${S}"
@@ -359,10 +363,10 @@ do_deploy() {
deploy_image '${MACHINE_ARCH}'
# And the machine specific images
- deploy_image 'nslu2${SITEINFO_ENDIANESS}' '${nslu2_MACHID}'
- deploy_image 'nas100d${SITEINFO_ENDIANESS}' '${nas100d_MACHID}'
- deploy_image 'dsmg600${SITEINFO_ENDIANESS}' '${dsmg600_MACHID}'
- deploy_image 'fsg3${SITEINFO_ENDIANESS}' '${fsg3_MACHID}'
+ deploy_image 'nslu2${SITEINFO_ENDIANESS}' 'nslu2'
+ deploy_image 'nas100d${SITEINFO_ENDIANESS}' 'nas100d'
+ deploy_image 'dsmg600${SITEINFO_ENDIANESS}' 'dsmg600'
+ deploy_image 'fsg3${SITEINFO_ENDIANESS}' 'fsg3'
}
addtask deploy before do_build after do_compile
diff --git a/packages/linux/ixp4xx-kernel/2.6.19/series b/packages/linux/ixp4xx-kernel/2.6.19/series
index ec0e7a81c5..df62b582e7 100644
--- a/packages/linux/ixp4xx-kernel/2.6.19/series
+++ b/packages/linux/ixp4xx-kernel/2.6.19/series
@@ -39,8 +39,9 @@ squashfs/squashfs-Makefile.patch
86-nas100d-rtc-fixup.patch
87-dsmg600-rtc-fixup.patch
88-dsmg600-dflt-cmdline.patch
-88-nas100d-dflt-cmdline.patch
-88-nslu2-dflt-cmdline.patch
+# These are now done via arm-kernel-shim
+#88-nas100d-dflt-cmdline.patch
+#88-nslu2-dflt-cmdline.patch
95-pata-ixp4xx.patch
96-fsg3-support.patch
97-avila-setup-pata.patch
diff --git a/packages/linux/ixp4xx-kernel/2.6.20/series b/packages/linux/ixp4xx-kernel/2.6.20/series
index f362b614b4..d98b4ba58f 100644
--- a/packages/linux/ixp4xx-kernel/2.6.20/series
+++ b/packages/linux/ixp4xx-kernel/2.6.20/series
@@ -35,8 +35,9 @@ squashfs/squashfs-Makefile.patch
86-nas100d-rtc-fixup.patch
87-dsmg600-rtc-fixup.patch
88-dsmg600-dflt-cmdline.patch
-88-nas100d-dflt-cmdline.patch
-88-nslu2-dflt-cmdline.patch
+# These are now done via arm-kernel-shim
+#88-nas100d-dflt-cmdline.patch
+#88-nslu2-dflt-cmdline.patch
96-fsg3-support.patch
98-sata_via-pata-support-upstream.patch
99-avila-mtd-microcode.patch
diff --git a/packages/linux/ixp4xx-kernel_2.6.19.bb b/packages/linux/ixp4xx-kernel_2.6.19.bb
index 6841c93d00..915e241f75 100644
--- a/packages/linux/ixp4xx-kernel_2.6.19.bb
+++ b/packages/linux/ixp4xx-kernel_2.6.19.bb
@@ -23,16 +23,3 @@ require ixp4xx-kernel-svnpatch.inc
SRC_URI += "file://defconfig"
SRC_URI += "file://series"
-
-# Remove the specific cmdline hacking patches if we are not building for nslu2.
-addtask remove_cmdline_hacks before do_patch after do_unpack
-do_remove_cmdline_hacks() {
-
-# if [ "${MACHINE}" != "nslu2" ] ; then
- sed -e '/88-nas100d-dflt-cmdline.patch/d' \
- -e '/88-nslu2-dflt-cmdline.patch/d' \
- '${WORKDIR}/series' > '${WORKDIR}/series.new'
- mv '${WORKDIR}/series.new' '${WORKDIR}/series'
-# fi
-
-}
diff --git a/packages/linux/ixp4xx-kernel_2.6.20.bb b/packages/linux/ixp4xx-kernel_2.6.20.bb
index 0cc6b387f7..304866c555 100644
--- a/packages/linux/ixp4xx-kernel_2.6.20.bb
+++ b/packages/linux/ixp4xx-kernel_2.6.20.bb
@@ -23,16 +23,3 @@ require ixp4xx-kernel-svnpatch.inc
SRC_URI += "file://defconfig"
SRC_URI += "file://series"
-
-# Remove the specific cmdline hacking patches if we are not building for nslu2.
-addtask remove_cmdline_hacks before do_patch after do_unpack
-do_remove_cmdline_hacks() {
-
- if [ "${MACHINE}" != "nslu2" ] ; then
- sed -e '/88-nas100d-dflt-cmdline.patch/d' \
- -e '/88-nslu2-dflt-cmdline.patch/d' \
- '${WORKDIR}/series' > '${WORKDIR}/series.new'
- mv '${WORKDIR}/series.new' '${WORKDIR}/series'
- fi
-
-}