aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2007-08-23 08:27:18 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2007-08-23 08:27:18 +0000
commit0f600231b5e6028cde94417ae7e4dc27a12d362e (patch)
tree6d3a672ab84da1a15ec7279a00fd8a6767442bca
parentb6d6e400005ee9a12a5c859609e3cb609c0d8dea (diff)
downloadopenembedded-0f600231b5e6028cde94417ae7e4dc27a12d362e.tar.gz
python-openmoko: make it build on amd64
-rw-r--r--packages/python/python-openmoko/.mtn2git_empty0
-rw-r--r--packages/python/python-openmoko/python-path.patch21
-rw-r--r--packages/python/python-openmoko_0.1.bb8
3 files changed, 26 insertions, 3 deletions
diff --git a/packages/python/python-openmoko/.mtn2git_empty b/packages/python/python-openmoko/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/python/python-openmoko/.mtn2git_empty
diff --git a/packages/python/python-openmoko/python-path.patch b/packages/python/python-openmoko/python-path.patch
new file mode 100644
index 0000000000..f43260cd0e
--- /dev/null
+++ b/packages/python/python-openmoko/python-path.patch
@@ -0,0 +1,21 @@
+--- python.orig/m4/python.m4
++++ python/m4/python.m4
+@@ -43,12 +43,18 @@
+ [AC_REQUIRE([AM_PATH_PYTHON])
+ AC_MSG_CHECKING(for headers required to compile python extensions)
+ dnl deduce PYTHON_INCLUDES
++AC_ARG_WITH(python-includes,
++ [ --with-python-includes=DIR path to Python includes], py_exec_prefix=$withval)
++if test x$py_exec_prefix != x; then
++PYTHON_INCLUDES="-I${py_exec_prefix}/include/python${PYTHON_VERSION}"
++else
+ py_prefix=`$PYTHON -c "import sys; print sys.prefix"`
+ py_exec_prefix=`$PYTHON -c "import sys; print sys.exec_prefix"`
+ PYTHON_INCLUDES="-I${py_prefix}/include/python${PYTHON_VERSION}"
+ if test "$py_prefix" != "$py_exec_prefix"; then
+ PYTHON_INCLUDES="$PYTHON_INCLUDES -I${py_exec_prefix}/include/python${PYTHON_VERSION}"
+ fi
++fi
+ AC_SUBST(PYTHON_INCLUDES)
+ dnl check if the headers exist:
+ save_CPPFLAGS="$CPPFLAGS"
diff --git a/packages/python/python-openmoko_0.1.bb b/packages/python/python-openmoko_0.1.bb
index 343a79aa03..e193f0f2de 100644
--- a/packages/python/python-openmoko_0.1.bb
+++ b/packages/python/python-openmoko_0.1.bb
@@ -3,11 +3,13 @@ AUTHOR = "Holger 'Zecke' Freyther"
LICENSE = "LGPL"
DEPENDS = "python-pygtk libmokoui2 libmokojournal2 libmokogsmd2"
SECTION = "devel/python"
+PR = "r1"
+
+SRC_URI = "svn://svn.projects.openmoko.org/svnroot/bindings;module=python;proto=http \
+ file://python-path.patch;patch=1"
-SRC_URI = "svn://svn.projects.openmoko.org/svnroot/bindings;module=python;proto=http"
S = "${WORKDIR}/python"
inherit autotools distutils-base
-
-
+EXTRA_OECONF += "--with-python-includes=${STAGING_INCDIR}/../"