aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Busch <morphis@amethyst.openembedded.net>2010-12-19 20:06:08 +0100
committerSimon Busch <morphis@gravedo.de>2011-01-04 11:41:52 +0100
commit12b9367140e6a394c9e32b451f7ed626d9037a43 (patch)
tree763161a3547ef9efe74db74e3397e3966d2dae56
parent5e75168f83c99df22f34222d76b666c64b89734a (diff)
downloadopenembedded-12b9367140e6a394c9e32b451f7ed626d9037a43.tar.gz
read_tokens: add initscript to read tokens on boot
Signed-off-by: Simon Busch <morphis@amethyst.openembedded.net>
-rw-r--r--recipes/palmpre/read-tokens/read_tokens6
-rw-r--r--recipes/palmpre/read-tokens_git.bb18
2 files changed, 21 insertions, 3 deletions
diff --git a/recipes/palmpre/read-tokens/read_tokens b/recipes/palmpre/read-tokens/read_tokens
new file mode 100644
index 0000000000..5997226695
--- /dev/null
+++ b/recipes/palmpre/read-tokens/read_tokens
@@ -0,0 +1,6 @@
+
+#!/bin/sh
+
+if [ ! -e /etc/tokens ] ; then
+ /usr/bin/read_tokens > /etc/tokens
+fi
diff --git a/recipes/palmpre/read-tokens_git.bb b/recipes/palmpre/read-tokens_git.bb
index d958438b32..178163b6f3 100644
--- a/recipes/palmpre/read-tokens_git.bb
+++ b/recipes/palmpre/read-tokens_git.bb
@@ -3,13 +3,25 @@ HOMEPAGE = "http://www.freesmartphone.org"
AUTHOR = "Simon Busch <morphis@gravedo.de>
SECTION = "console/utils"
LICENSE = "GPL"
-PR = "r0"
+PR = "r1"
PV = "1.0.0+gitr${SRCPV}"
SRCREV = "93a640dafa8ebebdb1a03f051cb1b566629b227c"
-SRC_URI = "${FREESMARTPHONE_GIT}/utilities.git;protocol=git;branch=master"
+SRC_URI = " \
+ ${FREESMARTPHONE_GIT}/utilities.git;protocol=git;branch=master \
+ file://read_tokens \
+"
S = "${WORKDIR}/git/palmpre/read_tokens"
PACKAGE_ARCH = "${MACHINE_ARCH}"
-inherit autotools
+inherit autotools update-rc.d
+
+INITSCRIPT_NAME = "read_tokens"
+INITSCRIPT_PARAMS = "defaults 23"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/init.d/
+ install -m 0755 ${WORKDIR}/read_tokens ${D}${sysconfdir}/init.d/
+}
+