aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeremy Laine <jeremy.laine@m4x.org>2008-04-21 08:20:28 +0000
committerJeremy Laine <jeremy.laine@m4x.org>2008-04-21 08:20:28 +0000
commit89511d0970a5d93663076d8a5e6e97d722e3be5c (patch)
tree4942e2a8129553a5706690b02000995800050454
parent7e263956d2b6c222f1a105fbfa2eb8abdcc14237 (diff)
downloadopenembedded-89511d0970a5d93663076d8a5e6e97d722e3be5c.tar.gz
glibc_2.6.1.bb: fix powerpc/soft-float builds
* fixes errors message stating fe_nomask.o cannot be built * see http://sources.redhat.com/ml/libc-ports/2007-06/msg00005.html
-rw-r--r--packages/glibc/files/glibc-2.6.1-powerpc-nofpu.patch11
-rw-r--r--packages/glibc/glibc_2.6.1.bb5
2 files changed, 15 insertions, 1 deletions
diff --git a/packages/glibc/files/glibc-2.6.1-powerpc-nofpu.patch b/packages/glibc/files/glibc-2.6.1-powerpc-nofpu.patch
new file mode 100644
index 0000000000..893c754628
--- /dev/null
+++ b/packages/glibc/files/glibc-2.6.1-powerpc-nofpu.patch
@@ -0,0 +1,11 @@
+--- dummy-libc/ports/sysdeps/powerpc/nofpu/Makefile 2006-11-22 09:13:11.000000000 -0600
++++ libc25/ports/sysdeps/powerpc/nofpu/Makefile 2007-06-07 09:53:05.708240976 -0500
+@@ -6,7 +6,7 @@
+ endif
+
+ ifeq ($(subdir),math)
+-libm-support += fenv_const fe_nomask
++libm-support += fenv_const
+ CPPFLAGS += -I../soft-fp/
+ # The follow CFLAGS are a work around for GCC Bugzilla Bug 29253
+ # "expand_abs wrong default code for floating point"
diff --git a/packages/glibc/glibc_2.6.1.bb b/packages/glibc/glibc_2.6.1.bb
index 0cbdef8dcb..e44e6bea14 100644
--- a/packages/glibc/glibc_2.6.1.bb
+++ b/packages/glibc/glibc_2.6.1.bb
@@ -63,7 +63,10 @@ SRC_URI_append_sh3 = " file://no-z-defs.patch;patch=1"
SRC_URI_append_sh4 = " file://no-z-defs.patch;patch=1"
# PowerPC Patches to add support for soft-float
-SRC_URI_append_powerpc = "file://powerpc-sqrt-hack.diff;patch=1"
+SRC_URI_append_powerpc = "\
+ file://powerpc-sqrt-hack.diff;patch=1 \
+ file://glibc-2.6.1-powerpc-nofpu.patch;patch=1 \
+"
S = "${WORKDIR}/glibc-${PV}"
B = "${WORKDIR}/build-${TARGET_SYS}"